Videostreaming

Informationen zur neuen Foren-Software hier
Bei Login Problemen bitte ein neues Kennwort anfordern (nur alle 24 Stunden). Neuen Aktivierungscode anfordern oder Registrierung mit Aktivierungscode abschließen
Ansonsten Email an webmaster[äet]forum-raspberrypi.de
  • Hallo Freunde der Himbeere,

    meine HW: Raspi3B

    BS: Raspbian Jessie 4.9.35 V7

    Browser: Firefox 52.4.0.ESR 32 Bit und Chrome Vers. ? über LAN


    Problem:

    Ich bekomme sowohl von Netflix als auch Amazons Prime kein Vidostream mit Firefox und Chrome zum Laufen.

    Bei beiden Browsern hängt sich Netflex einfach auf, Prime wirft die Fehlermeldung "In Ihrem Browser fehlte eine DRM Komponente (Widevinecdm). Bitte aktivieren" und einen FC aus.

    Bei der Firefox Vers. 52 ESR soll ja NAPI noch vorhanden sein, sicherheitshalber habe in der Firefox Config den Booleanwert "plugin.load_flash_only = false" eingetragen, und das Paket "GNU-Shockwave Fash Player Plugin for Mozilla nachinstalliert (ob es gebraucht wird, weiß ich allerdings nicht), ohne Erfolge. Der Versuch, "apt-get install flashplugin-nonfree" schlug mit "nicht für dieses BS o.Ä", fehl.

    Hier im Forum wurden schon ähnliche Fragen gestellt, habe aber dort und I-Net nichts gefunden, was mir weiter hilft.

    Ich habe das Ganze mal unter Windoofs mit Firefox 56.01 64Bit probiert, läuft. Dabei ist mir aufgefallen, dass ich unter FF "Einstellungen --> Suchen --> drm" die Anzeige "Inhalte mit DRM-Kopierschutz wiedergeben" bekomme, wo ich das Häckchen setzten oder heraus nehmen kann. Beim Firefox ESR fehlt dieser Dialog völlig.
    Was ich nicht verstehe: Beide Anbieter haben auf HTML5 umgestellt, so dass eigentlich keine NAPI Plugins mehr nötig sein sollen, Firefox 52 ESR enthält diese angeblich und trotzdem weist Amazon auf die fehlende DRM hin.

    Hat jemand eine Idee, wie ich die Streams zum Laufen bekomme?

    Mit freundlichen Grüßen

  • Das Problem hatte ich gestern auch.


    Probier mal folgendes:


    1. Chromium installieren

    Shell-Script
    1. wget https://github.com/kusti8/chromium-build/releases/download/netflix-1.0.0/chromium-browser_56.0.2924.84-0ubuntu0.14.04.1.1011.deb
    2. sudo dpkg -i chromium-browser_56.0.2924.84-0ubuntu0.14.04.1.1011.deb

    2. UserAgent Faker installieren

    Danach installier die mal diese Chrome Extension


    3. Eigene UserAgent erstellen

    In den Optionen des UserAgent Faker brauchen wir einen neuen UserAgent, um Netflix "Vorzutäuschen" dass wir ChromeOS nutzen:


    Name: Netflix

    UserAgent String: Mozilla/5.0 (X11; CrOS armv7l 6946.63.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.106 Safari/537.36

    Group: Chrome

    Append: Replace

    Indicator Flag: IE


    4. UserAgent aktivieren

    Klicke oben rechts auf den UA Faker und dann auf "Netflix"


    5. Es sollte klappen


    So hat es zumindest bei mir gestern geklappt!


    - toasty

  • Hallo Dunkles Toast,

    herzlichen Dank für deinen Tipp, leider ohne Erfolg. Meine vorhandene Chrome Version lautet "56.0.2924.84 Build on Ubuntu 14.04 running on Raspian 8.0", von der Version her die gleiche. Deshalb habe ich Chrome nicht noch einmal installiert, liegt darin das Problem? Denn unter den Chrome Erweiterungen fehlt der Punkt "geschützte Inhalte wiedergeben", genau das gleiche Problem hat ja auch die instalierte Firefox Version. Den User Agent Switcher habe ich hinzu gefügt, 2 neue Agenten nach deiner Anweisung hinzugefügt, sie "Netflix" & "Amazon Prime" genannt und aktiviert.

    Allerdings ist mir als Linux Laie unklar, weshalb man dem Browser ein Chrome OS vorgaukeln muss und wie der dann erkennt, dass er die Inhalte von Netflix bzw. Prime wiedergeben soll, denn es sind ja keinerlei Links (URL) oder ähnliches in den Agenten hinterlegt.

    Ich habe den Eindruck, ohne in die nutzlose FDebatte pro/contra Linux/Win zu verfallen, dass Linux sich generell mit Multimedia äußert schwer tut, denn die Nutzung der Mediathek View der öffentlichen TV Sender via VLC habe ich auch nur mit geduldiger Hilfe von meigrafd hinbekommen und bis heute läuft der Linux VLC nur im Vollbildmodus, also kaum zu gebrauchen, aber das nur nebenbei.

    Wenn ich den Chrome aus deiner Quelle installiere, muss ich dann vorher den vorhandenen deinstallieren (Kmd wär hilfreich)?

    Mit freundlichen Grüßen

    raspihotte

  • Zitat

    Moin,

    Allerdings ist mir als Linux Laie unklar, weshalb man dem Browser ein Chrome OS vorgaukeln muss und wie der dann erkennt, dass er die Inhalte von Netflix bzw. Prime wiedergeben soll,


    das liegt nicht am Betriebssytem sondern an Netflix


    Zitat

    Netflix filtert Namen weiterer Linux-Distributionen

    Das heißt, dass Netflix explizit den Namen der Linux-Distribution Fedora im User-Agent filtert und den Dienst für deren Nutzer versagt. Das Verhalten konnte Golem.de nachstellen. Darüber hinaus werden Nutzer unserem kurzen Test zufolge ebenfalls blockiert, wenn die Zeichenketten openSUSE, Debian oder CentOS im User-Agent vorkommen. Der Name Ubuntu wird hingegen nicht blockiert.

    Besonders irritierend daran ist, dass es für diese Art des Filterns keinerlei technische Begründung gibt, da der Dienst ohne die Namen der Distributionen im User-Agent eben fehlerfrei genutzt werden kann.

    Quelle:

    https://www.golem.de/news/vide…onen-aus-1704-127254.html



    Edit: hatte den Nachtrag vom April übersehen:


    Zitat

    Es wird aber nur Fedora erwähnt, was mit den anderen BS steht dort nicht