HIFIberry miniAmp aktivieren

Ein neuer Artikel wurde veröffentlicht
  • Hallo,


    ich habe auf einem RPI3 einen HIFIBerry MiniAmp aufgesteckt und möchte den nun aktivieren.

    Wie schalte ich das interne Audio ab und aktiviere den HIFIBerry MiniAmp ?

    Als Image verwende ich das aktuelle Raspbian Stretch mit Desktop.


    Gruß Frank

  • Moin DL3AD,


    ein Tip. Es gibt ein README in /boot/overlays. Dort mal nach hifiberry suchen.


    Ansonsten eine Suchmaschine. die Eingabe vonHIFIBerry MiniAmp und der 3te Eintrag war die Lösung.

    Hier die Seite.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein "Like"

  • Moin DL3AD,


    ich wollte mal nachfragen, ob mein Beitrag hilfreich war? Weil du das Thema als erledigt markiert hast.


    Als Helfender ist es immer rech schön, wenn man eine Rückantwort bekommt. Egal ob negativ oder positiv.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein "Like"

  • Uhh löck, ist das Ding geil!


    Ich habe den Hifiberry MiniAmp nur gekauft, weil ich für die Kids eine Art tragbaren Mediaplayer basteln will. Da reichen auf alle Fälle mickrige 3W Musikleistung! Ich habe das Ding zunächst an folgenden Minilautsprechern von reichelt getestet, die ich für den Einbau ins Gehäuse vorgesehen habe. Mir war klar, dass das klanglich nix Besonderes sein wird, zumal im fliegenden Versuchsaufbau ohne Resonanzkörper.


    Aber immerhin:

    Die Audioausgabe trotz nur 3W Ausgangsleistung (wenn überhaupt, da 8R-Lautsprecher) ist ganz schön laut! (Auch klar: Das menschliche Lautstärkeempfinden steigt logarithmisch an. Zur gefühlten Verdoppelung der Lautstärke bedarf es etwa der zehnfachen Leistung...)


    Trotz allem wollte ich dann den MiniAmp mit gescheiten Lautsprechern testen und ich fiel fast aus den Socken!

    Wenn's auch nur ein Class-D-Verstärker ist, der MiniAmp bringt wirklich guten Klang auch leicht oberhalb der sogenannten Zimmerlautstärke:lol:



    Bild 1:

    RPi2 mit S-USV und MiniAmp (Versuchsaufbau)



    Bild 2:
    Die geplanten Einbaulautsprecher (da bin ich mir mittlerweile nicht mehr sicher:neutral:)



    Bild 3:

    relativ fette Lautsprecher, mit denen ich schon so manche Party beschallt habe



    Das 12V-Netzteil ist schon richtig, ich habe eine S-USV dazwischen...

  • Ich bin seit diesem Thema auch in Versuchung

    Hi Bernd,

    bei einer passenden Zielanwendung machst Du mit dem MiniAmp definitiv nichts falsch!


    Ich weiß zwar noch nicht genau, wie man ihn unter ALSA (Raspbian Stretch) richtig einbindet, so dass auch der ALSA-Lautstärkeregler funktioniert, die Anleitungen auf der Hifiberry-Seite funktionierten bei mir auf die Schnelle nicht (Achtung: Linux-Noob). Meine Tests liefen stattdessen mit dem omxplayer, der neuerdings auch eine Audioausgabe über ALSA ermöglicht:

    Code
    1. omxplayer -o alsa <mediafile>

    Bei Start des omxplayers über die Konsole kann man mit den Tasten + und - die Lautstärke in dB steuern. Da muss man in Verbindung mit dem MiniAmp aber recht schnell sein, um nicht selbst oder die anderen Familienmitglieder im Hause unnötig zu erschrecken :)

    wie gesagt: 0 dB entspricht "gehobener Zimmerlautstärke"8o

  • ... habe das ding noch nicht ans laufen bekommen.

    Ohne das Modul über Klinke bekomme ich sound raus - getestet mit aplay ud einem File auf der Console

    Mit Modul und Änderung in der Config.txt - dtoverlay=hifiberry-dac hinzugefügt - dann reboot und getestet nix


    Gruß Frank

  • Moin DL3AD,


    was sagt den die Ausgabe voncat /proc/asound/cards? Taucht da das neue Device auf?

    Wenn ja, den alsamixer aufrufen, mit F6 wird eine Auswahl der vorhandenen Geräte gezeigt. Das richtige Gerät wählen und testen


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein "Like"

  • Einbinden des HiFiBerry MiniAmp für Lautstärkeregelung über ALSA

    Ich habe jetzt herausgefunden wie's geht :)

    Ich weiß zwar noch nicht genau, wie man ihn unter ALSA (Raspbian Stretch) richtig einbindet, so dass auch der ALSA-Lautstärkeregler funktioniert, die Anleitungen auf der Hifiberry-Seite funktionierten bei mir auf die Schnelle nicht (Achtung: Linux-Noob).


    Ich bin schrittweise nach den beiden folgenden Anleitungen auf der HiFiBerry-Homepage vorgegangen:

    1. HiFiBerry-Anleitung Configuring Linux 4.x or higher

    2. HiFiBerry-Anleitung Adding software volume control


    /etc/asound.conf

    /boot/config.txt



    Letzlich muss man in der /boot/config.txt folgende Anpassung vornehmen:

    Zeile 2: Auskommentieren bzw. Entfernen des Eintrages für das onboard-Soundmodul (Klinke und HDMI):

    Zeile 3: Stattdessen "Device Tree Overlay File" für MiniAmp laden

    Code
    1. # Enable audio (loads snd_bcm2835)
    2. ####dtparam=audio=on
    3. dtoverlay=hifiberry-dac

    und meine /etc/asound.conf sieht folgendermaßen aus:


    Dass diese Anleitung bei mir zuerst nicht funktioniert hat, lag wohl wieder mal an meiner chronischen Linux-Noobhaftigkeit, verbunden mit Copy-Paste-Fehlern und Ähnlichem:stumm:

    Jedenfalls habe ich jetzt die brachialen 3W vom MiniAmp unter meiner Kontrolle :lol:

    Selbst bei Verwendung des hardwarenahen omxplayers funktioniert die externe ALSA-Lautstärkeregelung :cool:

    3735929054 = 0xDEADC0DE

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von schlizbäda () aus folgendem Grund: Tippfehler beseitigt

  • Detaillierte Anleitung:

    Ganz so einfach wie oben beschrieben ist es leider auch nicht. Es hakt im Detail :fies:


    Ich habe bemerkt, dass die obigen Dateieinstellungen für /boot/config.txt und /etc/asound.conf an sich zwar richtig sind. Allerdings befindet sich im Homeverzeichnis nach geänderten Einstellungen in /etc/asound.conf immer wieder die unsichtbare Datei .asoundrc, die vor gewünschten Anpassungen vor einem reboot gelöscht werden muss, damit die neuen Änderungen greifen!

    Um ein jungfräuliches Raspbian-Stretch-Image 2017-09-07-raspbian-stretch.img anzupassen, sind folgende Schritte notwendig


    1. raspi-config durchführen:
    $ sudo raspi-config

    Die notwendigen Starteinstellungen über folgenden Menüpunkte vornehmen:

    1. Change User Password

    4.I1. Change Locale

    4.I2. Change Timezone

    4.I3. Change Keyboard Layout

    4.I4. Change Wi-fi Country

    5.P2. SSH


    2. apt-get aktualisieren (dauert jeweils ein paar Minuten!):

    $ sudo apt-get update

    $ sudo apt-get dist-upgrade


    3. ALSA für MiniAmp konfigurieren:

    Die beiden Konfigurationsdateien /boot/config.txt und /etc/asound.conf wie in Beitrag #9 anpassen:

    $ sudo nano /boot/config.txt

    $ sudo nano /etc/asound.conf



    Wichtig dabei: Prüfen, dass die unsichtbare Datei .asoundrc nicht im Homeverzeichnis von pi liegt!

    $ ls -la ~

    $ rm ~/.asoundrc

    $ reboot

    Nur so wird diese Datei mit den gewünschten Inhalten neu erstellt!


    4. Letzte ALSA-Einstellungen von MiniAmp:

    Nach dem Reboot ist der grafische ALSA-Lautstärkeregler in der Raspbian-PIXEL-Startleiste deaktiviert, da ALSA offenbar noch nicht vollständig aktiviert wurde. Fragt den Dauernoob nicht warum:denker:

    $ aplay -l

    Die Ausgabe muss etwas in dieser Art liefern:

    **** Liste der Hardware-Geräte (PLAYBACK) ****

    Karte 0: sndrpihifiberry [snd_rpi_hifiberry_dac], Gerät 0: HifiBerry DAC HiFi pcm5102a-hifi-0 []

    Sub-Geräte: 1/1

    Sub-Gerät #0: subdevice #0


    $ speaker-test -D hifiberryMiniAmp -c 2

    Es wird ein Rosa Rauschen in maximaler Lautstärke ausgegeben. Bei guten Lautsprechern aufgrund der wahnsinnigen 3W laut, aber zum Aushalten...

    Mit ^C in der Konsole abbrechen.


    $ alsamixer

    Anzeige des in /etc/asound.conf definierten Reglers "Master" im Konsolenfenster. Mit den Tasten Cursor-Up und Cursor-Down ist eine Regelung möglich und ich empfehle eine Einstellung von 20-30%. Mit ESC den alsamixer beenden.


    5. Erste Tests von MiniAmp über ALSA:

    Damit jetzt auch die Einstellungen aus Punkt 4 übernommen werden, ist ein erneuter Reboot erforderlich

    Wichtig dabei: Auch jetzt wieder prüfen, dass die unsichtbare Datei .asoundrc nicht im Homeverzeichnis von pi liegt! Gegebenenfalls erneut löschen. Diese Datei stört offenbar eher als sie nützt. Fragt auch jetzt den Dauernoob nicht warum:denker:

    $ ls -la ~

    $ rm ~/.asoundrc

    $ reboot
    Nach dem Bootvorgang ist jetzt jetzt auch der grafische ALSA-Regler in der Startleiste von Raspbian-PIXEL wieder aktiv!

    Selbst die Audioausgabe des omxplayers läuft jetzt über ALSA und seine Lautstärkeregelung:

    $ omxplayer -o alsa "01 Saga - Wind Him Up.wav"


    6. Kaputtmachen mit KsCD (und ein paar Kommentare "off topic"):

    Eigentlich möchte ich zu Weihnachten für meinen Sohn (7 Jahre) einen aufgemotzten CD-Spieler mit RPi bauen. Klar, die normalen CD-Player für 50,--€ aus dem Geschäft sehen schöner(?) aus, als mein DIY-Einbau in einem ausrangierten bopla-Industriegehäuse aus der Arbeit mit externem DVD-Brenner "LG GP50NW40" und RPi 3 samt offiziellem 7"-RaspiDisplay.

    Aber vielleicht wird ihm der Eigenbau trotzdem besser gefallen, als der gekaufte 0815-CD-Player, weil der RPi-Player möglicherweise irgendwie cool ist. Auf jeden Fall kann man den immer wieder altersgerecht aufmotzen :lol:

    Das Schönste wäre, wenn die Buben (7, 5 und 2 Jahre) das dann rechtzeitig als vernünftige(?) Alternative zu dem ganzen Android-ipad-Tablet-Rotz :baeh2: erkennen würden. Beim großen (16 Jahre) ist dieser Zug abgefahren...


    Jedenfalls gefiel mir für den Buam die Oberfläche von KsCD zunächst ganz gut.

    Also mit $ sudo apt-get install kscd auf den RPi gespielt und die Lautstärkeregelung funktioniert nur über den Regler, der in der GUI von KsCD integriert ist und nicht über den ALSA-Regler aus der Startleiste. Das Blöde: Auch bei allen anderen Programmen funktioniert der ALSA-Regler nicht mehr! Er lässt sich zwar noch bedienen, bleibt aber wirkungslos.

    Die (für mich) schnellste Art es wieder wie gewünscht zum Laufen zu bringen, sind die Schritte 1-5 durchzuführen :bravo2:


    :auslachen:Die Suche nach einem passenden kindgerechten Software-CD-Player geht weiter...

    Der omxplayer mag ja keine Audio-CDs direkt vom Laufwerk spielen und deshalb fällt auch mein yamuplay aus! :no_sad: 


    schlizbäda

    3735929054 = 0xDEADC0DE

    Dieser Beitrag wurde bereits 4 Mal editiert, zuletzt von schlizbäda () aus folgendem Grund: Rechtschreib-, Grammatik- und Formatfehler beseitigt