Raspberry nur kurz nach Start oder nach Ping(RPi -> PC) über Putty erreichbar

  • Hallo zusammen,


    mein Raspberry Pi 2 lief seit mehreren Wochen ohne Probleme 24/7, erreichbar durch einen Edimax WLAN USB Stick nur im eigenen Netzwerk.

    Vor 2 Tagen war er dann auf einmal nicht mehr über Putty erreichbar und auch die Website die er hostet auch nicht(Flask), war jedoch weiterhin im WLAN Netz.


    Zuerst Neustart etc versucht, dann alles abgesteckt bis auf den WLAN Stick

    und neues Image auf einer anderen Micro SD installiert, eingerichtet wie immer.

    (Energiesparmodus vom Edimax ist über die 8192cu.conf Datei deaktiviert)


    Er ist wieder ganz normal im WLAN, aber nicht direkt erreichbar durch Putty am PC.

    Mir ist aber zufällig aufgefallen, dass ich mich über Putty anmelden kann sobald ich vom Pi einen Ping Versuch zu meinem PC starte.

    Manchmal schlägt der erste fehl, die weiteren gehen dann durch.


    WLAN Konfiguration am Pi ist minimalistisch gehalten, lediglich SSID/PSK.

    Habe es über die alte Weise durch /etc/network/interfaces versucht, aber auch über wpa_supplicant oder direkt in der dhcpcd.conf Datei.

    Immer das selbe Ergebnis:

    - Pi ist im Netzwerk

    - nicht erreichbar, außer nach anpingen des PCs


    Was könnte ich noch versuchen?

  • Immer das selbe Ergebnis:

    - Pi ist im Netzwerk

    - nicht erreichbar, außer nach anpingen des PCs


    Was könnte ich noch versuchen?

    Schau mal nach, ob sich der PI vor dem Ping und nach dem Ping, im arp-cache deines PCs befindet.

    Code
    arp -av
    ip n s

    (oder gleichwertig, je nach OS auf dem PC).

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Moin Korikatzo,


    wenn du am Raspberry nichts gemacht hast, dann sollte der Fehler wo anders liegen.

    Simple Frage: Hast du mal deinen Wlan-Router resetet??


    Gruss Bernd


    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Edit: Und plötzlich scheint es zu funktionieren (mit vorsichtigem Optimismus)....

    Hab den Router nochmals neugestartet (eig gestern und vorgestern Abend auch schon)

    und bin auf etwas mit ARP Cache leeren gestoßen, das hab ich mal gemacht und nun funzt es wohl wieder... Wobei ich nicht genau verstehe weshalb...^^


    Edited 2 times, last by Korikatzo ().

  • Moin Korikatzo,


    Danke! Werde ich bei mir auch mal testen.


    Wenn dein Thema erledigt ist, dann setze, bitte, den Erledigt-Harken.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Ok, muss mich korrigieren...

    Läuft leider immer noch nicht so richtig..

    Pi ist wieder im Wlan, jedoch nicht anpingbar usw. Steht auch im ARP Cache als ungültig.

    Sollte eigentlich nicht am Rechner selbst liegen, da vom Handy aus und vom anderen Rechner aus das gleiche Verhalten ist...

  • Pi ist wieder im Wlan, jedoch nicht anpingbar usw. Steht auch im ARP Cache als ungültig.

    Versuch mal als Test in der geeigneten crontab deines PIs, mit einem "gezielten" arping (alle 3 Minuten) zum Router und mit einem "nicht angeforderten/kostenlosen" arping (alle 2 Minuten) in das Subnetz deines Routers.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Welchen Befehl brauch ich für die arpings?

    Z. B.:

    Code
    sudo apt-get install iputils-arping
    Code
    */3 *    * * * root /usr/bin/arping -q -c 3 -w 10 -b -f -I wlan0 -s <IP-PI> <IP-Router> > /dev/null 2>&1
    */2 *    * * *    root /usr/bin/arping -q -c 2 -A -I wlan0 -s <IP-PI> 255.255.255.255 > /dev/null 2>&1
    Code
    sudo tcpdump -vvveni wlan0 arp

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Okay, ich behaupte mal vorsichtig es läuft nun...

    Habe zum testen immer die micro sd aus dem pi und in meinen zweiten, da der andere fest verbaut ist usw... Mit dem USB Wifi stick vom Test pi lief es dann, USB Sticks getauscht, jetzt ist der pi seit etwa 18h erreichbar..

    Scheint also als ob der Wifi Stick eine Macke hat.