Raspbian Stretch lite - MPD - Autostart

  • Hallo,


    ich benutze das Raspbian Stretch Lite Image.


    MPD ist bereits installiert und läuft auch.


    Jetzt möchte ich den Autostart festlegen und habe folgendes gemacht:


    Code
    1. nano /home/pi/radio.sh


    Dort habe ich folgendes eingegeben:


    Shell-Script
    1. #!/bin/sh
    2. sudo /etc/init.d/mpd start
    3. mpc volume 85
    4. mpc load radiosender
    5. mpc play


    Nach dem Speichern habe ich die Datei ausführbar gemacht:


    Code
    1. chmod a+x /home/pi/radio.sh


    Der Befehl ./radio.sh startet das Radio.


    Dann habe ich den Autostart versucht zu definieren:


    Code
    1. crontab -e


    Folgende Zeile habe ich am Ende hinzugefügt:


    Code
    1. @reboot /home/pi/radio.sh


    Nach einem Neustart passiert jetzt leider nichts. Habe ich etwas falsch gemacht oder liegt es an der neuen Version "Stretch"?

  • Hallo chrissi1,


    von der Sache her ist das garnicht nötig. Der Dämon sollte auch so automatisch straten, nachdem Du einmalig sudo /etc/init.d/mpd start bzw. nach dem bearbeiten der /etc/mpd.conf  sudo /etc/init.d/mpd restart gemacht hast. Die Playlist und die Lautstärke brauchst Du auch nicht extra angeben, das sollte automatisch bleiben, wenn es so in der mpd.conf eingetragen wurde.

  • Ok, ich werde das Morgen mal testen.


    Aber wo und wie kann ich denn einstellen, das die Lautstärke bei einem Neustart auf z.B. 85 Prozent eingestellt wird?


    Wenn ich nämlich die Lautstärke auf 100 habe, dann möchte ich bei einem Neustart nicht die volle Lautstärke haben.


    Des weiteren soll der Pi täglich um 4:30 Uhr einen Neustart machen.


    Wie bekomme ich das dann ohne den Autostart / Skript hin?

  • Stimmt, die Lautstärke bleibt so, wie sie war bevor der RPi ausgeschaltet wurde.

    Des weiteren soll der Pi täglich um 4:30 Uhr einen Neustart machen.

    Dafür gibt es einige Möglichkeiten, u.a. könntest Du einen Cronjob einrichten und die Lautstärke auch gleich mit einbinden. ;)

  • Des weiteren soll der Pi täglich um 4:30 Uhr einen Neustart machen.

    Warum? Welchen driftigen Grund gibt es denn dafür. "Sinnlose" Neustarts sind eine der Hauptursachen für Probleme

    Der Unterschied zwischen Genie und Wahnsinn definiert sich im Erfolg.

  • Wie müsste ich dann genau vorgehen, wenn ich einen Cronjob anlegen möchte, der die Lautstärke zurücksetzt und den Pi um 4:30 Uhr neustarten lässt?


    Und genau, bei der Zwangstrennung durch den Provider hat der Pi bei mir am nächsten Morgen kein Internet mehr, deswegen der Neustart.

  • Mit sudo crontab -e öffnest Du die Crontab von root. Unter den letzten Eintrag fügst Du folgende Zeile ein: 30 4 * * * mpc volume 85; reboot Das bedeutet: (Minute / Stunde * * * Lautstärke einstellen; Neustart).

    Achte darauf, dass am Ende der Tabelle eine Leerzeile ist und speichern nicht vergessen.

  • Ok, wenn ich heute Abend zu Hause bin, dann teste ich das Ganze.


    Nach dem automatischen Neustart startet der Player dann automatisch mit dem 1. Sender aus der Playlist???

  • Hallo chrissi1,


    von der Sache her ist das garnicht nötig. Der Dämon sollte auch so automatisch straten, nachdem Du einmalig sudo /etc/init.d/mpd start bzw. nach dem bearbeiten der /etc/mpd.conf sudo /etc/init.d/mpd restart gemacht hast. Die Playlist und die Lautstärke brauchst Du auch nicht extra angeben, das sollte automatisch bleiben, wenn es so in der mpd.conf eingetragen wurde.

    Ich habe das gerade getestet.

    Das klappt leider nicht.

    Was muss ich denn für einen MPD Autostart in der /etc/mpd.conf verändern oder hinzufügen?

  • Was genau klappt nicht? Der richtige Sender oder die Lautstärke oder wird garnichts gestartet?


    Wie es bei Dir aussieht kann ich nicht sagen, ich kann Dir nur zeigen welche Einträge ich in der mpd.conf angepasst/überprüft hatte:

    falls Du damit keine Lösung findest, dann gehen wir alles mal Schritt für Schritt durch...:conf:

  • Ich komme leider nicht weiter.

    Ich beschreibe mal Schritt für Schritt was ich gemacht habe.

    1. Das Image Stretch auf eine SD-Karte geladen.


    2. Paketdaten heruntergeladen

    Code
    1. sudo apt-get install mpd mpc alsa-utils

    3. Sound Einstellungen

    Code
    1. sudo modprobe snd_bcm2835
    2. sudo amixer cset numid=3 1

    4. Konfiguration

    Code
    1. sudo nano /etc/mpd.conf

    #bind_to_address


    5. Module nach Neustart laden

    Code
    1. sudo nano /etc/modules

    Am Ende habe ich


    snd-bcm2835


    eingetragen.

    6. Rechte setzten


    Code
    1. sudo chmod g+w /var/lib/mpd/music/ /var/lib/mpd/playlists/
    2. sudo chgrp audio /var/lib/mpd/music/ /var/lib/mpd/playlists/

    7. Radiolinks hinzufügen:

    Code
    1. sudo nano /var/lib/mpd/playlists/radiosender.m3u


    Das Radio läuft auch, aber wie gesagt, es startet nach einem Neustart nicht automatisch.

    Was muss ich machen und wie bekomme ich es hin, dass der Pi automatisch um 4:30 Uhr einen Neustart macht?


  • So, ich habe mal mpd auf meinem Test-RPi 3 installiert:


    Pakete installieren:

    Code
    1. sudo apt-get update
    2. sudo apt-get upgrade
    3. sudo apt-get install mpd mpc alsa-utils
    4. sudo reboot


    ALSA konfigurieren:

    Code
    1. sudo modprobe snd_bcm2835
    2. sudo amixer cset numid=3 1
    3. sudo alsactl store



    Konfiguration vom MPD:


    sudo nano /etc/mpd.conf



    Hier alle wichtigen Parameter:




    Nach der Änderung der mpd.conf den Daemon neu starten:


    sudo /etc/init.d/mpd restart



    In das 'playlists' Verzeichnis Radio Liste erstellen:


    sudo nano /var/lib/mpd/playlists/Rock.m3u



    Mit z.B. diesem Inhalt:

    Code
    1. http://bob.hoerradar.de/mp3-radiobob
    2. http://rockradio.de:8090



    Liste Laden:


    mpc load Rock



    Und starten:


    mpc play 2



    ... Radio läuft, jetzt noch der Test, ob es nach einem Neustart automatisch startet:


    sudo reboot


    ... funktioniert. Färtsch! :thumbup:

    Nebenbei noch ein Tip(p) weil ich da gerade war: ALSA Lautstärke einstellen: sudo alsamixer


    Wenn Du es bis hier geschafft hast, dann bekommen wir Deinen Autoreboot mit 85% Lautstärke auch noch hin... ;)



    //Edit: Autoreboot mit 85% Lautstärke funktioniert (bei mir) nur in der systemweiten Crontab, aber immerhin.


    Die Tabelle öffnen: sudo nano /etc/crontab und den Cronjob: 30 4 * * * root mpc volume 85; reboot eintragen. Speichern und das wars! :angel:

  • Hallo chrissi1,


    da der Thread als erledigt markiert ist gehe ich davon aus, dass Du Dein Problem mittlerweile lösen konntest. Leider kam aber von Dir bisher noch keine Rückmeldung.

    Könntest Du für andere Hilfesuchende und Interessierte abschließend noch beschreiben wo sich der Fehler versteckt hatte und wie Du diesen behoben hast?

  • Hallo hyle,

    ich bin direkt nach deiner Anleitung vorgegangen und es hat alles geklappt, das Internetradio startet automatisch nach dem Neustart um 4:30 Uhr.

    Eine Sache habe ich allerdings noch.

    Ich möchte gerne, dass nach dem Neustart MPD mit dem ersten Sender in der Playlist wieder startet. Derzeit startet der zuletzt gehörte Sender nach einem Neustart.

    Ist das irgendwie möglich?

    Gruß und Vielen Dank.