Wlan Problem pi3

Ein neuer Artikel wurde veröffentlicht
  • Ich hoffe, ...

    Versuch mal mit einer Datei:

    Code
    1. nano cat /etc/modprobe.d/brcmfmac.conf

    mit folgendem Inhalt:

    Code
    1. options brcmfmac roamoff=1
    2. options brcmfmac p2pon=0

    danach:

    Code
    1. sudo modprobe -rv brcmfmac && sudo modprobe -v brcmfmac

    (oder reboot des PI) und deaktiviertem WPS in deiner FritzBox (WLAN-Router).


    EDIT:


    Hast Du evtl. auch einen Repeater in deiner WLAN-Konstellation?

  • Code
    1. sudo nano /etc/modprobe.d/brcmfmac.conf

    Das cat gehört da nicht hin.

    leider keine Änderung:

    ifconfig:

    Code
    1. wlan0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
    2. ether b8:27:eb:86:6f:bb txqueuelen 1000 (Ethernet)
    3. RX packets 0 bytes 0 (0.0 B)
    4. RX errors 0 dropped 0 overruns 0 frame 0
    5. TX packets 0 bytes 0 (0.0 B)
    6. TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
  • leider keine Änderung:

    Wie ist jetzt die Ausgabe von:

    Code
    1. sudo wpa_supplicant -i wlan0 -Dnl80211 -c /etc/wpa_supplicant/wpa_supplicant.conf -d

    Hast Du evtl. einen Repeater, Hotspot, etc. (... mit der identischen SSID wie der AP/WLAN-Router) in deiner WLAN-Konstellation?


    EDIT:


    BTW: Die Ausgabe von "ifconfig" ist nicht relevant, denn die Herstellung einer funktionierenden WLAN-Verbindung bedeutet noch nicht, dass das Interface (hier wlan0), damit bzw. dadurch auch schon eine IP-Adresse zugewiesen bekommt.


    Dann besser, die Ausgabe von:

    Code
    1. iwconfig



    EDIT2:


    Poste mal auch aus der Ausgabe von:

    Code
    1. sudo iwlist wlan0 scan

    den vollständigen Teil, der dein WLAN betrifft.

  • Code
    sudo wpa_supplicant -i wlan0 -Dnl80211 -c /etc/wpa_supplicant/wpa_supplicant.conf -d

    Hast Du evtl. einen Repeater, Hotspot, etc. (... mit der identischen SSID wie der AP/WLAN-Router) in deiner WLAN-Konstellation?

    Ja, mehrere:

    Die 7390 hat einen Repeater mit gleicher SSID und einen RT-AC68 auch mit einem Repeater mit gleichnamiger SSID.....

    bisher hat sich daran aber noch kein Gerät gestoßen.


    iwconfig

    Code
    1. iwconfig
    2. eth0 no wireless extensions.
    3. lo no wireless extensions.
    4. wlan0 IEEE 802.11 ESSID:off/any
    5. Mode:Managed Access Point: Not-Associated Tx-Power=31 dBm
    6. Retry short limit:7 RTS thr:off Fragment thr:off
    7. Power Management:on

    sudo iwlist wlan0 scan

  • Code
    1. ctrl_iface bind(PF_UNIX) failed: Address already in use
    2. ctrl_iface exists and seems to be in use - cannot override it
    3. Delete '/var/run/wpa_supplicant/wlan0' manually if it is not used anymore
    4. Failed to initialize control interface 'DIR=/var/run/wpa_supplicant GROUP=netdev'.
    5. You may have another wpa_supplicant process already running or the file was
    6. left by an unclean termination of wpa_supplicant in which case you will need
    7. to manually remove this file before starting wpa_supplicant again.


    Mach mal:

    Code
    1. sudo rm /var/run/wpa_supplicant/wlan

    und danach:

    Code
    1. sudo wpa_supplicant -i wlan0 -Dnl80211 -c /etc/wpa_supplicant/wpa_supplicant.conf -d


    EDIT:


    Poste mal auch die Ausgaben von:

    Code
    1. sudo cat /etc/wpa_supplicant/wpa_supplicant.conf | grep -i ssid
    2. sudo iwlist wlan0 scan | grep -i essid



    EDIT 2:


    Von wegen nur WPA2:

    Code
    1. IE: WPA Version 1
    2. Group Cipher : TKIP
    3. Pairwise Ciphers (2) : TKIP CCMP
    4. Authentication Suites (1) : PSK
    5. IE: IEEE 802.11i/WPA2 Version 1
    6. Group Cipher : TKIP
    7. Pairwise Ciphers (2) : TKIP CCMP
    8. Authentication Suites (1) : PSK

    ... lt. der Ausgabe von "iwlist".

  • sudo cat /etc/wpa_supplicant/wpa_supplicant.conf | grep -i ssid

    Code
    1. $ sudo cat /etc/wpa_supplicant/wpa_supplicant.conf | grep -i ssid
    2. ssid="heyn7390"

    sudo iwlist wlan0 scan | grep -i essid

    Code
    1. $ sudo iwlist wlan0 scan | grep -i essid
    2. wlan0 Interface doesn't support scanning : Device or resource busy

    Von wegen nur WPA2:

    Fb steht auf: WPA2 (CCMP)



    Soll ich die Repeater mal deaktivieren?

  • Bitte?

    Doch, ich würde gerne den RPi über Wlan ansprechen.

    Ich entnehme deiner Aussage, daß mit dem geposteten Auszug was nicht stimmt?


    Habe es noch einmal versucht, nun steht da folgendes:

    Code
    1. sudo iwlist wlan0 scan | grep -i essid
    2. ESSID:"heyn-7390"
    3. ESSID:"heyn Gastzugang"
    4. ESSID:"heyn-68U"
    5. ESSID:"heyn-68U"

    Warum beim ersten Mal mal busy gezeigt hat, weiß ich nicht. die Befehlszeile hatte ich mit hineinkopiert.

  • O.K., Danke an ALLE :)


    was auch immer passiert ist, nun geht es. Ich was kurz weg und der RPi stromlos. Als ich wiederkam und ihn ansteckte, war er plötzlich auf der FB zu sehen. Nun hat er einen vorläufigen Platz außerhelb der Reichweite eines Kabels bekommen und lässt sich gut über Wlan ansprechen - über Repeater mit der selben SSID wie die FB.


    Nochmals Dank für eure Mühe und Tips,

    ein glücklicher

    Adolar