SSH mit Putty auf dem Zero geht und mal nicht

  • Guten Abend,


    ich nutze den Zero in Vebindung mit einer Raspberry Pi Camera. Beide befinden sich zusammen in einer Kamera Atrappe aus einem Metallgehäuse. Ich habe öfter das Problem, dass ich mal die Verbindung perr SSH zum Zero über Putty aufbauen kann und mal nicht. Dann kriege ich eine Network Error Connection Timeout Mledung in Putty. Der Zero ist per WLan-Stick mit dem Netzwerk verbunden.

    Leider weiß ich nicht wo ich mit der Fehlersuche anfangen soll. Vom Router wird der Zero wohl erkannt und wird in der Liste der kabellosen Geräte aufgeführt.
    Das kuriose ist, das ich mal eine Verbindung per SSH herstellen kann, an einigen Tagen gar nicht. Da muss ich den Zero von der Stromversorgung für paar Minuten trennen.. danach klappts wieder.


    Hab den Zero einmal angepingt wenn dieser per SSH nicht erreichbar ist und erhalte "Zielhost nicht erreichbar. Die gesendeten Packete werden aber empfangen 0% verloren.

    Hat wer eine Idee wie ich da zur Problemlösung vorgehen sollte?

    Grüße

  • Hab den Zero einmal angepingt wenn dieser per SSH nicht erreichbar ist und erhalte "Zielhost nicht erreichbar. Die gesendeten Packete werden aber empfangen 0% verloren.

    Kannst Du diese Ausgabe mal hier posten? Hast Du auch den lauschenden Port des sshd (auf deinem PI) mal aus dem W/LAN gescannt?

    Code
    nc -zv <IP-Adresse> <Port>

    oder gleichwertig.

    The most popular websites without IPv6 in Germany.

  • Connection Timeout Mledung in Putty. Der Zero ist per WLan-Stick mit dem Netzwerk verbunden.


    Hab den Zero einmal angepingt wenn dieser per SSH nicht erreichbar ist und erhalte "Zielhost nicht erreichbar. Die gesendeten Packete werden aber empfangen 0% verloren.

    Hallo apfel87,

    entweder ist der Pi0 komplett weg (abgestürzt) oder der WLAN USB Stick im Stromsparmodus (ausgeschaltet?) oder wegen ungünstigen Bedingungen (WLAN Reichweit) anderweitig nicht erreichbar. Die ping Antwort kommt sicher von dem Rechner, von dem Du sie abgesetzt hast. Die werden (zumindest vom Pi0) sicher nicht empfangen. Ich würde beim WLAN mit der Fehlersuche anfangen.


    Gruß, STF

  • Kriege folgendes Ergebnis:


    Warning: forward host lookup failed for secuirtycamera: h_errno 11004: NO_DATA


    securitycamera [IP-Adresse] 22 (ssh): TIMEDOUT

    Quote

    Hast Du auch den lauschenden Port des sshd (auf deinem PI) mal aus dem W/LAN gescannt?

    Wie scanne ich den auf dem Pi?

    Grüße und vielen Dank für deine Hilfe

  • Hallo apfel87,

    entweder ist der Pi0 komplett weg (abgestürzt) oder der WLAN USB Stick im Stromsparmodus (ausgeschaltet?) oder wegen ungünstigen Bedingungen (WLAN Reichweit) anderweitig nicht erreichbar. Die ping Antwort kommt sicher von dem Rechner, von dem Du sie abgesetzt hast. Die werden (zumindest vom Pi0) sicher nicht empfangen. Ich würde beim WLAN mit der Fehlersuche anfangen.


    Gruß, STF

    Hi, abgestürzt kann ich ausschließen. Habe eine Led die alle paar Minuten kurz aufblinkt, daran kann ich erkennen das der PI noch "lebt". Den Energiesparmodus habe ich per Software deaktiviert.

    Code
    wireless-power off

    Ob der Befehl so funktioniert kann ich zu 100% nicht sagen.
    Gibt es noch eine Energiesparfunktion für die USB-Ports?

    Die Reichweite kann ich mit einem WLAN-Stick mit Antenne überprüfen. Hatte mir eins die Tage bestellt, aber noch nicht eingebaut.

  • Wie scanne ich den auf dem Pi?

    Das ist vom OS der Geräte, die Du in deinem W/LAN hast, abhängig.


    Z. B. gibt es nmap, auch für Windows.

    The most popular websites without IPv6 in Germany.

  • Habe mir nmap für WIndows besorgt und einen Scan gestartet mit de Ziel IP-Adresse des Pis.

    Wirklich hilfreiche Informationen erhalte ich nicht die mich weiterbringen.
    Note: Host seems down. If it is really up, but blocking our ping probes, try -Pn

    Mit dem Zusatz -Pn probiert:
    IP address (0 hosts up) scanned in 8.11 seconds

    Wie ist den der Port für SSHD? Ich kenne nur den Standardport 22 für SSH

  • ... wird in der Liste der kabellosen Geräte aufgeführt.

    Welchen Router hast Du?


    Ich hatte schon Fälle, da war der PI (oder ein anderes Gerät) im (W)LAN per icmp (ping) nicht erreichbar, dafür aber mit dem arp-Protokoll (noch) erreichbar.

    In Linux gibt es als tools z. B. arp-scan oder arping. Schau mal im Internet nach, ob Du etwas Gleichwertiges für Windows findest.

    The most popular websites without IPv6 in Germany.

  • Probier doch mal per crontab alle 5 Min. oder so eine Datei auf einen anderen Rechner zu schieben und guck, ob das geht, oder ob die Datei auch nicht ankommt.

    Dann mal testen, obs geht, wenn du den Wlan-Stick abziehst, kurz wartest und ihn wieder ansteckst.

  • Hi das würde ich noch ausprobieren. Habe heute morgen des Zero aus der Kamera ausgebaut und im Haus ans Stromnetz angeschlossen. Heute schaffe ich es überhaupt nicht eine SSH Verbindung herzustellen. Die Spannungsversorgung für den Pi kann ich ausschließen, die hab ich mir mit einem Oszi im laufenden Betrieb angeguckt. Diese bleibt stabil. Ich habe auch ein Industrieschaltnetzteil dran hängen kein Steckernetzteil, welches die Spannung nachregelt. Die schlechte WLAN-Verbindung würde ich ebenfalls ausschließen, der Zero ist quasi neben dem Router..

    Habe nochmal mit raspi-config und nach dieser Anleitung SSH aktiviert. http://raspberrypiguide.de/how…nter-raspbian-einrichten/
    Die IP-Adresse des Zeros hab ich dem Router entnommen und es funktioniert immer noch nicht.

    Langsam verzweifel ich hier...macht es Sinn SSH zu deinstallieren und dann neu drauf zu spielen?

  • Die schlechte WLAN-Verbindung würde ich ebenfalls ausschließen, der Zero ist quasi neben dem Router..

    ...macht es Sinn SSH zu deinstallieren und dann neu drauf zu spielen?

    BTW: Auch neben dem WLAN-Router kann die WLAN-Verbindung schlecht sein, denn die ist u. a. auch von der Konfiguration abhängig.


    So lange dein PI nicht per arp oder icmp erreichbar ist, musst Du ssh nicht deinstallieren und neu installieren.

    The most popular websites without IPv6 in Germany.

  • SSH ist definitiv aktiv. Mit systemctl status ssh überprüft. Wenn ich den Status abfrage, steht dort auch sshd [568]: Server listening on 0.0.0.0 port 22

    Müsste da nicht die IP-Adresse des PIs stehen?

  • : Server listening on 0.0.0.0 port 22

    Müsste da nicht die IP-Adresse des PIs stehen?

    Nein, denn Du hast den sshd so konfiguriert, dass dieser an allen IP(v4)-Adressen lauscht.

    The most popular websites without IPv6 in Germany.

  • Ok. Fangen wir bei der Netzwerkkonfiguration des Pis an.


    /etc/network/interfaces steht folgendes drin:

    /etc/modprobe.d/8192cu.conf

    Code
    options 8192cu rtw_power_mgnt=0 rtw_enusbss=0

    Vielleicht steckt hier schon der Fehler drin.'

    EDIT:
    Mir ist noch was aufgefallen. Hab den Zero mit einem HDMI Display verbunden damit ich eine grafische Ausgabe hab. Wenn ich nun über die Konsole die IP mit ifconfig abfrage erhalte ich eine andere IP-Adresse ausgeben, als die die oben rechts in der Menü Leiste unter dem WLAN-Symbol angezeigt wird, wenn ich mit der Maus drüber fahre (wlan0: Configured "IP-Adresse"). Das kann doch schon nicht sein...

    Edited once, last by apfel87 ().

  • Fangen wir bei der Netzwerkkonfiguration des Pis an.

    Warum? Wo bzw. wie hast Du festgstellt, dass es Unterbrechungen in der WLAN-Verbindung gibt? Kannst Du evtl. das WLAN-Log des Routers einsehen?

    The most popular websites without IPv6 in Germany.

  • rpi444


    Gar nicht, hatte deinen Antworten entnommen, das es an falscher Konfiguration des WLANs liegen kann. Daher hab ich meine Einstellungen gepostet.


    Wenn schon zwei verschiedene IP-Adressen vom Pi angezeigt werden muss da doch was faul sein. Ifconfig und auf dem Desktop das WLAN-Symbol
    zeigen zwei verschiedene IP-Adressen an.


    RTFM
    am Zero kann ich kein Lan-Kabel anschließen. Hab aber den Eintrag in der Interfaces mal auskommentiert


  • rpi444


    Wenn schon zwei verschiedene IP-Adressen vom Pi angezeigt werden muss da doch was faul sein. Ifconfig und auf dem Desktop das WLAN-Symbol

    zeigen zwei verschiedene IP-Adressen an.

    Dann poste mal die Ausgaben von:

    Code
    ifconfig -a
    ip a
    route -n
    ps aux | grep -i [d]hc

    The most popular websites without IPv6 in Germany.