Pi gibt kein Bild über HDMI aus und ist im Netzwerk nicht erreichbar

  • Hallo miteinander,


    ich habe einen pi B im Einsatz. Nachdem ich diesen heute übertaktet habe, lief er auch nach einem Reboot ganz normal. Nun gibt er plötzlich keine Bild mehr aus und ist über das Netzwerk nicht erreichbar. Laut den LEDs bootet er wohl. Auch Netzwerkaktivität werden durch die LEDs angezeigt.

    Gibts eine Rettung oder muss ich die Kiste neu aufsetzen.


    Besten Dank.

  • Moin SiLAnceR,


    hast du die Übertaktung schon zurück genommen?


    Wenn nein, dann SD-Karte aus dem Raspberry nehmen und in einen Kartenleser am Pc stecken.

    Die Boot-Partition ist auch unter Windows erreichbar.

    Dann die Übertaktung in der config.txt löschen.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Hallo SiLAnceR,


    ein Übertakten führt zu einem größeren Stromverbrauch. Kann es sein, dass Dein Netzteil diesen gestiegenen Anforderungen nicht mehr gerecht wird? Welches Netzteil setzt Du denn ein (Hersteller, Modell, technische Daten)?


    Wenn es das Netzteil ist: Unter dem Stichwort Mysterium findest Du in diesem Forum sehr viele Threads, in denen die absurdesten Fehlerbeschreibungen auf eine letztlich unzureichende Stromversorgung zurückzuführen ist. Schau mal in meine Andreas' Link-Liste. Da haben sich mittlerweile > 30 Links zum Thema zusammengetragen.


    Ansonsten: Schließe mal einen Monitor an und schaue, woran es hängt. Poste dann auch mal die Ausgabe des Linux-Kommandos dmesg.


    Tip am Rande: An den meisten meiner RaspberryPi's habe ich über GPIO einen Taster geschaltet. Im Hintergrund läuft ein Programm, das je nach Dauer des Gedrückthaltens entweder sauber herunterfährt oder rebootet. Wie Bernd666 schon schreibt, kannst Du dann die SD-Karte entnehmen und das Hochtakten zurücknehmen.



    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

  • Hallo miteinander und vielen Dank für die schnellen zahlreichen Antworten.

    Das blöde ist, der Pi gibt kein Bild aus. Somit kann ich nicht sehen, wo die Geschichte stehen bleibt.

    In der config steht nur das hier:

    (over Voltage stand auf 2, core auf 200 und sdram auf 450). Trotz der wieder heruntergeschraubten Werte passiert nix.


    # Enable audio (loads snd_bcm2835)

    dtparam=audio=on

    gpu_mem=16

    max_usb_current=1

    core_freq=700

    sdram_freq=400

    over_voltage=0

  • Hallo hyle

    //Edit: Menno, diesmal zwei schneller, ich muss mal Schnellschreiben üben. ;(

    Ja! Da stimme ich Dir vorbehaltlos zu. Zumal Du auch mit Abstand das Wenigste :no_sad: geschrieben hast. Aber wahrscheinlich hast Du die Ursache getroffen...


    ;)


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

    Edited once, last by Andreas ().

  • Hi Bernd,


    schaue ich gleich. Hab nur grad den Pi mit der anderen Karte dran :-)

    Wie setze ich die Übertaktung zurück? Reicht es wenn ich die von mir genannten Werte lösche?

    arm-freq hab ich in der config nämlich nicht.


    Sorry, Sorry Leute...hatte wohl Eier auf den Augen. Habe den Eintrag gefunden.

    Die anderen Werte passen?

  • Moin SiLAnceR,


    also, bei mir steht davon nichts in der config.txt. Habe hier jessie lite.

    core_freq=700

    sdram_freq=400

    over_voltage=0

    Diese kannst du auskommentieren. # vor


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Hab jetzt arm-freq auskommentiert und das andere Gebrezel gelöscht.

    Tut sich aber nichts. Die andere SD Karte mit jessie Lite rennt jedoch.

    Hat es mir die Karte zerschossen?

  • Leider nein. Habe mir gestern nämlich was aufgesetzt...wäre nicht wirklich wichtig, hat nur n Stück arbeit gekostet. Demnach wäre es nice, falls man die Kiste wieder iwie zum Laufen bekommen würde.

  • Hallo SiLAnceR,


    Hab jetzt arm-freq auskommentiert und das andere Gebrezel gelöscht.

    Tut sich aber nichts. Die andere SD Karte mit jessie Lite rennt jedoch.

    Hat es mir die Karte zerschossen?


    was machen die LEDs beim Versuch, davon zu starten? Leuchten sie, blinken sie?


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

  • Hallo Andreas,


    die grüne LED neben der "Power" Led blinkt und zeigt dadurch Aktivität an. Auch die LEDs fürs Netzwerk sind an.

  • Hallo SiLAnceR,


    dann scheint das Betriebssystem zu funktionieren.

    Kannst Du einen Monitor anschließen, damit man sehen kann, was dem Teil fehlt?


    Solange Du nicht weißt, was mit dem Netzwerk ist, bringt alles andere (außer die Netzteilfrage zu beantworten oder mal ein "gutes" Netzteil einzusetzen) nichts.


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

  • Da wären wir beim Punkt, Andreas. Der Pi gibt darüber nichts mehr aus.

    Starte ich ein anderes Image, funktioniert es aber.

  • Hallo SiLAnceR,


    da fällt mir nur noch eines ein:

    1. Richte auf einem andern RPi die UART-Schnittstelle ein (Suche hilft)
    2. Schließe die UART-Schnittstelle (GPIO14 an GPIO15 und GPIO15 an GPIO14 eines anderen Raspberry) des "stummen-blinden" RPi an einen anderen funktionsfähigen RPi an, der an einen Monitor angeschlossen ist GPIO-Tool zur Identifizierung von GPIO-/WiringPi-/Pin-Nummern, Alternativ-Funktionen
    3. auf dem "sehenden" RPi gibst Du ein cat /dev/ttyAMA0 (oder wie auch immer die serielle Schnittstelle bei dem eingesetzten Modell / Betriebssystem heißt)
    4. dann startest Du den "blinden" RPi
    5. Auf dem "sehenden" RPi erscheint dann die Boot-Meldung des "blinden" RPi

    Und diese Meldung postest Du dann bitte hier...


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

  • Hallo SiLAnceR,


    ein Arduino würde auch gehen - sofern richtig beschaltet.


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.