WLAN ohne SSID

  • Hallo,

    ich habe verschiede Anleitungen probiert den Raspi 2 B mit WLAN USB mit dem Router ohne SSID übermittlung zu verbinden.

    Aber es klappt einfach nicht.

    WLAN mit SSID Übertragung wird angezeigt in der Netzwerkübersicht.

    Aktuell ist die Software

  • ich habe verschiede Anleitungen probiert den Raspi 2 B mit WLAN USB mit dem Router ohne SSID übermittlung zu verbinden.

    Doch das funktioniert. Poste mal was Du bis jetzt probiert hast. Evtl. finden wir den Fehler.


    EDIT:


    Teste mal ob der Router gefunden/gesehen wird:

    Code
    sudo iwlist wlan0 scan | grep -i 'ESSID:""'

    (evtl. musst Du wlan0 anpassen).

    The most popular websites without IPv6 in Germany.

    Edited once, last by rpi444 ().

  • Man kann nur die Anzeige/Ausgabe der ssid unterdrücken..

    Ja, das hat der TE ja auch so in seinem 1. Beitrag geschrieben:

    Quote

    ... Router ohne SSID übermittlung ...

    The most popular websites without IPv6 in Germany.

  • Hallo und vielen Dank für die Antworten, vor allem rpi 444.

    wenn ich den Befehl sudo iwlist wlan0 scan | grep -i 'ESSID:""' eingebe kommt nur rote Schrift: ESSID:""
    wenn zwischen den "" die SSID (Routername) steht passiert nichts

    in sudo nano /etc/network/interfaces sieht es so aus:

    # interfaces(5) file used by ifup(8) and ifdown(8)
    .
    #please note that this file is written to beused with dhcpcd
    #for static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf

    # Include files from /etc/network/interfaces.d:
    source-directory /etc/network/interfaces.d

    #allow-hotplug wlan0
    auto wlan0
    iface wlan0 inet dhcp
    wpa-ap-scan 1
    wpa-scan-ssid 1
    wpa-ssid "ssid name"
    wpa-psk "passwort"

    aber nach einem Neustart des Raspi mit der SSID und dem Passwort bleibt die LED des WLAN Stick aus. Wenn

    #allow-hotplug wlan0
    auto wlan0
    iface wlan0 inet dhcp
    wpa-ap-scan 1
    wpa-scan-ssid 1
    wpa-ssid "ssid name"
    wpa-psk "passwort"

    rausgelassen bleibt, leuchtet die WLAN LED am Stick.

  • Wenn

    Code
    #allow-hotplug wlan0
    auto wlan0
    iface wlan0 inet dhcp
    wpa-ap-scan 1
    wpa-scan-ssid 1
    wpa-ssid "ssid name"
    wpa-psk "passwort"

    rausgelassen bleibt, leuchtet die WLAN LED am Stick.

    Welches Betriebssystem bzw. welche Version hast Du auf deinem PI2?

    The most popular websites without IPv6 in Germany.

  • wenn sudo iwlist wlan0 scan | grep -i 'ESSID:""'

    das ausgibt: ESSID:""

    dann hat der raspi ein WLAN-Funknetz ohne Namen erkannt.


    SSID ist der Name des WLAN Funknetz

  • Raspberian 2.1

    OK.

    Code
    wpa-ssid "ssid name"
    wpa-psk "passwort"

    Beinhaltet die SSID deines Routers auch Leerstellen? Denn in der interfaces-Datei sind die Anführungszeichen für SSID und psk nicht erforderlich.


    Du könntest auch die richtige MAC-Adresse deines Routers angeben und zum testen einen debug-level inkl. den Eintrag in eine Datei (mit den entsprechenden Schreibrechten), verwenden. Z. B.:

    Code
    wpa-bssid <BSSID>
    wpa-debug-level 1
    wpa-logfile /<Pfad>/<Datei.log>

    (ohne spitze Klammern).

    The most popular websites without IPv6 in Germany.

  • OK.

    Code
    wpa-ssid "ssid name"
    wpa-psk "passwort"

    Beinhaltet die SSID deines Routers auch Leerstellen? Denn in der interfaces-Datei sind die Anführungszeichen für SSID und psk nicht erforderlich.


    Du könntest auch die richtige MAC-Adresse deines Routers angeben und zum testen einen debug-level inkl. den Eintrag in eine Datei (mit den entsprechenden Schreibrechten), verwenden. Z. B.:

    Code
    wpa-bssid <BSSID>
    wpa-debug-level 1
    wpa-logfile /<Pfad>/<Datei.log>

    (ohne spitze Klammern).

    Hallo rpi444,


    nein Leerstellen hat die SSID nicht, okay die Anführungszeichen hab ich rausgenommen, die USB Stick LED bleibt aus.

    ich hatte experimentiert, es leuchtet zumindest die LED, wenn es wie unten aussieht.

    allow-hotplug wlan0
    auto wlan0
    #iface wlan0 inet dhcp
    wpa-ap-scan 1
    wpa-scan-ssid 1
    wpa-ssid ssid
    wpa-psk passwort

    aber die Verbindung steht wohl noch nicht zum Router, sonst würde die LED blinken.

    bedeutet es bei den Befehlen wpa-ap-scan 1 und wpa-scan-ssid 1 daß der Router auf Kanal 1 gesucht wird auf WPA?

    Mit dem Debug Code komme ich nicht zurecht, bzw. er kennt den Befehl nicht.


  • Nein. Die Befehle bedeuten:

    Quote

    # 1: wpa_supplicant initiates scanning and AP selection; if no APs matching to

    # the currently enabled networks are found, a new network (IBSS or AP mode

    # operation) may be initialized (if configured) (default)

    Quote

    # 1 = scan with SSID-specific Probe Request frames (this can be used to

    # find APs that do not accept broadcast SSID or use multiple SSIDs;

    # this will add latency to scanning, so enable this only when needed)

    Schau mal nach welchen Treiber dein WLAN-Stick benutzt: wext oder nl80211.


    Evtl. mit einer wpa_supplicant.conf-Datei und im Terminal/Konsole im debug-/fg-Modus versuchen:


    Code
    sudo wpa_supplicant -i wlan0 -D wext,nl80211 -c /etc/wpa_supplicant/wpa_supplicant.conf -d

    , absichtlich so mit beiden Treiber.

    The most popular websites without IPv6 in Germany.

  • wenn die SSID aktiviert ist, funktioniert WLAN Datenübertragung, nur bei der manuellen SSID Eingabe funktioniert es nicht.

    nach der Eingabe von dem unten stehenden Code bleibt das Terminal stehen, die letzten zwei Meldungen:
    WEXT: if_removed already cleared - ignore event
    EAPOL: disable timer tick

    sudo wpa_supplicant -i wlan0 -D wext,nl80211 -c /etc/wpa_supplicant/wpa_supplicant.conf -d

    Beim Öffnen eines weitern Terminal und Eingabe des Code, geht kurz die WLAN LED an, das erste Fenster geht weiter und bleibt stehen bei :

    l2_packet receive - recvfrom: Network ist down


    in dem langen Text steht: WEXT: cfg80211-based driver deteced

  • ... bei der manuellen SSID Eingabe funktioniert es nicht.

    nach der Eingabe von dem unten stehenden Code bleibt das Terminal stehen, die letzten zwei Meldungen:
    WEXT: if_removed already cleared - ignore event
    EAPOL: disable timer tick

    Was genau meinst Du mit "der manuellen SSID Eingabe"?


    Dass das Terminal "stehen bleibt" ist richtig, denn ich habe doch geschrieben "im fg-/debug-Modus" (oder so ähnlich).


    Wie sind nach dem "stehen bleiben" des Terminals, in einem anderen Terminal-Tab oder -Fenster, die Ausgaben von:

    Code
    iwconfig
    ps aux | grep -i wpa_supplicant
    sudo wpa_cli status
    sudo wpa_cli scan_results

    ?

    The most popular websites without IPv6 in Germany.

  • okay, ich hab den Fehler behoben. Hatte wohl zuviel verändert im Raspi, und ging davon aus daß wenn man die SD Karte auf einen USB Stick kopiert, daß es 1:1 geschieht, aber dem ist wohl nicht so. wie erstellt man am besten eine 1:1 Sicherung der SD Karte?

    Nochmal gemountet und geupdatet und geupgradet und WLAN ohne SSID funktioniert in dieser Konfig:


    allow-hotplug wlan0
    auto wlan0
    iface wlan0 inet dhcp
    wpa-ap-scan 1
    wpa-scan-ssid 1
    wpa-ssid ssid
    wpa-psk passwort


    Vielen Dank nochmal