PHP5 Probleme / Pi Control

  • Hallo.


    Ich brauche nochmal eure Hilfe.


    Ich installiere mir gerade PI Control. Nun möchte ich gerne folgende installieren.

    Code
    1. sudo apt-get install php5-ssh2
    Code
    1. sudo apt-get install php5-mcrypt
    Code
    1. sudo apt-get install php5-curl
    Code
    1. sudo apt-get install php5-zip


    So steht es in der Anleitung. Leider können sämtliche PHP5 Pakete nicht gefunden werden.


    Kann mir jemand helfen?


    Vielen Dank

  • Stretch?


    Code
    1. sudo apt-get install php-ssh2 php-mcrypt php-curl php-zip

    Da es jetzt PHP 7 ist...


    Dry run:


    Knut

  • Ich würde diesen Beitrag gerne nochmal "nach oben holen"


    Ich hab nen Pi 3b mit folgendem drauf:

    • Raspbian Stretch
    • Apache2
      • Server version: Apache/2.4.25 (Raspbian)
        Server built: 2018-06-02T08:01:13
    • PHP
      • PHP 7.0.30-0+deb9u1 (cli) (built: Jun 14 2018 13:50:25) ( NTS )
        Copyright (c) 1997-2017 The PHP Group Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies with Zend OPcache v7.0.30-0+deb9u1, Copyright (c) 1999-2017, by Zend Technologies
    • NextCloudPi v0.59.0 mit Nextcloud 13.0.6.1

    Der installationswizard von PiC sagt mir jetzt, dass ich kein ssh2 installiert/aktiviert habe. Laut php -m ist ssh2 allerdings installiert und aktiviert. o0


    Ich habe auch dies als Lösung probiert jedoch leider ohne Erfolg. :(


    Die Pakete die du oben genant hast KKoPi habe ich auch alle installiert.


    Per ssh auf dem Pi folgender code erscheint mir auch als korrekt:

    Code
    1. $result = ssh2_connect('localhost');
    2. var_dump($result);
    3. --> resource(1) of type (SSH2 Session)


    Hat jmd von euch ne Idee? :)


    Edit1:

    Aus der PHPinfo:

    ssh2

    SSH2 support => enabled

    extension version => 1.0

    libssh2 version => 1.7.0

    banner => SSH-2.0-libssh2_1.7.0

    2 Mal editiert, zuletzt von Paratoxin ()