Jukebox mit RFID

  • Hallo Forum-Gemeinde,

    mein 13-jähriger Sohn benötigt für die Schule ein Projekt, was er frei wählen konnte.

    Da er sich für Computer interessiert und gerne das Programmieren lernen möchte, hat er sich ein Projekt mit dem Raspberry PI ausgesucht.

    Er ist ganz begeistert von dem Projekt Jukebox für Kinder. Da ich auch ganz begeistert von diesem Projekt bin, möchte ich ihn dabei unterstützen.

    Wir haben uns seit den Sommerferien sehr intensiv über ein Buch und über das Internet in den Grundlagen eingelesen.

    Jetzt möchten wir uns gezielter einarbeiten. Dazu habe ich einen USB RFID Reader für TK4100 und EM4100 Karten gekauft.

    Leider haben wir es heute nicht geschafft den Reader zum Laufen zu bekommen. Wir haben sehr viel im Internet nach Anleitungen geschaut,

    aber so richtig haben wir nichts gefunden bzw. wir haben Fehlermeldungen erhalten.

    Wenn ich es richtig verstanden habe, benötige ich für die Python-Scripte das Modul evdev für den Import. Leider hat die Installation nicht funktioniert.

    Python hat die Version nicht gefunden.

    Wer kann uns bitte weiterhelfen. Mein Sohn und ich haben so eine Lust auf das Projekt, scheitern aber leider schon an der wichtigsten Funktion.


    Nette Grüße,

    Frank

    :danke_ATDE:

  • Wenn du nicht schilderst, was genau ihr zur Installation versucht habt und welche Fehlermeldungen (als Code formatieren!) euch dabei hindern wird niemand helfen können.

  • Ein USB Kartenleser (Client) handelt mit dem USB Master (Pi) die Parameter, damit auch den Maximalstrom aus.

    Je nach Kartenleser (und Linuxdisitribution) wird der serielle Kartenleser mit einem Device verbunden. Das kann bei einem reinen Leser auch ein keyboard (hid-Deice) sein (ist es bei Euch aber nicht). Vermutlich stellt der USB Kontroller den vom RFID Leser gesendeten Byteblock auf /dev/USB0 oder /dev/ttyusb0 /dev/AMA0 oder so, default zur Verfügung, während Euer Terminal ( /dev/tty_x ) auf /dev/stdin lauscht und nach /dev/stdout und /dev/stderr ausgibt.


    Vllt. hilft Euch Beiden, neben dem Buch, < lsusb >, auch < lsusb -v > < usb-devices > und < dmesg -w > das in einer eigenen Konsole, vorerst weiter.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • Ein Dankeschön für die schnelle Hilfe.

    RTFM, ein guter Tipp um weiter zu recherchieren.

    Ich merke, mir fehlt noch so einiges an Wissen.

    Eine Abänderung auf EM4100 ist bestimmt nicht so schwer,

    für mich schon. Ich werde mich aber damit auseinander setzen.


    Guude !

  • Hier im Forum im Bereich abgeschlossene Projekte gibt es im Thread "Jukeox4kids" eine Anleitung von hailogugo.

    Im Bereich PHP-Installation soll man die folgende Zeile eingeben:


    sudo apt-get install lighttpd php5-common php5-cgi php5


    Das Ergebnis habe ich mal rauskopiert und unten angehängt.

    Was kann ich machen?


    pi@raspberrypi:/usr/bin $ sudo apt-get install lighttpd php5-common php5-cgi php5

    Paketlisten werden gelesen... Fertig

    Abhängigkeitsbaum wird aufgebaut.

    Statusinformationen werden eingelesen.... Fertig

    Paket php5 ist nicht verfügbar, wird aber von einem anderen Paket

    referenziert. Das kann heißen, dass das Paket fehlt, dass es abgelöst

    wurde oder nur aus einer anderen Quelle verfügbar ist.


    Paket php5-common ist nicht verfügbar, wird aber von einem anderen Paket

    referenziert. Das kann heißen, dass das Paket fehlt, dass es abgelöst

    wurde oder nur aus einer anderen Quelle verfügbar ist.


    Paket php5-cgi ist nicht verfügbar, wird aber von einem anderen Paket

    referenziert. Das kann heißen, dass das Paket fehlt, dass es abgelöst

    wurde oder nur aus einer anderen Quelle verfügbar ist.


    E: Für Paket »php5-common« existiert kein Installationskandidat.

    E: Für Paket »php5-cgi« existiert kein Installationskandidat.

    E: Für Paket »php5« existiert kein Installationskandidat.

  • Hallo Dellex


    Habe meine Box am Laufen, aber das selbe Problem wie Du.

    Musste auch PHP7 instaliert, aber bekomme es nicht zum laufen.:helpnew:

    Wenn ich die IP im Browser eingebe habe ich nur die Info seite von Apache2 .


    hyle läuft der Skript in PHP7 ? oder muss etwas umgestellt werden ?

  • läuft der Skript in PHP7 ? oder muss etwas umgestellt werden ?

    Keine Ahnung, ich gab nur den Hinweis, das PHP5 raus ist und zeigte einen Weg die aktuelle Version von PHP zu installieren. Mal sehen, evtl. sehe ich mir das Projekt morgen mal an. :denker: :-/ Nur am Rande: Ich will hier nicht klugscheißen und auch nur zur Info, es heißt das Skript bzw. Script.;)



    dreamshader Menno, den Vorschlag mit dem neuen Thread wollte ich doch machen...

  • Sorry, nicht gesehen das Thread als erledigt markiert wurde.

    Ist noch alles neu für mich hier.

    Evtl. hätte ich hier eine Lösung bekomme, statt einen eigenes Thema zu eröffnen

    Edited once, last by Gerry 478 ().

  • Hallo Dellex,


    dreamshader meinte Gerry 478 und nicht Dich. ;)

    Es ist IMHO besser einen eigenen Thread zu erstellen. Oft kristallisieren sich bei einem vermeintilich gleichen Fehlerbild, erhebliche Unterschiede heraus. Dann den Überblick zu behalten und dem jeweiligen User seine individuelle Antwort zu geben ist nicht immer leicht. Deshalb der Hinweis neuer Thread.


    Warum Dein Thread hier als erledigt markiert ist? :conf: Entweder warst Du das versehentlich selbst oder die Frage an dbv macht das die Forensoftware evtl. nach einer Zeit automatisch?

  • dbv

    worauf hyle vielleicht hinauswill: es sind mehrere Threads zum Thema "Subforum in der mobilen Ansicht" als erledigt markiert gewesen, ohne Zutun des jeweiligen TE. Soweit ich das sehe bleibt nach wie vor jegliche Reaktion der Mods und Admins zu dem Thema aus, aber unterstellen will ich euch ja nix :fies:

  • Hallo Dellex,


    ich wollte direkt mal nachfragen, ob die Installation von PHP bei Dir funktioniert hat und mich bei der Gelegenheit auch für den OT entschuldigen! :daumendreh2:

    hyle,

    vielen Dank für deine Hilfe.

    Dein Tipp war prima und hat mir weitergeholfen.

    Ein kleines Problem habe ich noch, ich denke aber es liegt nicht am PHP.

  • Ich habe nach der sehr ausführlichen Anleitung von hailogugo die Komponenten der Jukebox für Kinder installiert.

    Es hat auch alles soweit funktioniert und es gab keine Fehlermeldungen bei der Installation.

    Die Datei latestID.txt wird immer wieder bei jedem Chip erneuert.

    Im Ordner shortcuts habe ich in der Datei die ID ersetzt mit dem Begriff Test.

    Anschließend habe ich im Ordner audiofolders einen Ordner Test neu angelegt und vier mp3-Dateien dort reinkopiert.

    Nachdem ich im Webbrowser die IP-Adresse eingegeben habe öffnet sich die Jukebox.

    Doch leider wird mir dort kein Titel oder Playlist angezeigt.

    Im Bereich letzte eingelesene ID wird auch nichts angezeigt.

    Was mache ich falsch? Hat vielleicht doch mit der Installation etwas nicht richtig funktioniert?


    Natürlich ist mir bewusst, dass nur diejenigen mir weiterhelfen können, die dieses Projekt gut kennen.

    Ich bin über jede Hilfe dankbar!

  • In der Datei latestid.txt ist nur der letzte Code / die ID des Chips drin.


    Im Ordner shortCuts findest du alle Karten bzw. die einzelnen IDs welche du je eingelesen hast. Diese Datei öffnest du mit einem Editor am besten proton oder nano im Linux. In dieser Datei findest du wieder die ID.

    Wenn du in dieser Datei die ID zb. durch test wechselt, versucht die Jukebox aus dem Ordner Audiofiles den Ordner test abzuspielen.


    Je nach dem was du dort für Datein drin hast kann es ein stream oder halt mp3 Datein sein.


    Ich so klappt es.


    wenn du mich mit @ und meinem Namen im Beitrag schreibst sehe ich das du mich angesprochen hast.