Vodafone K3565Z 3G Internet Stick lässt sich nicht mit usb_modeswitch starten

  • Guten Tag lieber Gemeinde,

    Ich habe momentan ein Projekt am laufen und komme irgendwie nicht weiter.

    Ich möchte einen 3G internet Stick auf meinen Raspberry pi zum Laufen bringen und habe diverse Anleitungen ausprobiert, jedoch ohne Erfolg ( zum Beispiel: https://raspberry.tips/raspber…rwenden-mobiles-internet/, https://www.thefanclub.co.za/h…-usbmodeswitch-and-wvdial).

    Bei dem Schritt wo usb_modeswitch nach einem reboot den 3G Stick "umwandeln" müsste,passiert nichts weiteres (es wird keine neue Vendor ID erkannt).


    OS: Raspbian Stretch


    Bus 001 Device 004: ID 19d2:0016 ZTE WCDMA Technologies MSM

    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
    Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    Es bleibt immer bei 19d2:0016

    Mit dem OS Windows 10 funktioniert der Stick.


    Ich wäre euch für vorschläge zum vorangehen sehr Dankbar!!

    Edited once, last by Lyr! ().

  • Die Vendor ID (19d2) bleibt immer gleich. Nur die interne Device id (0016) steht noch auf CD-Rom. Und da gibt es nicht nur eine richtige für das Modem, sondern mehrere, je nachdem, wo der Stick gekauft wirde (O2, Vodafone ...)



    Servus !

    RTFM = Read The Factory Manual, oder so

  • Dankeschön für den Hinweis, gibt es denn eine Möglichkeit mit usb_modeswitch manuell von CD-Rom auf Modem zu wechseln?

  • Ich habe mich etwas damit beschäftig und mit dem Befehl "dmesg" den stick in den raspberry Pi gesteck und bekomme folgende Meldung:

    [19447.393636] usb 1-1.3: new high-speed USB device number 8 using dwc_otg
    [19447.534905] usb 1-1.3: New USB device found, idVendor=19d2, idProduct=0016
    [19447.534920] usb 1-1.3: New USB device strings: Mfr=2, Product=1, SerialNumber=0
    [19447.534928] usb 1-1.3: Product: ZTE CDMA Technologies MSM
    [19447.534936] usb 1-1.3: Manufacturer: ZTE,Incorporated
    [19447.536691] option 1-1.3:1.0: GSM modem (1-port) converter detected
    [19447.537107] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB0
    [19447.537950] option 1-1.3:1.1: GSM modem (1-port) converter detected
    [19447.538494] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB1
    [19447.539335] option 1-1.3:1.2: GSM modem (1-port) converter detected
    [19447.539792] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB2


    Liege ich mit der Annahme richtig, dass usb_modeswitch den Stick gleich als Modem erkennt?

    Ich habe Prompt einen versuch mit WV DIAL gestartet, jedoch ohne Erfolg (evtl Falsche Parameter für die Anmeldung) .

  • Hallo Lyr,


    den zweiten Link von RTFM hast Du nicht gelesen?


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

  • Möglicherweise verlässt der Stick seinen Zero-CD Mode bei Product-ID 0052, oder dem Modem AT Kommando AT+ZCDRUN=8


    https://pandorawiki.org/ZTE_K3565Z_3G_USB_Modem


    Eigentlich lässt sicj so ein Stick auch über den Internen Webserver konfigurieren ( bei mir über http://192.168.0.1/index.html#home ). Bei den Billigversionen ist der interne Webserver abei meist auf ein Minimum eingeschränkt.


    Letzlich könnte auch ein einfaches update der USB Modem Modeswich Liste (in /usr/share/usb_modeswitch) erfolgreich sein, wenn Dein Modem in der aktuellen Liste inzwischen eingepflegt wurde.



    Servus !

    RTFM = Read The Factory Manual, oder so

  • Ich habe nun mit dem AT KOMMANDO bei Windows 10 über putty den Befehl Eingegeben und bekam:


    AT+ZCDRUN=8

    Close autorun state result(0:FAIL 1:SUCCESS):1
    OK


    Wenn ich den Stick in den Raspberry Pi reinstecke und lsusb abfrage erscheint keinerlei Veränderung der ID.
    Über den Webserver habe ich den Stick nicht erreichen können. Wenn ich den Befehl ifconfig eingebe erscheint kein neuer Eintrag oder kein neues Modem.

    Außerdem habe ich bei der 40-usb_modeswitch.rules Datei nach dem Stick gesucht, jedoch nichts gefunden. Ich habe dann einen neuen Eintrag mit Namen, Vendor- und Porduct ID erstellt.


    Ich kann mich daran erinnern, dass ich ein Firmwar-update gemacht habe, vielleicht daher die Umstände?

    Edited 2 times, last by Lyr! ().

  • Ich kann mich daran erinnern, dass ich ein Firmwar-update gemacht habe, vielleicht daher die Umstände?

    Von Vodafone gibt es kein Firmware-Update für diesen Stick und deshalb wird kaum noch ProductID 0x053, noch AT+ZCDRUN=8 erfolgreich funktionieren, sonder die ProductID und der ZeroCD Runlvel des Firmwareprogrammierers. Vielleicht findest Du noch einen Hinweid auf einem Binary der Stick-CD Rom, wenn Du mit einem HexEditor die Files auf der für Windows bestimmten Autorun CD durchschaust.


    Und die udev-Regel für den Stick trage mal schnell wieder aus. Da wird ja jetzt bei jedem Anstecken des Sticks eine falsche Regel ausgeführt. Da würde selbst ein erfolgreiches AT+ZCDRUN=8 , was ja vorzuliegen scheint (Close autorun state result(0:FAIL 1:SUCCESS):1) - 1 = Success, wieder mit einer falschen Regel beim Anstecken des Stix am pi wieder überschrieben.



    Servus !

    RTFM = Read The Factory Manual, oder so

  • Danke für den Hinweis habe die Regel zurückgesetzt.

    Bei Windows wird der Stick nicht als Laufwerk erkannt, es gibt auch keine Installationsdatei nur das geräusch von Windows wenn man ein Usb Gerät hineinsteckt (Im Gerätemanager ist der Stick zu Sehen) - mit dem Programm Join air connectet sich der stick erfolgreich mit dem Internet. Das Firmware-Update war ein Fehler, allerdings ist das wirklich sehr lange her. Ich habe leider auch keine Orginal ISO Datei als Backup. Wäre die Orginale Firmware des Sticks Ausschlaggebend?

  • Natürlich wird bei Windows das autorun von der CD abgearbeitet, dabei festgestellt, dass der Treiber schon auf der Platte vorhanden ist und das CD "Laufwerk" wieder ausgehängt, das wird ja nicht mehr gebraucht. Am Linux kannst Du die CD ansehen, schlimmstenfalls musst Du mit < mount /CD > oder so, nachhelfen. Siehe < man mount >


    Natürlich brauchst Du für den Vodafone ZTE Stick die Firmware von Vodafone fpr die Umstellung mittels PID=0053, weil ja jeder Provider seine eigenen Produkt-IDs für denselben ZTE-Stick erhält. Jetzt kannst Du nur versuchen eine gültige Produkt ID für die Zero CD Entkoppelung zu finden. Oder Du testes alle von 0001 - ffff (hexadezimal) durch.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • Hey Ho, es gibt neues!

    Es war alles richtig eingestellt (idVendor=19d2, idProduct=0016, modus ist Modem), zuvor habe ich den Stick auch unter Windows zum laufen bekommen, anschließend problemlos mit wvdial über den pi.

    Das Problem lag an einem Wackelkontakt der Simkarte, durch einen defekten micro simcard adapterXD

    Mein nächstes Anliegen wird sich um portforwarding eines auf dem pi befindlichen Servers drehen, werde dafür ein neues Thema eröffnen.

    Vielen dank für die Hilfe zum lösen des Problems!