Volumio & zeroW

Ein neuer Artikel wurde veröffentlicht
  • Ich habe schon gegoogelt aber leider nichts zu meinem Problem gefunden. Kennt jemand eine Anleitung wie ich Volumio auf einem zeroW ins Netz kriege? Da der zeroW ja kein Netzwerkanschluß hat, kann ich mich logischerweise nicht über einen Browser anmelden und mein WLAN einrichten (SSID & Passwort). Auf Volumio+zeroW habe ich natürlich Zugriff über Tastatur & Monitor. Wenn ich wüßte wo ich was einzutragen hätte wäre mir schon geholfen.

  • Moin yege,

    Da es dein erster Beitrag ist: Herzlich Willkommen im Forum!

    Da der zeroW ja kein Netzwerkanschluß hat, kann ich mich logischerweise nicht über einen Browser anmelden und mein WLAN einrichten (SSID & Passwort).

    Bei einem ZeroW macht man meistens eine "headless" Einrichtung. Mal als Suchbegriff in einer Suchmaschine eingeben.

    Aber, soviel ich weiß ist Volumio eine eigenständige Distribution. Also muss es dort eingestellt werden

    Auf Volumio+zeroW habe ich natürlich Zugriff über Tastatur & Monitor. Wenn ich wüßte wo ich was einzutragen hätte wäre mir schon geholfen.

    Hast du schon mal auf der Erzeugerseite gesucht??

    Eventuell das durchgelesen??


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein "Like"

  • Vielen Dank für deine schnelle Antwort. Aber ich bin inzwischen ein Stück weiter und der Fehler lag bei mir. Als erstes macht Volumio einen eigenen Hotspot auf. Soweit so gut. Wenn man allerdings im Internet sucht heißt es immer das Passwort ist: volumio. Leider ist das Passwort jetzt: volumio2. Sorry. Ich bin da auf ältere Post hereingefallen.

    Allerdings gibt es ein neues Problem. Ich komme jetzt auf die Einstellungen für das Netzwerk aber er findet mein Netzwerk nicht. Er hängt 30cm neben dem Router und er findet zig Andere. Nur meins nicht. Aber auch das werde ich wohl noch rauskriegen.

  • Netzwerk aber er findet mein Netzwerk nicht. Er hängt 30cm neben dem Router und er findet zig Andere. Nur meins nicht. Aber auch das werde ich wohl noch rauskriegen.

    Hallo yege,


    was mir spontan dazu einfällt: Hast Du eine Fritz!Box (oder ähnlich) , die auf Kanal 12/13 eingestellt ist? Dann könnte es sein, dass das daran liegt.


    Bevor Du die Kanäle in der FB änderst: ich kenne jetzt volumio nicht, habe aber folgendes dazu gefunden.


    Gruss, STF

    "And now for something completely different."

    Dieser Beitrag wurde bereits 4 Mal editiert, zuletzt von STF () aus folgendem Grund: Link repariert...

  • Hallo,

    mit dem Kommando sudo iw list|grep "* 24"|grep "MHz" siehst Du, welche funktionieren.

    wenn Kanal 12 und 13 'disabled' sind, liegt das am Wifi-Country.

    Das Stichwort ist "Regulatory domain".


    Ich sehe mit sudo iw reg get oder mit dmesg | grep "Regulatory" den Wifi-Country.

    Der Code 'DE' steht für Deutschland.


    Beim Raspi kann man mit sudo raspi-config unter "Internationalisation Options => Change Wi-fi Country" den Wifi-Country ändern.

    Schönen Gruß, kle

  • Beim Raspi kann man mit sudo raspi-config unter "Internationalisation Options => Change Wi-fi Country" den Wifi-Country ändern.

    schon, jedoch nicht bei volumio. Das gibts da nicht. Wenn es wirklich daran liegt, dann kann man das so einstellen, wie im Link erklärt.


    Gruß, STF

  • Vielen Dank für eure Hilfe.

    @STF

    Das mit den Kanälen hatte ich auch schon gefunden. Versuchsweise hatte ich meinen Router (D-Link 615 mit ddwrt) auf bestimmte Kanäle eingestellt. Das hatte leider nicht funktioniert.

    kle

    Bei beiden grep Aufrufen erhalte ich keine Meldung und auch keine Ausgabedateien.

    Code
    1. sudo iw reg get

    ergibt:

    Code
    1. country 00:DFS-Unset
    2. (2402-2472@40), (N/A,20), (N/A)
    3. (2457-2482@20), (N/A,20, (N/A), NO-IR
    4. (2474-2494@20), (N/A,20), (N/A, NO-OFDM, NO_IR
    5. (5170-5250@80), (N/A,20), (N/A), NO-IR
    6. (5250-5330@80), (N/A,20), (0ms), DFS, NO-IR
    7. (5490-5730@160), (N/A,20), (0ms), DFS, NO-IR
    8. (5735-5835@80), (N/A,20, (N/A), NO-IR
    9. (57240-63720@2160), (N/A,0), (N/A)

    Deine Tips beziehen sich auf Raspian. Als ich es einmal benutzt hatte, hatte ich es dort auch auf de eingestellt. Bei Volumio gibt es sowas nicht. Aber wenn ihr noch mehr Tips habt würde ich mich freuen. Danke!


    STF

    Deinen letzten Post zu spät gesehen. Ich werde das nachher nochmal probieren einzutragen und nicht nur am Router zu ändern. Muss jetzt los :-).

  • Beitrag von kle ()

    Dieser Beitrag wurde vom Autor gelöscht ().
  • STF

    Ich habe das jetzt mal versucht nach zu voll ziehen was in deinem Link steht.

    1. es gibt keine /etc/default/crda

    2. es gibt keine /etc/wpa_supplicant/wpa_supplicant.conf

    So weit, so schlecht. Um die Datei wpa_supplicant.conf zu erzeugen habe ich über Einstellungen-> Netzwerk-> Manuelle WLAN-Verbindung meine Daten für mein Netzwerk eingegeben. Darauf hin wurde automatisch die „/volumio_data/dyn/etc/wpa_supplicant/wpa_supplicant.conf“ erstellt. Eine „…/default/crda“ gibt es aber auch weiterhin nicht. Dann weiter mit der „wpa_supplicant“ beschäftigt und country=DE eingesetzt (wie im Link gefordert). Restart und es funktioniert. Vielen Dank! Du hast mich in die richtige Richtung geschubst :danke_ATDE:

    Meine wpa_supplicant.conf

    Code
    1. ctrl_interface=/var/run/wpa_supplicant
    2. country=DE
    3. network={
    4. scan_ssid=1
    5. ssid="mein_Netz"
    6. psk="mein_Passwort"
    7. priority=1
    8. }

    Als Hinweis: scan_ssid=0 oder 1 hatte keine Auswirkung. 0 scheint aber die empfohlene Einstellung zu sein.

    hyle

    Ich vermute mal STF ist gleich Bernd :conf: