WLAN Steckdose EDIMAX SP1101W

  • Hallo Gemeinde,


    ich habe ein Problem mit dem anbinden der WLAN Steckdosen von EDIMAX SP-1101W.

    Benutzt habe ich den Code von https://gist.github.com/wendlers/a5fc0bf06bbe656c7291 , in den Kommentaren habe ich schon gelesen ,dass es eine Authänderung mit der neuen Firmware gab.

    Leider bekomme ich aber mit dem angepassten Code ebenfalls keine Verbindung hin.


    Aktueller Status:


    python smartplug.py -H 192.168.43.228 -l admin -p 1234 -s ON

    2017-12-07 17:28:32,729 - DEBUG - Starting new HTTP connection (1): 192.168.43.228

    2017-12-07 17:28:32,764 - DEBUG - http://192.168.43.228:10000 "POST /smartplug.cgi HTTP/1.1" 401 333

    2017-12-07 17:28:32,799 - DEBUG - http://192.168.43.228:10000 "POST /smartplug.cgi HTTP/1.1" 401 333

    Failed to communicate with SmartPlug


    Hat jemand Erfahrung mit diesen Geräten?

  • Hallihallo,


    ich hoffe, meine Antwort ist nicht schon zu spät.

    Ich habe auch eine Edimax Smartplug SP1101-W Steckdose. Ich habe diese zum Laufen bekommen. Funktioniert einwandfrei,

    Zu deinem Fall: Ich habe gelesen, dass im Zuge eines Software-Updates etwas an der Authentifizierungsmethode geändert wurde, wie du schon gesagt hast. Ich habe nach einiger Recherche herausgefunden, dass ein Downgrade der Firmware diesen Fehler behebt, indem man eben auf die alte Methode zurückgeht. Ich habe das getan, es hat reibungslos funktioniert. So sollte der Fehler schnell behoben sein!


    Kommt das für Dich in Frage? Dann würde ich genauere Informationen hinterlassen.


    Gruß

    Ich besitze einen Raspberry Pi 3 unter Raspbian