Zusätzliche Orte im "Speichern unter..." Fenster anlegen

  • Wie kann man zusätzliche Orte im "Speichern unter..." Fenster anlegen unter Raspbian? Wenn ich hier z.B. im Firefox mit der rechten Maustaste "Speichern unter..." wähle, sind auf der linken Seite u.A. diverse Ordner des Pi Users und Datenträger zu sehen die man auswählen kann. Claws hat da einen Eintrag (Favoriten?) Adressbuch eingefügt. Also gehe ich davon aus, das man das auch manuell machen kann. Was ich gerne hätte, ist ein Zugriff auf fritz.nas.

  • Claws ist ein Email Programm. Das hat wohl irgendwas (automatisch?) gemacht, das ein Adressbuch Ort in den "Speichern unter..." Fenster auftaucht. Im PCManFM (Raspbian Dateimanager) ist der Eintrag auch. Daher nehme ich an, das man auch manuell Orte irgendwie hinzufügen kann. Wie macht man das für das "Speichern unter..." Fenster?

  • Hallo daxb !


    Das "speichern unter" Fenster ist normalerweise nur ein Teil eines Dateibtowsers und zeigt die Verzeichnisse (und Dateien) des Filesystems an. Wenn Du in Deinem Home Verzeichnis einen weiteren Unterordner anlegst, wird auch dieser bei "speichern unter" erscheinen. Und Du kannst auch Dein NAS (oder eines seiner Unterverzeichnisse) direkt ins Homeverzeichnis mountenm dann erscheint das NAS-Verzeichnis genauso unter "speichern unter".



    Servus !

    RTFM = Read The Factory Manual, oder so

  • hyle:

    Danke für den Link. Das ist auf jeden Fall eine Alternative und später sicherlich nochmal nützlich.


    RTFM:

    Das scheint mir am einfachsten/besten zu sein. Leider kenne ich noch zu wenig von Linux und habe dort noch nie etwas gemountet. "man mount" hatte ich schon überflogen, aber für den Anfang von den ganzen Optionen erschlagen. Habe es dann nach Internetanleitung über ein /etc/fstab Eintrag versucht:

    //192.168.178.1/Maxtor /NAS cifs username=xxx,password=xxx,uid=pi,gid=pi 0 0

    Anstatt 192.168.178.1 hatte ich auch fritz.nas probiert. Beide male kam eine Fehlermeldung beim booten "Failed to mount /NAS." Mein Aufruf ist sicherlich falsch. Vermutlich die ersten beiden Argumente. "Maxtor" ist die USB Festplattte an der Fritzbox die als NAS Speicher dient. Der Zugriff darauf mit dem Dateimanager funktioniert. /NAS soll pi/NAS sein (siehe unten). Was mache ich falsch?

  • Ok, Danke! In der Anleitung wurde kein absoluter Pfad benutzt und als Anfänger weiss man das natürlich nicht.


    Leider kommt weiterhin eine Fehlermeldung: Failed to mount /home/pi/NAS. Ist vielleicht //192.168.178.1/Maxtor

    falsch? Die IP ist die der FritzBox. Der Zugriff im Dateimanager sieht so aus: smb://fritz.nas/fritz.nas auf fritz.nas/Maxtor

  • Hallo daxb !


    Mit überfliegen der man pages wirst Du Linux nie administrieren können. So hast Du bereits übersehen:


    COMMAND-LINE OPTIONS
    default options: rw, suid, dev, exec, auto, nouser, and async.


    _netdev

    The filesystem resides on a device that requires network access (used to prevent the system from attempting to mount these filesystems until the network has been enabled on the system).


    FILESYSTEM-SPECIFIC MOUNT OPTIONS

    Mount options for cifs

    See the options section of the mount.cifs(8) man page (cifs-utils package must be installed).



    Und bevor Du mit Windows-CIFS auf den NAS mountest, musst Du (narütlich) am NAS einen Mount für den Pi freigeben. Und warum CIFS, kann Dein NAS kein NFS ?


    Servus !

    RTFM = Read The Factory Manual, oder so

  • Mit dem "überfliegen" meine ich auch, das ich nicht alles verstanden habe. Aber 2400 Zeilen sind nicht ohne. Es fehlen halt die Grundlagen. Mit der Zeit sollte das ja besser werden.


    Wie gesagt habe ich das (fstab Eintrag) aus einer Anleitung (Internet) entnommen. Laut der soll es funktionieren. Soll, oder muss die Option _netdev gesetzt sein? Ich hatte keine Ahnung cifs ein Filesystem ist. cifs-utils ist installiert. Die Freigabe am NAS ist schon vorhanden. Warum CIFS? K.A. warum. Was fritz.nas kann weiss ich auch nicht. In der Anleitung habe ich jetzt nichts dazu gefunden. Common Internet File System klingt für mich erst mal nicht schlecht.

  • RTFM Wenn Du 'ne Platte oder einen Stick an die Fritte hängst, dann ist das doch ein einfacher Sambashare oder? Gut, ist bei mir schon eine Weile her, aber hat sich das geändert? Deshalb mein Vorschlag... ;)


    daxb Failed to mount /home/pi/NAS Bitte die genaue Fehlermeldung hier posten! Aber eigentlich dürftest Du keine Fehlermeldung sehen, wenn Du diesen Eintrag in die /etc/fstab gemacht hast?! Zum Testen kannst Du auch:


    sudo mount -t cifs -o username=XXX,password=YYY //192.168.178.1/Maxtor /home/pi/NAS angepasst eingeben. Ob der Pfad //192.168.178.1/Maxtor


    stimmt, kannst nur Du beurteilen... :conf:

  • Hallo daxb !


    Samba Client = CIFS, verbindet sich mit einer Samba(Windows) UID, GID samt Passwort mit einem Samba Server.


    Samba Server = File Server als Teil einer Windows Domain. Wenn kein eigener (Windows) Domain Controller existiert, muss der Samba Server auch die verschlüsselte Authentifizierung der Samba-User abarbeiten, bevor das freigegebene Verzeichnis (Share) einem Samba User durchgereicht wird. Am Samba Client (hier CIFS-mount am Pi), werden die Fileattribute/-Rechte an den mountenden User angepasst.


    Ältere NAS (Samba Server) können mit der aktuellen Authentifizierungsverschlüsselung (Vers.3) noch nicht umgehen. Dann wäre die Option für die ältere Verschlüsselung, laut < man mount.cifs > zu setzen.


    Bevor ein mount Befehl nicht eindeutig richtig funktioniert, hat dieser in /etc/fstab nichts verloren und wäre zu löschen. Genauso kann im Rootverzeichnis schon ein /NAS Verzeichnis entstanden sein, das mit rm /NAS gelöscht werden sollte.


    Zuerst musst Du mit einem mount Befahl die (Samba)username + passwd samt Freigabeordner vom NAS richtig sycronisieren (siehe hyle #12). Fehler werden gleich angezeigt und müssen nicht erst in den Logdateien gesucht werden.


    Und nach jedem Mountversuch sollte ein umount folgen.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • Vielen Dank für eure Hilfe hyle und RTFM!


    Der Fehler war der Pfad zum NAS. Wenn man den weiss, dann ist es einfach und im Nachhinein auch logisch. Richtig ist //fritz.box/FRITZ.NAS, oder die IP anstatt "fritz.box". //fritz.box/FRITZ.NAS/Maxtor weisst dann auf die USB HD, so wie ich das geplant hatte. Problem gelöst. :)


    FRITZ.NAS unterstützt laut Anleitung wohl nur SMB V1.


    Im Root Verzeichnis war tatsächlich ein /NAS Verzeichnis. Habe ich gelöscht. Danke für den Hinweis. Wie kam das dahin? Durch mein Eintrag in /etc/fstab?


    SMB vs. FTP: Mit FileZilla FTP <-> FRITZ.NAS bekomme ich hier nur 1.xMB/Sek.. Über SMB ca. 5MB/Sek.. Eigentlich sollte doch FTP schneller sein, oder? Wie ist denn die durchschnittliche oder theoretisch maximale Übertragungsgeschwindigkeit bei Pi3 + USB Stick <-> LAN <-> 100/1000MBit Switch <-> Router (hier FritzBox)? Kann es sein das der Pi3 + USB Stick die Bremse ist? Ich meine hier gelesen zu haben, das USB und LAN Port sich den Bus teilen.