Amazon Dash und Pi-Hole

  • Hey xXDarkMasterXx


    Leider bin ich auch noch neu auf dem Gebiet weswegen ich dir nicht alle Fragen beantworten kann.


    Werden denn die Verbindungen zu Amazon im PiHole log angezeigt? Bzw wie leitest du den Traffic deines W/Lans auf das Pi-Hole? Per DNS über den Router oder richtest du die Geräte einzeln ein damit sie das PiHole als DNS verwenden? Bei ersterem geht die Anfrage des Dash Buttons ja direkt über das PiHole (Sofern Googles DNS-Server geblockt sind), evt könnte man die Amazonserver direkt damit blocken oder alternativ mit iptable?

    Das wäre zumindest das was ich erstmal probieren würde bevor ich versuche den Pi zu einem Accesspoint zu machen. Wenn das für dich gar nicht in frage kommt einfach ignorieren ;)


    Den DHCP-Server des PiHoles kann man sonst über das Webinterface de-/aktivieren


    Das hier hab ich noch gefunden:

    Quote
    • You must configure the button with the official phone app.
    • It will take an IP from your local DHCP server.
    • After that, it will try to resolve the host parker-gw-eu.amazon.com (here in Europe) from the Google DNS Servers (8.8.8.8, 8.8.4.4).
    • If the Google DNS’s can’t be reached, it will try to resolve the host from your local DNS.
    • After resolving the hostname, it will try an HTTPS connection to it and make the request needed to order the item you configured previously with the App.


    Hacking this behaviour a little:

    • We will configure the button with the Amazon App (Android Play Store or Apple Store), as normal.
    • After using the button for buying some things from Amazon (if you like), we will disassociate it from our Amazon Dash active devices, using the same Amazon App. Don’t push the button yet, because if it can reach to Amazon it will know that it’s not associated to your Amazon account anymore and will reset the configuration.
    • The button is going to take an IP from your local DHCP server, but we must not allow it to connect with amazon servers, so we will not route any packet originated from the device. This way, it will always think that it can’t reach amazon because of network problems, and will try again anytime we press the button.
    • If we disable any outgoing traffic originated from the button, it will resolve the host parker-gw-eu.amazon.com from our local DNS, and our router is going to answer to that query with the IP of our local Linux server running a NodeJS process, in my case a Raspberry Pi.
    • The NodeJS server will be unable to identify itself with a valid HTTPS certificate for the Amazon server, but it will receive the initial connection request from the button, more than enough for us to know that someone pressed the button.

    Ich suche nicht nach einer fertigen Lösung sondern nach dem Weg dahin ;)

    Edited 10 times, last by Apop85 ().

  • Kann mir wirklich keiner weiterhelfen..?

    Entweder es kann keiner oder die die können haben keine Lust, keine Zeit oder zu wenige Informationen. Den Thread zu pushen hilft da nur minimal.

  • Weil du das gateway vergessen hast. (meistens die IP deines routers), ein dns-nameservers eintrag wäre auch nicht schlecht.

    Der Unterschied zwischen Genie und Wahnsinn definiert sich im Erfolg.

  • Beides gleichzeitig geht nicht, das sagt dir auch die Fehlermeldung. Für mich gehören Netzwerksachen nach /etc/interfaces. Systemd sieht das anders. Schon das man in ner Datei namens udhcpd statische IPs eintragen soll, regt mich auf

    Der Unterschied zwischen Genie und Wahnsinn definiert sich im Erfolg.