GPIO bringt keine 3,3V

  • Hi Zusammen,


    ich finde im Netz zu meinem Prob keine Antwort .


    Mein Raspberry Pi 3 Model B (Kauf Ende Nov. 17) mit 2000mA Netzteil bringt an die GPIO's (Output = HIGH) nur max. 1,3V raus, in den meisten Fällen sind es 0,7V oder 0,5V.


    Ich hab 'ne einfache Schaltung mit gelber Diode und 1k Vorwiderstand aufgebaut und die leuchtet nur, wenn ich direkt an die 3,3V oder 5,0V Pins anschließe.

    3,3V bzw. 5,0V - 1k - gelbe LED - GND(6)


    Versuche ich, über verschiedene GPIO's es zu schalten kommt zu wenig Spannung an (gemessen hab ich 0,7V, 0,5V).

    zB GPIO 14 - 1k - gelbe LED - GND(6)


    Über Python hab ich eine BlinkPrg erstellt. Ich kann hier über mein Multimeter die wechselnde Spannung (0V und 0,7V) zwischen GPIO und GND abgreifen. Aber es ist halt zu wenig Saft.



    Warum bringt mein Pi keine 3,3V an den GPIO? Ich hab schon mehrere GPIO's durchprobiert

    - Die 3,3V und 5,0V Pins haben ihre Spannung.

    - Es ist nichts anderes am Pi angeschlossen

    - Ich bin mit dem Pi über RemoteDesktop drahtlos mit PC verbunden


    - Hab ich mein Pi schon verbrannt (Betrieb mit Kühlrippen)? oder

    - Netzteil zu schwach? oder

    - gibt es da noch was, das ich als Newbee nicht kenne? oder oder oder



    danke im Voraus

    Tom



  • es ist von C ein:

    Voltcraft SP-5C Steckernetzeil für PI 3 1462834 / 4016139088686

    Beschriftung des Netzteiles:

    - SWITCHING ADAPTER

    - Model FJ-SW0502000E

    - INPUT: 100-240V AC 60/60Hz / 0,35A

    - OUTPUT: 5V 2000mA

  • Über Python hab ich eine BlinkPrg erstellt.

    Und wie sieht das aus?


    Vermutung ins Blaue, Du schaltest die GPIOs zwar auf high, aber nicht auf Ausgang, dabei aktivierst Du den internen Pull-Up-Widerstand von einigen 10 bis 100kohm, welcher die Spannung zwar ein wenig hochzieht, aber nicht durchschaltet.


    Einschalten der GPIOs zu Fuss: Erst aktivieren, dann auf Ausgang setzen, dann Wert high oder low setzen.


    Und, böser Fehler: Wenn ein GPIO über das Filesystem aktiviert wird, dauert das Aktivieren mitunter bis zu 50msec (gemessen). Wird der GPIO zu zeitig, also innerhalb der 50msec dann als Ausgang gesetzt, wird das nicht ausgeführt und der GPIO bleibt Eingang, mit oben beschriebenen Ergebnis. Führt man die einzelnen Befehle per Hand aus, merkt man das nicht, weil immer mehr als 50msec dazwischenliegen. Laufen sie dann automatisch ab, geht es erstmal, weil der GPIO schon vorher durch die Handaktivierung aktiv war. Beim Neustart geht es dann plötzlich nicht mehr.

  • Btw: Wenn die LED an den 3.3V leuchtet, und der Pi sonst normal funktioniert, und kein Unterspannungssymbol (Blitz) am per HDMI angeschlossenen Monitor gezeigt wird - wirds kaum am Netzteil liegen. Eine LED mit 2mA wird das kaum in die Knie zwingen.

  • Ich vermute (wie Timm Thaler) Du hast einen Fehler im Programm. Du musst den richtigen Pin als Ausgang konfigurieren und auf HIGH stellen. Wenn dein Raspberry noch läuft hast Du auch noch Spannung. Könntest Du mal den Code Posten (in CODE-Tags!) den Du verwendest um die LED an GPIO14 zum blinken zu bringen?

    "Schlechte" Netzteile können aber zu vielen unerklärlichen Phänomenen führen. Damit man dies von vorne herein ausschließen kann, "empfehlen" die meisten das Originale zu verwenden - sobald irgendwas nicht so funktioniert wie es soll...

    ...wenn Software nicht so hard-ware ;-) ...

    Freue mich über jeden like :thumbup:

  • ich hab mal den Pi über HDMI und USB-Maus ohne Remote angesteuert:

    - gleiches Prob, jedoch nur noch 0,28V (auch bei abgestöpselter Maus)

    - kein Blitzsymbol über HDMI


    die Meßwerte hab ich auch ohne die LED, sprich ich greife über die Pins ab

  • Hallo BrotDings,


    und wenn Du in der Schleife statt

    Code
    GPIO.setup(pin, GPIO.HIGH)

    sowas nutzt?

    Code
    GPIO.output(pin, GPIO.HIGH)

    und konsequent dadurch ersetzt? Und dito für den LOW-Pegel? Und auch für Zeile 20...

    Lösche dann Zeile 9...



    Tip: Mit Deinem Code hat der betreffende GPIO-Pin niemals einen HIGH-Pegel bekommen - auch wenn Du das vermutet haben solltest. Weder kann die LED leuchten noch kannst Du einen HIGH-Pegel messen.



    Beschäftige Dich bitte mit den Befehlen einer eingebundenen Bibliothek. Sowas kann leicht ins Auge gehen. Der Raspberry Pi verzeiht in der Hinsicht fast gar nichts.

    Und eine Beschäftigung mit einem GPIO-Pin-Layout wäre auch nicht schlecht, damit der GPIO-Pin laut schreien kann, wenn er gemeint ist.


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

    Edited 6 times, last by Andreas ().

  • Der Fehler ist, wie bereits vermutet, nicht die Hardware sondern die Software


    Probier es damit:

    Desweiteren ist es wichtig dass du GPIO#20 verwenden willst, das wäre Pin#38

  • ja supi - schnurrt wie ein Kätzchen!



    sorry,

    da hab ich euch wegen meinem Schreibfehler im Code genervt.

    Ich war seit dem 24. ziemlich damit beschäftigt und frustriert.


    In meinem Lehrbuch "Die elektr. Welt d Raspberry Pi entdecken" steht es ja mit output. Man wird auch durch Fehler klug.


    Ich bin gespannt, wie das mit dem Gärschrank noch wird. Die PowerLED kann ich schon einschalten, fehlen nur noch ...................



    Auf alle Fälle lasse ich zu Silvester für jeden von euch eine Rakete hochgehen


    Danke

    Tom

  • Hallo Tom,


    das Buch habe ich auch - habe mir aber nie die Python-Codes angeschaut, weil ich in dieser - nennen wir sie mal - Programmiersprache nicht programmiere. Steht das da echt so drin? Oder hast Du das schon wild herumprobiert?



    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - µController-Programmierung in Icon! - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

  • Hallo Andreas,


    auf Seite 216 steht das so (mit output) drin. Wer lesen kann hat Vorteile.


    Ob ich bei Python bleibe oder doch C/C++ mache steht in den Sternen. Python würde mir bei CAD (Allplan Nemetschek) entgegen kommen.


    Zuerst muß ich mich in die Materie einarbeiten. Bis der Gärschrank Realität wird, dauert es wahrscheinlich noch ein Jahr. Genug Zeit zum Ausprobieren und Lernen.



    Gruß aus Bayern

    Tom