SSHFS auf Windows für Datenzugriff auf rPI2

  • Hallo Ihr Lieben,

    nachdem ich meinen rPI2 komplett neu aufgesetzt habe, gibt es ein Problem.


    Ich greife mit meinem Windows-Rechner mit dem SSHFS-Manager (0.0.1.5) normalerweise auf meinen kompletten rPI2 zu.

    Jetzt funktioniert das aber nicht (mehr).


    Egal, was ich mache, ich erhalte die Fehlermeldung:

    "rPI2 could not connect:

    An estabilshed connection was aborted by the software in your host machine." :@;(


    Gibt es irgendeine Möglichkeit, irgendein Log, wo ich im rPI2 die Fehlermeldung nochmal habe und raus bekomme, was genau da passiert ist, dass er mir den Zugriff verweigert? Per SSH mit putty oder SFTP habe ich Zugriff. :daumendreh2:


    Gefunden habe ich den SSHFS-Manager damals dank diesen Beitrags: https://linuxundich.de/gnu-lin…sftp-transparent-windows/

    Bis heute hatte ich weder auf W7, WXP oder W10 keinerlei Probleme.


    Auf dem rPI2 habe ich die aktuelle raspberrian-Version, alles auf dem aktuellen Stand von vorgestern.


    Danke Euch und schonmal einen guten Rutsch in das neue Jahr,

    LG Ralf

    Edited once, last by synth ().

  • An estabilshed connection was aborted by the software in your host machine."

    Und jetzt lesen wir zusammen was da steht: Eine bestehende Verbindung wurde durch die (sshfs) Software auf dem Host-PC abgebrochen.

    Was willst du da auf dem Pi schauen?

    Der Unterschied zwischen Genie und Wahnsinn definiert sich im Erfolg.

  • Hallo Synth.


    Was hast Du gemacht, unmittelbar bevor der Fehler auftrat ? Windows update ? Am Pi etwas installiert, geändert. In den Logfiles kein Hinweis enthalten ?



    Servus !

    RTFM = Read The Factory Manual, oder so

  • dbv ... autsch ... ja hast recht ... ich bin schon blind.


    RTFM ... ich hatte bei einem test-rPI2 wo ich mein neues System drauf aufgesetzt habe versucht das Laufwerk zu mounten. Da war wohl ein Fehler in den Zugangsdaten und danach kam nur noch die Meldung. Also werde ich mal die Software runter schmeissen und neu insallieren. In er Hoffnung, dass da irgendwelche Fehleinträge irgendwo sind.



    EDIT:

    und nein, es wurde auch nix verändert am System. :)
    Ich komme auch auf meinen anderen PI drauf ohne Probleme.


    Allerdings muss es irgendwie dennoch mit dem System zusammenhängen auf dem Pi, weil ich jetzt den Pi gewechselt habe, und die Speicherkarte getauscht habe ... also Ursprungskonfiguration:


    PI1 mit Produktiv-System

    PI2 mit Test-System


    Auf PI2 mit Test-System konnte ich nicht mehr zugreifen, auf PI1 mit Produktiv-System aber schon,

    jetzt habe ich das Test-System in PI1 und es bleibt dabei, komme nicht rauf.

    Und ... eine komplette Deinstallation von sshfs hat nichts gebracht, habe auch die REG gereinigt und sämtliche Files die zu finden waren entfernt. :(

    Werde morgen endilch mal mein Notebook auspacken und mit dem nochmal schauen, ob es läuft.


    THNX für den Anfang, LG Ralf aka synth

    Edited once, last by synth: Nachtrag + weitere Beobachtungen/Infos ().

  • UPDATE 2.1.2018 - sorry wg. Doppelpost, aber sonst bekommts keiner mit.

    Hallo Ihr Lieben,

    so ich habe jetzt endlich mal mein Notebook raus gekramt und auch das meines Vater mir "einverleibt" und selbes Problem. Somit definitiv nicht sshfs das Problem, sondern wirklich der rPI2.

    Ich habe Spaßeshalber die alte microSD mal rein geschoben und siehe da, ich komme wieder drauf.

    Auf der alten ist ein mittlerweile ziemlich verbogenes Wheezy LITE drauf, auf der neuen selbstverständlich ein aktuelles Stretch LITE.


    Gibt es irgendeine Möglichkeit nachzuvollziehen, was bzgl. SSH geändert wurde? Ich habe zwar eine andere Software gefunden, welche das macht, was der sshfs-Manager macht, allerdings ist diese saulangsam, scheint auch einmal komplett den rPI2 zu spiegeln, versucht nämlich erstmal im Laufe der Zeit auf alle Ordner einmal zuzugreifen. Schön ist somit anders.


    Danke, LG Ralf aka synth


    PS: Wünsche allen ein frohes und gesundes neues Jahr!

  • Moin synth,


    win-sshfs-0.0.1.5 stammt aus dem Jahre 2012.

    Ich meine das in den letzten Jahren einiges an SSH gemacht wurde. Ich meine irgendwo gelesen zu haben, das Protokol-Varianten abgeschaltet wurden.

    Was ich sagen will, kann es sein das dein Programm einfach veraltet ist.

    Ich habe mal die Setup.exe geladen und versucht auf einem Windows10 zu installieren.


    Dabei kam dann das.



    Ich habe die Installation abgebrochen, weil es nicht weiter ging.



    Nix für ungut!!1


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.