Pi Zero W läuft nicht mit Software-Kopie von Pi3

  • Moin,


    Ich habe mir gerade einen Zero W gegönnt, um Temperaturen auszulesen und auf 'nem Netzwerklaufwerk der Fritzbox abzulegen...

    So weit, so schön.

    Jetzt habe ich die Software meines bestehenden Pi 3 geclont, den Hostnamen angepaßt und war/bin der irrigen Hoffnung, das die konfigurierte NOOBS-Software jetzt einfach auf dem Zero W läuft...


    Ich habe jetzt leider keinen micro-HDMI-Adapter (oder Kabel), kann also nichtmal gucken, was raus kommt.

    Leider bootet der Zero W nicht mit der Software des Pi 3 soweit, das ich per Netz drauf zugreifen kann.


    Hat irgendwer eine Idee?

    Außer den micro-HDMI nach HDMI Adapter zu bestellen.

    Also: sobald ich die Karte(n) in den PI 3 stecke läuft alles wie gewünscht; beim Zero sehe ich nichts.

    (Natürlich ist der Pi 3 dann nicht aktiv).


    Danke

    Joh

  • Moin Joh,

    erstmal: Herzlich Willkommen im Forum!


    Hast du unter dem RPi3 SSH aktiviert??

    Wieso meinst du das der Zero W nicht bootet??

    Du setzt Noobs ein. Und was wird dann gestartet?



    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Jep, beim Pi3 läuft SSH, eigentlich greife ich nur (wie heute zum testen) selten auf den Monitor zu.


    Eigentlich nur per PuTTy unter Win 7.

    Die Fritzbox findet den Zero W nicht.

    Ein Netscan findet den Zero W nicht.


    Oder kann ich die Software des Pi3 nicht auf dem zero laufen lassen mit der kompletten Konfiguration?

  • PS: die grüne LED des Zero leuchtet; beim Pi3 ist das Dauerleuchten (für mich) das Zeichen, das ich komplett drauf zugreifen kann.

  • Gerade die Micro-SD-Karte wieder in den Pi3 gesteckt: sofort sagt Netscan:

    192.168.0.20 raspberrypi.fritz.box B8-27-EB-63-5B-47 110 ms


    Gruß

    Joh

  • Moin Joh,


    ich habe mit Noobs keine Erfahrung!

    Ich bin mir nicht mal sicher, ob ein System das auf einem Raspberry 3erstellt wurde, auf eine Zero rennt.

    Unterschiedliche CPU!


    Flackert die grüne Leuchtdiode auf dem Zero w?


    Ansonsten hilft nur die "headless-Installation" auf dem Zero w.

    Aber dann, bitte, ohne Noobs, sondern gleich das richtige Betriebssystem nutzen.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • jepp, werde ich machen... wenn ich denn den Micro-HDMI-Adapter bekomme, um zu sehen, was der Zero so macht.


    Das war ja eigentlich die Frage/sollte die Frage sein: läuft das System vom Pi3 auf dem Zero.


    Anfangs blinkend, dann durchgängig.


    Ich werde deinen Rat befolgen und Raspbian ohne NOOBS installieren.

    Damals gab's bei der Installation Probleme und dann habe ich (ähh) einfach NOOBS genommen.

    Die fürchterliche Konfigurationsorgie mit mehrfachen Umpartionierungen hat mich damals schon genervt.


    Joh

  • Die fürchterliche Konfigurationsorgie mit mehrfachen Umpartionierungen hat mich damals schon genervt.

    Bitte was? Wo muss man das denn machen? Ich habe noch NIE sowas machen müssen um nen Pi zu installieren :denker:

    Der Unterschied zwischen Genie und Wahnsinn definiert sich im Erfolg.

  • Bitte was? Wo muss man das denn machen? Ich habe noch NIE sowas machen müssen um nen Pi zu installieren :denker:

    nee, *ich* mußte das nicht machen...

    Mich hat genervt, das NOOBS mir mehrfach das Partitionsschema ungefragt verändert hat und die Daten umgeschaufelt hat.

    Ich hatte mir vorgestellt, ca. 4 GB für das System und 16GB als FAT32-Daten-Partition, damit ich die Daten unter Windows auslesen kann.

    Aber da hat mir NOOBS einen Strich durch die Rechnung gemacht und die Partitionen nach eigenem Gutdünken angelegt..


    Ich wollte nur /schnell/ meine Steuerung des Gärautomaten und das Tool zum Auslesen der Heizungstemperaturen fertig haben; da hat mich der Betriebssystemunterbau wenig interessiert.


    Und das NOOBS mir die Partitionen zerschossen hat, hat einen Vorteil für mich: auf der Suche nach Alternativen fiel mir das integrierte NAS meiner Fritzbox ein; damit habe ich jetzt mit riesigen :) 512MB genügend Speicher für meine RASPI-Programme samt Daten. Wenn mir die SD-Karte abraucht, brauche ich nur noch das Betriebssystem-Image wieder einzuspielen und mich nicht mehr um die Restauration der aktuellen Python-Scripte kümmern.

  • Dann nimmste eben besser kein NOOBS, sondern ein plain Raspbian :fies:

    Es ist nach willst vor ein Rätsel, warum die Foundation jedem am Anfang pauschal erstmal ein NOOBS empfiehlt. Immer wenn's seltsame Probleme gibt und dann jemand "... NOOBS..." sagt, wundert sich keiner mehr...

    Mich würde mal interessieren, ob die da im englischen Forum gar nicht von betroffen sind :conf:

    :wink:


  • Es ist nach willst vor ein Rätsel, warum die Foundation jedem am Anfang pauschal erstmal ein NOOBS empfiehlt.

    Mir jetzt auch ;-)


    i) Das Raspbian draufgespielt

    ii) WLAN-Konfiguration angepaßt

    iii) SSH-Zugriff eingerichtet


    Zugriff wie gewollt, und das sowohl vom Pi3 als auch vom Zero W.

    Danke zusammen. Die Hardware-Konfig muß ich zwar wieder einrichten, aber irgendwas ist ja immer...


    Und nein, ich meine nicht mich damit, wenn ich das Thema abschließe mit ScheiXX NOOBS ;-)


    Joh

  • Als ich "Noobs" gelesen habe, war bei mir schon Schluss .... ;) :D

    ;) Gruß Outi :D
    PIs: 2x Pi B (Rente) / 1x Pi B+ (Rente) / 1x Pi 2 B (Tests) / 2x Pi 3 B (RaspberryMatic / Repetier Server) / 2x Pi Zero 1.2 (J. Lite)
    2x Pi Zero 1.3 (J. Lite) / 2x Pi Zero W 1.1 (Stretch) / 1x Pi 3 B+ (Buster) / 1x Pi 4 B 4GB (Buster)
    Platinen: Sense HAT / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT