Disk Imager schreibt kein Image auf die SD-Karte (für Ubuntu Mate)

Ein neuer Artikel wurde veröffentlicht
  • Hey Leute!


    Ich entschuldige mich gleich im vorhinein, wenn ich in der falschen Sektion poste oder meine Frage schon wo existiert, ich bin aber gerade ganz frisch. Ich komme gleich zu meinen Problem: Ich habe einen Raspberry Pi 3 Model B von einem Freund bekommen, inklusive Retro-Pi auf einer SD-Karte. Soweit, so gut. Jetzt wollte ich mir Ubuntu-Mate installieren, habe mir als Pi-Frischling natürlich einige Tutorials angesehen, etc. Ich habe zuerst Ubuntu Mate von der offiziellen Website runtergeladen (https://ubuntu-mate.org/download/), habe diese mit 7.zip entpackt und wollte es dann mittels Win32 Diskimager auf eine neue SD-Karte spielen (64 GB). Ich erhalte einen etwa 90 sekündigen Schreibvorgang inklusive Erfolgsmeldung, jedoch bleibt die SD-Karte immer leer. Ich bekomme einfach kein Image auf die Karte, bzw. der Pi Startet dann einfach nicht. (Sobald ich die SD-Karte mit RetroPi einstecke, läuft er wieder ohne Probleme).


    Als kompletter Neuling bin ich gerade am Verzweifeln, und ich danke jeden von euch für im vorhinein für die Hilfe!!:)

  • Ich habe zuerst Ubuntu Mate von der offiziellen Website runtergeladen (https://ubuntu-mate.org/download/)

    Ganz blöd gefragt: das Image für den Raspi 2/3?

    habe diese mit 7.zip entpackt

    Prüfsumme stimmt überein?

    neue SD-Karte spielen (64 GB)

    64GB könnte schon grenzwertig sein, keine Ahnung, ob der Pi die immer unterstützt. Probier mal mit 8 oder 16GB. Auch am SD-Kartenleser kann es liegen. 90s scheint mir aber etwas arg schnell.

    jedoch bleibt die SD-Karte immer leer

    Wie genau stellst du das fest? Dein Windows-PC kann mit einer ext4 Partition nichts anfangen, zumindest aber die Boot-Partition (FAT32) sollte erkannt werden.

    bzw. der Pi Startet dann einfach nicht.

    Wie äußert sich das? Was erscheint auf dem Bildschirm, wie verhalten sich die LEDs?


    Ich habe kein Windows, unter Linux ist es ganz einfach mit dd zu erledigen. Wenn du also ein Linux System zur Verfügung hast würde ich das an deiner Stelle bevorzugen. Ansonsten habe ich viel gutes über Etcher gelesen, dieses selbst aber nie getestet. Einen Versuch ist's wert.

  • Danke für die Antwort!

    1. Ja, das image für Raspi 2/3

    2. Wie überprüfe ich die Prüfsumme?

    3. Das die Karte auf dem RetroPi ist, hat auch 64 GB und wird vom Raspi erkannt

    4. Wie ich das feststelle? Ich kann die Karte im Explorer nachwievor auswählen, rechtsklick-eigenschaften, kein Speicher belegt. Außerdem zeigt es nichts an, wie eben ein leerer Datenträger.

    5. Die LED leuchtet Rot, der Bildschirm bleibt schwarz(erhält kein Signal)


    Habe leider nur einen Windows 10-rechner zur Verfügung.

    Was noch verdächtig erscheint, vor dem entpacken hat die Datei ca. 1,2 GB. Nach dem entpacken kommt es nur mehr auf gut 800 MB. Das sollte doch eigentlich umgekehrt sein.

  • Windows zeigt ohne Sondertreiber keine Linuxpartitionen an. Das erklärt, warum deine SD-Karte im Windowsexplorer leer zu sein scheint.


    Das Flashen sollte schon 15 Minuten dauern.

    Mit der ZIP-Datei stimmt etwas nicht, wenn nach dem entpacken das Image nur 800MB groß ist.

  • Was noch verdächtig erscheint, vor dem entpacken hat die Datei ca. 1,2 GB. Nach dem entpacken kommt es nur mehr auf gut 800 MB. Das sollte doch eigentlich umgekehrt sein.

    Ich bin nicht ganz sicher, theoretisch müsste es das in ungünstigen Fällen auch geben können, aber ich kann's mir kaum vorstellen. Ich lade das Image mal eben herunter (dauert noch so 1 min) und schaue selbst, ich berichte gleich. Ist aber merkwürdig.

  • flyppo das ist glaube ich kein ZIP, die Endung ist .xz :conf:

    Da müsste ich suchen, was das ist...

  • Hallo zusammen,


    so:


    Code
    1. tar xvfJ filename.tar.xz


    oder mit 7-zip in der GUI direkt.


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

  • also, ich habe es gerade nochmal runtergeladen, nach dem download entzipt (funktioniert trotz komischer Endung) und das neue image hat jetzt fast 5GB.

    Auch das aufspielen auf die SD-karte hat funktioniert, und Ubuntu Mate installiert gerade. Also war irgendwo ein fehler beim downloaden oder entpacken.

    Danke aber auf jeden fall für eure hilfe!

  • Hallo TPS1992,


    herzlich Willkommen in unserem Forum!


    Hättest Du die empfohlene Checksummenprüfung vorgenommen (in der Regel steht bei jedem Betriebssystem-Download die mit einem angegebenen Programm ermittelten Checksumme), wäre Dir vorher bewusst geworden, dass mit dem Download was nicht stimmt.


    Was ich aber gar nicht verstehe: Ein korrupter Download kann eigentlich nicht sauber entpackt werden. Gab es da keine Fehlermeldung?



    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

  • Ja, genau 5GB stimmt. Das habe ich auch gerade erhalten. Gut, dass es jetzt geht! Bitte noch das Thema als erledigt markieren.


    Andreas : nö. das ist kein .tar.xz, sondern ein .img.xz. Das hat bei mir funktioniert: https://askubuntu.com/a/471225/549598

    Deins hingegen:

    Code
    1. $ tar xvfJ ubuntu-mate-16.04.2-desktop-armhf-raspberry-pi.img.xz
    2. tar: Das sieht nicht wie ein „tar"-Archiv aus.
    3. tar: Springe zum nächsten Kopfteil.
    4. tar: Beende mit Fehlerstatus aufgrund vorheriger Fehler
    5. $