Raspberry kommt nicht ins Internet, ist aber im lokalen Netzwerk normal vorhanden

  • Ich habe rasbian auf meinem Raspberry installiert. Ich komme auch im lokalen Netzwerk über den VNC Viewer mit der eingestellten festen IP drauf.

    Nur komme ich vom Raspberry aus nicht ins Internet.

    Unter Rasbian funktioniert ein Ping auf die Fritzbox problemlos.


    Die /etc/network/interfaces sieht wie folgt aus:

    Hier kann ich keinen Fehler sehen. Wir haben bei uns statische IP Adressen.

    Nach was kann ich noch schauen?

  • Nur komme ich vom Raspberry aus nicht ins Internet.

    Unter Rasbian funktioniert ein Ping auf die Fritzbox problemlos.

    Einstellungen im Router überprüfen.

    Übersetzungen zu Donald Trump:
    Mexikanisch -> El Trump
    Deutsch -> Trampel

    ----------------------------------------------------

    Wenn man sich nur lang genug mit jemandem austauscht merkt man, "Man, so ein Arschloch ist der gar nicht"

  • Nur komme ich vom Raspberry aus nicht ins Internet.

    Unter Rasbian funktioniert ein Ping auf die Fritzbox problemlos.

    Wie sind auf deinem PI, die Ausgaben von:

    Code
    1. ip a
    2. route -n
    3. cat /etc/resolv.conf
    4. ping -c 3 -W 2 9.9.9.9
    5. host -t A heise.de 9.9.9.9

    BTW: Die interfaces-Datei war mal. Mit dem neuen OS, besser systemd-networkd (oder dhcpcd, auch für statische IPs) verwenden.

  • Also zu 1) ip a erhalte ich

    zu 2)route -n

    Code
    1. Kernel IP routing table
    2. Destination Gateway Genmask Flags Metric Ref Use Iface
    3. 0.0.0.0 192.168.0.30 0.0.0.0 UG 0 0 0 eth0
    4. 169.254.0.0 0.0.0.0 255.255.0.0 U 202 0 0 eth0
    5. 192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0

    zu 3)cat /etc/resolv.conf

    Code
    1. # Generated by resolvconf

    zu 4)ping -c 3 -W 2 9.9.9.9

    Code
    1. PING 9.9.9.9 (9.9.9.9) 56(84) bytes of data.
    2. 64 bytes from 9.9.9.9: icmp_seq=1 ttl=57 time=32.8 ms
    3. 64 bytes from 9.9.9.9: icmp_seq=2 ttl=57 time=21.3 ms
    4. 64 bytes from 9.9.9.9: icmp_seq=3 ttl=57 time=96.8 ms
    5. --- 9.9.9.9 ping statistics ---
    6. 3 packets transmitted, 3 received, 0% packet loss, time 2002ms
    7. rtt min/avg/max/mdev = 21.355/50.352/96.847/33.210 ms

    zu 5)host -t A heise.de 9.9.9.9

    Code
    1. ping: unknown host heise.de



    In der Fritzbox habe ich die alte IP rausgeschmissen. Die neue IP erscheint aber unter "ungenutzte Verbindungen" und ich kann auch in den Settings nichts sehen, um dies zu beheben.

    Komischerweise habe ich noch einen Raspberry, der erscheint auch unter ungenutzte Verbindungen und steht so in der Leiste "LibreELEC LAN 3 mit 100 Mbit/s verbunden mit dem anderen Raspberry(der nicht ins I-Net kommt)"

  • Also zu 1) ip a erhalte ich

    zu 2)route -n

    zu 3)cat /etc/resolv.conf

    Code
    1. # Generated by resolvconf

    zu 4)ping -c 3 -W 2 9.9.9.9

    Code
    1. PING 9.9.9.9 (9.9.9.9) 56(84) bytes of data.
    2. 64 bytes from 9.9.9.9: icmp_seq=1 ttl=57 time=32.8 ms
    3. 64 bytes from 9.9.9.9: icmp_seq=2 ttl=57 time=21.3 ms
    4. 64 bytes from 9.9.9.9: icmp_seq=3 ttl=57 time=96.8 ms
    5. --- 9.9.9.9 ping statistics ---
    6. 3 packets transmitted, 3 received, 0% packet loss, time 2002ms
    7. rtt min/avg/max/mdev = 21.355/50.352/96.847/33.210 ms

    zu 5)host -t A heise.de 9.9.9.9

    Code
    1. ping: unknown host heise.de

    PI ohne LL-IP-Adressen konfigurieren bzw. so konfigurieren, dass die DNS-Server in die /etc/resolv.conf eingetragen werden (z. B. mit systemd-network oder mit der dhcpcd.conf).


    Lt. Ping auf 9.9.9.9 ist Internetverbindung vorhanden. D. h. dein PI kommt ins Internet.


    Was hast Du gemacht, weil die Ausgabe von:

    Code
    1. host -t A heise.de 9.9.9.9
    Code
    1. ping: unknown host heise.de

    ist?


    EDIT:


    Wie ist die Ausgabe von:

    Code
    1. nc -zv 9.9.9.9 53

    ?

  • Auf "nc -zv 9.9.9.9 53" erhalte ich


    Code
    1. Connection to 9.9.9.9 53 port [tcp/domain] succeeded!
    2. pi@raspberrypi:~ $


    Auf "host -t A heise.de 9.9.9.9" erhalte ich nun

    Code
    1. Using domain server:
    2. Name: 9.9.9.9
    3. Address: 9.9.9.9#53
    4. Aliases:
    5. heise.de has address 193.99.144.80

    Im Browser kann ich immer noch nichts aufrufen :-(


    Wie kann ich den Raspberry ohne die LL IP Adresse konfigurieren?

  • Im Browser geht es nur mit der IP-Adresse und zwar deshalb, weil in der /etc/resolv.conf. keine DNS-Server für die Namensauflösung eingetragen sind.


    Wie man die LL-IP-Adressen mit der interfaces-Datei verhindert weiß ich nicht.


    Mit der dhcpcd.conf:

    Code
    1. noipv4ll
    2. Don't attempt to obtain an IPv4LL address if we failed to get one
    3. via DHCP. See RFC 3927.

    mit systemd-network:

    Code
    1. IPv4LL=false

    in der *.network-Datei. BTW: Das hat aber mit deinem aktuellen Problem (keine Namensauflösung) nichts zu tun.

  • Danke für eure Antworten, aber ich versteh irgendwie gar nichts mehr und auch nicht, wie/warum das jetzt so ist.


    Also ich komm ins Internet, kann aber keine Seite aufrufen?!


    Wenn ich im Browser 172.217.30.9 eingebe, so wird die IP in http://www.google.com umgewandelt, aber auf der Seite heißt es "This site can't be reached" ERR_NAME_RESOLUTION_FAILED


    Was kann ich jetzt tun? Muss ich den kompletten Raspberry neu aufsetzen oder kann ich "irgendein Paket" für die Netzwerkschnittstelle installieren?

  • Was kann ich jetzt tun?

    Trage die DNS-Server, mit der richtigen Syntax in die interfaces-Datei ein und reboote.


    EDIT: https://wiki.debian.org/Networ…tc.2Fnetwork.2Finterfaces


    Oder mit der Holzhammer-Methode: Die /etc/resolv.conf richtig editieren und für diese Datei, danach das immutable Flag setzen.

  • OK, meine /etc/network/interfaces sieht nun so aus


    Das Internet funktioniert leider immer noch nicht.