Stromversorgung Pi 3 über GPIO / Pin

Ein neuer Artikel wurde veröffentlicht
  • Ich versorge meine RPi3 über Pin 2 und 6 mit >5V aus einem Labor-Netzteil.

    In die 5V-Leitung ist eine Diode vorgeschaltet. Mit ~5,7V kommen 5,05V am Raspi an. Die Schaltung zieht ~ 350mA, sobald der grafische Desktop da ist etwas mehr.


    Trotzdem sehe ich immer den gelben Blitz in der oberen Ecke. Gebe ich noch ein bisschen mehr Spannung, dann startet der Raspi nicht mehr oder rebootet ständig.


    Was mache ich falsch? Das Netzteil sollte ausreichend STrom liefern.

  • Hallo n.nikisch,


    ob Du was falsch machst, kann ich nicht beurteilen. Mich würde erstmal die Diode stutzig machen. Erlaubt diese denn soviel Strom, dass der Raspberry POi sich daran nicht stört?


    Wenn die rote PWR-LED dauerhaft leuchtet, ist dies für mich ein hinreichendes Kriterium einer mindestens ausreichenden Spannungsversorgung.


    Wenn Du feststellen möchtest, ob alle Dienste stromseitig laufen und nicht ständig de- und reaktiviert werden, dann schaue Dir doch mal die Auisgabe von

    Code
    1. dmesg

    an. Stecke mal irgendwas in die USB-Buchse (USB-Speicherstick, WLAN-Stick, ...). Wenn diese Teile nicht ständig de- und reaktiviert werden, dann fließt da auch genug Strom.


    Wenn Du Dir sicher bist, dass alles passt, dann kannst Du auch diesen gelben Blitz / Regenbogen-Quadrat oder was auch immer von Betriebssystem unterstützt wird, abschalten.


    Beste Grüße


    Andreas

    Ich bin wirklich nicht darauf aus, Microsoft zu zerstören. Das wird nur ein völlig unbeabsichtigter Nebeneffekt sein.
    Linus Torvalds - "Vater" von Linux

    • Icon-Tutorials (IDE: Geany) - GPIO-Library - ser. Devices - kein Support per PM / Konversation

    Linux is like a wigwam, no windows, no gates, but with an apache inside dancing samba, very hungry eating a yacc, a gnu and a bison.

  • Oder man ignoriert es. Mein Octoprint Pi (Pi1) hängt auch an nem Schaltnetzteil mit mehr als genug Saft. Auch die Spannung sind ok und es funktioniert alles wunderbar. Trotzdem hab ich auch den Blitz ab und an mal. Da der Monitor meistens aus ist, seh ich ihn aber nicht. Aus den Augen, aus dem Sinn :lol:. Ich glaube, dass es an der Einspeisemethode liegt. Bei GPIO Einspeisung wurde dieses Phänomen schon öfter mal berichtet.

  • Okay! Ich werde mal die Diode überbrücken und erneut probieren

    aber nicht ohne runterzudrehen, 5,7V ist zuviel


    1. Strippen zu dünne

    2. nur ein Pin genutzt, jeder Pin hat Kontaktübergangswiderstand, deswegen an beide +5V und auch an 2x GND einspeisen


    Je mehr Einspeisepunkte genutzt werden umso besser, +5V hat ja nur 2, aber GND gibt es öfter

    lasst die PIs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr