etc/fstab mountet beim start nicht meine nas ordner

  • Hallo Bernd,


    habs genauso gemacht und in der Konsole eingegeben, Ordner wurde gemountet.

    Habe dann noauto rausgenommen und neu gebootet, Ordner wurde nicht gemountet.


    Viele Grüße

    Jürgen

  • Moin StarFriend,


    na siehste. Wieder ein Stück weiter.


    Und was ist wenn du statt noauto auto rein schreibst?


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • diese Fehlermeldung kam zurück


    mount: /etc/fstab: parse error at line 5 -- ignored


    Haste noch eine Idee, haben schon viel ausprobiert, glaube das liegt an was anderem als an der syntax.


    Den pi bediene ich über mein Tablet, ssh client, der user in der Konsole ist pi@raspberrypi


    Viele Grüße

    Jürgen

  • Hallo Bernd,


    so sieht jetzt die zeile in fstab aus


    //192.168.172.35/photo /home/pi/nas/photo cifs user=admin,password=xxxxxxxx,rw,auto,0 2,_netdev,soft,user


    nachdem mounten gibst den bekannten parse fehler

  • Moin Jürgen,


    kannst du mal deine fstab komplett hier posten??


    Wenn das mounten per Hand geht dann sollte es auch automatisch gehen,


    Code
    proc /proc proc defaults 0 0
    PARTUUID=c8a1cea8-01 /boot vfat defaults 0 2
    PARTUUID=c8a1cea8-02 / ext4 defaults,noatime 0 1
    //192.168.1.160/Musik /media/netz cifs user=jemand,password=XXX,rw,auto
    # a swapfile is not a swap partition, no line here
    # use dphys-swapfile swap[on|off] for that

    So, sieht meine /etc/fstab aus.


    Du editierst die Datei aber auf den Raspberry, oder??


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Moin Jürgen,


    und der Editor speichert auch im Unixformat?


    Ich habe mal was entfernt aus deiner Datei.

    Code
    proc /proc proc defaults 0 0
    PARTUUID=17fb45b9-01 /boot vfat defaults 0 2
    PARTUUID=17fb45b9-02 / ext4 defaults,noatime 0 1
    # a swapfile is not a swap partition, no line here
    # use dphys-swapfile swap[on|off] for that
    //192.168.172.35/photo /home/pi/nas/photo cifs user=admin,password=xxxxxxxx,rw,auto,_netdev,soft,user

    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Hallo Bernd,


    habe meine fstab mit deinem inhalt ersetzt.

    Habe danach mit sudo mount -a gemountet und hat funktioniert, diesmal keine Fehlermeldung.

    Habe dann rebootet und der Ordner wurde nicht gemountet, wieder per hand wie oben gemountet, und alles takko.


    Editieren tue ich im nano.


    Gruss Jürgen

  • Moin Jürgen,


    der Parserfehler ist aber nun weg?


    Ich hatte da schon mal nach gefragt. Du hast in raspi-config den Punkt "Warten auf Netzwerk" auf ja gesetzt?

    Hatte ich auch schon nach dem Betriebssystem gefragt?


    So, ich habe es mal genauso wie du gemacht. Und bei mir geht es!


    Ich weiss nicht ob da Fehler drin stehen. Aber wir haben schon soviel getestet. Mach mal sudo systemctl status home-pi-nas-photo.mount


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Hallo Bernd,


    der haken ist in der config gesetzt, als os habe ich stretch.

    Anbei der Inhalt nach der befehlseingabe.

    Werde das gleiche mnochmal machen nach einem reboot, jetzt hatte ich ja von hand gemountet.


    Gruss Jürgen



    home-pi-nas-photo.mount - /home/pi/nas/photo

    Loaded: loaded (/etc/fstab; generated; vendor preset: enabled)

    Active: active (mounted) (Result: exit-code) since Thu 2018-01-25 16:38:53 CET; 35min ago

    Where: /home/pi/nas/photo

    What: //192.168.172.35/photo

    Docs: man:fstab(5)

    man:systemd-fstab-generator(8)

    Process: 602 ExecMount=/bin/mount //192.168.172.35/photo /home/pi/nas/photo -t cifs -o user=admin,password=0238j9042f,rw,_net

    CGroup: /system.slice/home-pi-nas-photo.mount

  • Hi Bernd,


    so sieht es direkt nach dem reboot aus.


    Gruss Jürgen


    home-pi-nas-photo.mount - /home/pi/nas/photo

    Loaded: loaded (/etc/fstab; generated; vendor preset: enabled)

    Active: failed (Result: exit-code) since Thu 2018-01-25 17:19:09 CET; 1min 11s ago

    Where: /home/pi/nas/photo

    What: //192.168.172.35/photo

    Docs: man:fstab(5)

    man:systemd-fstab-generator(8)

    Process: 605 ExecMount=/bin/mount //192.168.172.35/photo /home/pi/nas/photo -t cifs -o user=admin,password=0238j9042f,rw,_net


    Jan 25 17:19:09 raspberrypi systemd[1]: Mounting /home/pi/nas/photo...

    Jan 25 17:19:09 raspberrypi systemd[1]: home-pi-nas-photo.mount: Mount process exited, code=exited status=32

    Jan 25 17:19:09 raspberrypi systemd[1]: Failed to mount /home/pi/nas/photo.

    Jan 25 17:19:09 raspberrypi systemd[1]: home-pi-nas-photo.mount: Unit entered failed state.

  • Moin Jürgen,


    setze bitte in der Zeile am Ende, durch Komma getrennt _netdev. Laut man mount

    Code
    _netdev
    The filesystem resides on a device that requires network access (used to prevent
    the system from attempting to mount these filesystems until the network has been
    enabled on the system).

    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Hallo Bernd,


    hab es so gemacht, hoffe habe dich richtig verstanden, hat aber leider nicht geholfen, kam die gleiche Fehlermeldung wie beim letzten mal.


    Gruss Jürgen


    //192.168.172.35/photo /home/pi/nas/photo cifs user=admin,password=0238j9042f,rw,auto,soft,user,_netdev

  • //192.168.172.35/photo /home/pi/nas/photo cifs username=admin,password=0238j9042f,rw,auto,soft,user,_netdev


    ...und vor rw ein Leerzeichen ohne Komma.


    //Edit:


    In meinem ersten Beitrag #12 hatte ich einen Fehler bei password :wallbash: und möchte fast wetten, dass es jetzt so funktioniert:


    //192.168.172.35/photo /home/pi/nas/photo cifs username=admin,password=0238j9042f 0 0

  • Moin hyle,


    Noe!


    Die fstab ich ich dem StarFriend geschickt habe, rennt so in meinem RPi2b.


    Abgesehen davon wenn er sudo mount /home/pi/nas/photo eingibt, dann wird gemounted.

    Ich vermute das sich sein Wlan zuviel Zeit nimmt.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Hallo Bernd,


    :denker: das Kompendium schreibt dazu:

    //192.168.1.2/SambaPi /home/pi/shares/pi cifs defaults,noauto,nofail,username=pi,passwd=raspberry,x-systemd.automount,x-systemd.requires=network-online.target 0 0

    Evtl. hilfts ja.


    Sorry fürs Einmischen! Ich begebe mich dann wieder in den Hintergrund. ;)

  • Moin Jürgen,


    ich weiß nicht, wie lange dein Netzwerk braucht bis es fertig ist. Ich finde auch nichts das Ganze irgendwie langsamer zu machen.


    Eine "dreckige" Lösung ist folgendes. Ändere die /etc/rc.local so

    Mit der Wartezeit (sleep) kannst du spielen.


    Probier es bitte.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Guten Tag Bernd,


    habe die "dreckige Lösung" ausprobiert und siehe da, es FUNKTIONIERT, habe dann mit den sleep Zeiten gespielt, mal ging es mit 2 oder 3, dann mal wieder nicht, habe es jetzt auf 5 stehen und scheint damit stabil zu sein.

    Ein DICKES DANKE an Dich das Du mir so toll geholfen hast.


    Viele Grüsse

    Jürgen

  • Moin Jürgen,

    das freut mich!


    Dann, bitte, noch dein Thema als erledigt markieren.


    Viel Spaß noch mit dem Raspberry.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Systemd macht alles besser und schöner..haben sie gesagt. Hier sieht man mal wieder schön, das es nicht so ist. Ausser sinnloser Meldungen, mit verweisen auf Befehle die diese Sinnlosen wiederholen kommt da nix bei rum. Das was seit Jahrzehnten funktioniert, klappt zum Glück immer noch.

    Der Unterschied zwischen Genie und Wahnsinn definiert sich im Erfolg.