etc/fstab mountet beim start nicht meine nas ordner

  • Soll heissen das _netdev übergeordnet existiert und somit funktioniert? So würde ich das zumindestens interpretieren.

    Es heisst, dass diese Option nicht vom Dateisystem abhängig ist und somit auch nicht in "man mount.cifs" zu erwarten wäre.

    Gemäß man systemd.mount müsste systemd das korrekt handhaben, aber wie das mit Konjunktiven so ist...

    " […] if you give a man a fish he is hungry again in an hour. If you teach him to catch a fish you do him a good turn."

  • Die Fehlermeldung ist eindeutig. Da liegt ein Kopierfehler vor. Die Zeile "ExecStart" wird leider oben im Codeblock zweizeilig angezeigt, aber es es nur EINE lange Zeile... bis einschließlich exit 1'

  • Es heisst, dass diese Option nicht vom Dateisystem abhängig ist und somit auch nicht in "man mount.cifs" zu erwarten wäre.

    Gemäß man systemd.mount müsste systemd das korrekt handhaben, aber wie das mit Konjunktiven so ist...

    Richtig, und systemd handhabt das auch korrekt.. es verlegt den Mount hinter "network-online.target"... ganz genau so, wie man das erwarten kann. Aber das so eine Netz-Verbindung notwendig ist und auch tatsächlich steht, ist eine individuelle Angelegenheit allein dieses Systems... individuell so von mir als Admin vorgegeben und eingestellt... was quasi ein Eingriff in den Default-Zustand des Systems darstellt, bei dem in der fstab anfangs keine Net-Mounts eingerichtet sind.


    Wieso sollte sich systemd um von mir (privat) vorgegebene Abhängigkeiten kümmern? Wo zieht man da die Grenze? Habe ich ein NAS, oder zwei, oder drei, auf wieviel isolierte Subnetze verteilt? Sind diese NAS lokale Geräte, oder auch via Web? Und dann noch vor dem Hintergrund, dass Leute immer wieder nachfragen "Wie mach ich das, weil ich mein NAS aus Stromspargründen immer bei Nichtgebrauch abschalte?" Systemd handhabt das imho vor dem Hintergrund, dass es NUR ein Init-System für den Rechnerstart ist m.E. perfekt, vor allem auch deshalb, weil es nicht wie sysvinit den kompletten Boot blockieren würde, wenn man allein für einen Prozess zwingend aufs Netzwerk warten will. Nur hat eben der Parameter _netdev keine explizite Bedeutung oder sonst irgend einen Einfluss. Ob der da ist oder nicht, ist das selbe.

    Edited once, last by ThomasL ().

  • Die Fehlermeldung ist eindeutig. Da liegt ein Kopierfehler vor. Die Zeile "ExecStart" wird leider oben im Codeblock zweizeilig angezeigt, aber es es nur EINE lange Zeile... bis einschließlich exit 1'

    Hallo Thomas,

    danke für die Antwort.

    Die betreffende Zeile war zwar correct, aber ich hatte die Leerzeilen vergessen, jetzt geht zumindest der erste schritt schon.


    Danke

    Nils

  • Hallo,

    ich habe es jetzt mal ne Nacht durchgelaufen und mein Problem aus dem anderen Thread schein erledigt zu sein.

    Vielen Dank an ThomasL für die Tipps und heißen dank für den Hinweis auf diesen Thread.


    Es scheint wohl beim reconnect ein Problem mit dem DNS zu sein, das ist wohl durch ansprache der IP behoben.


    liebe grüße

    Nils