Raspberry Pi 3: externer WLAN adapter

  • Hallo Experten

    ich muss wegen Interferenzen den built-in WLAN Adapter gegen einen externen "ersetzen", nachdem

    mein RPI mit WLAN einwandfrei funktioniert hat:

    Habe verschiedenste Foren Beiträge gelesen:


    1. Habe dann zuerst in /boot/config.txt die Zeile dtoverlay=pi3_wifi-disable eingetragen

    und damit offensichtlich das Wi-Fi System ausser Betrieb gesetzt.


    2. Auch nach Löschen dieser Zeile und -zum Versuch - mit der Eingabedtoverlay=pi3-wifi-enable 

    abeitet weder der built-in noch der per USB angeschlossene WLAN Adapter. Beim Letzteren

    leuchtet nicht einmal die kleine blaue LED.


    3. Der Eintrag in /etc/modprobe.d/raspi-blacklist.conf von blacklist brcmfmac blieb ohne Effekt

    (sollte angeblich den driver für das built-in Wi-Fi ausser Betrieb setzte zugunsten des Externen)


    4. in /etc/network/interfaces steht;

    Code
    auto lo
    iface lo inet loopback
    
    iface eth0 inet manual
    allow-hotplug wlan0
    iface wlan0 inet manual
    wireless power off
    wpa-ssid "meine Netzwerk ssid"
    wpa-psk "mein Netzwerk Passwort"

    ifdown wlan0 ergibt:


    Code
    ifdown: interface wlan0 not configured

    ifup wlan0 ergibt:

    Code
    wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
    run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
    ifup: failed to bring up wlan0

    lsusb ergibt, dass der externe WLAN Adapter erkannt wird:

    Code
    Bus 001 Device 005: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
    Bus 001 Device 004: ID 046d:c52b Logitech, Inc. Unifying Receiver
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
    Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    ip l ergibt:

    Code
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    2: enxb827eb382e85: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000
        link/ether b8:27:eb:38:2e:85 brd ff:ff:ff:ff:ff:ff
    3: wlx74da388bccd8: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DORMANT group default qlen 1000
        link/ether 74:da:38:8b:cc:d8 brd ff:ff:ff:ff:ff:ff

    und iwlist wlan0 scan | grep -i ssid zum Abschluss ergibt:

    Code
    wlan0     Interface doesn't support scanning.

    Bin nun am Ende meines Lateins ????

    Luemar

  • Moin luemar,

    2. Auch nach Löschen dieser Zeile und -zum Versuch - mit der Eingabedtoverlay=pi3-wifi-enable


    wie es aussieht hast du 2 Probleme. Was willst du denn nun als erstes erledigen??


    Das interne Wlan wieder an

    den externen Stick in Betrieb nehmen


    Gruss Bernd


    ps.:

    2. Auch nach Löschen dieser Zeile und -zum Versuch - mit der Eingabedtoverlay=pi3-wifi-enable


    Wo hast du den den Eintrag gefunden?? Oder mal ausgedacht??

    Habe fertich

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

    Edited once, last by Bernd666 ().

  • Ja Hallo Bernd,

    Habe endlich herausgefunden, warum mein PIR jeweils im 120 sec Abstand "spontan" und

    endlos ausgelöst wurde, und zwar an einem RPI 2B+ wie 3: Durch Interferenz des am USB Anschluss liegenden

    oder eingebauten WLAN Adapters mit dem PIR !

    Das Interferenz Problem ist beseitigt - habe es getestet - wenn der Adapter über ein USB Kabel

    min. 1 Meter entfernt von PIR oder RPI (Gehäuse) liegt.
    Deshalb will ich meinen RPI 3 so mit einem externen WLAN Adapter betreiben und muss dann wohl

    zuerst den Eingebauten deaktivieren ?


    Die Einträge, die ich in meinem ersten post beschrieben habe in

    /boot/config.txt und

    /etc/modprobe.d/raspi-blacklist.conf

    habe ich gefunden auf:

    https://www.raspberrypi.org/fo…ewtopic.php?f=63&t=138610.


    Einen schönen Sonntag, Luemar.

  • Moin luemar,


    wenn du Lust hast und was Lernen willst, dann kann ich dir einen Weg zeigen. Du übersetzt dir den Treiber.


    Wichtig ist zu wissen welcher Baustein in dem Stick verbaut ist.

    Am einfachsten bekommt man das folgendermassen raus.

    Wlanstick abziehen. Ein Terminalfenster/Konsole öffnen. Dort sudo journalctl -f eingeben und den Stick einstecken. Dabei sollte u.a. sowas rauskommen.

    Code
    usb 1-1.4: New USB device found, idVendor=7392, idProduct=7811
    Code
    7392:7811

    Diese Zahlenkombination ist eindeutig. Damit eine Suchmaschine füttern und den Baustein finden.


    Wenn, beim Kauf, eine CD dabei war, nachsehen ob ein Linuxverzeichnis mit Sourcecode drauf ist.


    Dann sehen wir weiter.


    ich habe das schonmal mit einem User gemacht. Ich suche gerade die Seite raus.


    Gruss Bernd


    Hier der Link .

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

    Edited once, last by Bernd666 ().

  • Hallo Bernd,

    habe an meinem anderen RPI den Code gefunden: Erste Zeile: idVendor=7392 idProducht=7811

    Auf der 2. Zeile steht dann 00e04c000001. Wenn ich die erste Zeile google komme ich unter anderem

    auf diese "Unterhaltung" und andere Foren Beiträge zu diesem Thema.


    Auf meinem anderen RPI deshalb, weil ich den RPI, um den es geht plötzlich nicht mehr starten konnte, die

    SD Karte war "futsch", nicht zum ersten Mal,
    Frage: Ist booten von einem USB Stick auf Dauer nicht sicherer als mit einer SD Karte, von denen man immer wieder

    über Probleme hört ?


    Habe diesen nun mit einer neuen SD Karte neu aufgesetzt und beim Konfigurieren meine SSID und Passwort in

    N2 Wi-fi unter 2 Network Options in raspi-config eingegeben, die Datei /etc/network/interfaces aber

    noch leer gelassen.
    Wie weiter ? Luemar

  • Hallo luemar,


    also, nochmal alles auf Anfang, ich glaube, hier ist einiges durcheinander.


    1) Wenn ich das richtig verstanden habe, hat der von Dir verwendete WLAN Adapter (nämlich der hier, oder?) bereits funktioniert. Wenn ja, dann brauchst Du für diesen Stick auch keine extra Treiber, schon mal gar nicht irgendwas selbst kompilieren.


    2) Du möchtest das interne WLAN eines RPi3 (wegen der Interferenzen) ausschalten und stattdessen den Stick an einer USB Verlängerung verwenden? Kein Problem.


    3) Welches System hast Du verwendet? (Raspbian oder Raspbian lite?) Bei Raspbian mit Pixel kannst Du den WLAN Zugang über die Oberfläche einrichten, per Kommandozeile u.a. mit lite so (Variante 2)


    4) Wie ist das passiert, dass das Dateisystem auf der Speicherkarte hinüber war? Im laufenden Betrieb Strom weg, oder? microSD Karten sind durchaus empfindlicher als die meisten Sticks, aber auch bei intensiver Nutzung habe ich bisher nur 3 Karten geschrottet (2 x noname Chinaware, 1 x lexar aus'm Mediamarkt. In den meisten Fällen ist "nur" das Dateisystem beschädigt.


    Gruß, STF

  • Moin luemar,


    ich setze eine neue Karte immer so auf.

    - Image auf Karte schreiben. Karte einmal ziehen stecken, damit sie erkannt wird.

    - Einen Dateiexplorer, kann auch unter Windows, öffnen.

    - Für Windows. es ist nur eine Partition sichtbar. Dort ein leeres Textdokument mit dem Namen ssh erstellen.

    - Für Linux bitte die Partition boot nehmen. Dort auch die Datei erstellen.

    - Von einem funktionierenden Raspberry die /etc/wpa_supplicant/wpa_supplicant.confkopieren. Achtung, geht nur mit root-Rechten! Diese Datei auch in die Boot-Partition kopieren.

    Falls man keine hat dann mein Beispiel anpassen.

    Und nun kann/farf man die Karte entfernen und in einem Raspberry stecken und mit Spannung versorgen.

    nach einem längeren Moment sollte er sich ins Wlan eingebucht haben und man kann mit ssh den Kontakt aufnehmen.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Moin,

    ich habe bei meiner Volumio-Installation ein ähnliches Problem gehabt.


    Pi3 internes WLAN aus:

    config.txt auf der SD-Card bearbeiten

    dtoverlay=pi3-disable-wifi

    einfügen

    nach Reboot kein WLAN mehr


    externes WLAN ein:

    WLAN-Stick Edimax stecken, reboot, WLAN läuft wieder


    Gruss

    Kurti

    Die beste Funkverbindung ist immer noch ein Kabel.

  • Hallo Bernd,

    1. Ja, der WLAN-Adapter - genau der EDIMAX - hat an einem anderen RPI seit längerer Zeit problemlos funktioniert.

    2. So ist es, den internen WLAN Adapter abschalten, einen Externen - eben dieser EDIMAX - einschalten.

    3. Verwende Rasbian und habe bis anhin nur über das Kommandofenster gearbeitet.


    Zum Kommentar von Kurti: Gemäss meinen Recherchen hiess der Befehl dtoverlay=pi3-wifi-disable und nicht umgekehrt. Diesen Befehl hatte ich am Anfang in /boot/config.txt eingegeben und dann ging nichts mehr. Vielleicht ist Kurti's Version richtig.


    Dein Vorgehen zum Aufsetzen der SD Karte war mir unbekannt:
    a) habe ich bis jetzt alle SD Karten nach Beschreiben mit dem Rasbian image sofort in des RPI gesteckt und denselben gebootet.
    Ich dachte ich müsste (wirklich ?) Router-SSID und -Passwort zuerst im Menu raspi-config eingeben. Aber diese Angaben stehen ja ja auch in /etc/network/interfaces, wobei ich dort jeweils nur wpa-ssid und wpa-psk eingetragen habe - gemäss der Anleitung des Elektronik-Kompendiums https://www.elektronik-kompend…/raspberry-pi/1912221.htm - in der Meinung ohne /etc/wpa_supplicant/wpa_supplicant.confauskommen zu können, da mein RPI nur mit einem Router kommuniziert.

    b) Eine SD Karte mit Rasbian kann ich an meinem PC (W10) nicht öffnen, es kommt die Aufforderung zum Formatieren

    und die Mitteilung, das Dateisystem könne nicht gelesen werden.
    Etwas viel Text aber bin nun sehr zuversichtlich, Luemar.

  • b) Eine SD Karte mit Rasbian kann ich an meinem PC (W10) nicht öffnen, es kommt die Aufforderung zum Formatieren

    und die Mitteilung, das Dateisystem könne nicht gelesen werden.

    Da hatter recht, der Win10PC. Er ist tatsächlich zu doof, mit Bordmitteln das ext4 Dateisystem der zweiten Partition zu lesen. Es gibt dafür extra Treiber, falls es mal not tut. Kaputt ist jedoch dadurch noch lange nüscht. Zumindest so lange, wie man der Aufforderung zum Formatieren nicht nachkommt... aber das macht man ja nicht.


    Gruß, STF

  • Moin!


    So steht es in der README für overlays.


    Quote

    Name: pi3-disable-wifi

    Info: Disable Pi3 onboard WiFi

    Load: dtoverlay=pi3-disable-wifi

    Params: <None>



    Dann habe ich meine Windows 10 Maschine angeschmissen und eine SD-Karte mit Raspbian angeschlossen. Ich sehe ein Laufwerk H: das BOOT heisst!!


    Ich wei? das es auch mit Einträgen in der interfaces geht. Es ist aber nicht mehr der Weg!


    Was ich nun verstanden habe, ist, es geht nun alles. Richtig?


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

    • Official Post

    Eine SD Karte mit Rasbian kann ich an meinem PC (W10) nicht öffnen, es kommt die Aufforderung zum Formatieren

    und die Mitteilung, das Dateisystem könne nicht gelesen werden.


    Dann solltest Du entweder den Cardreader oder das OS austauschen oder einen funktionierenden SD-Adapter nehmen, denn die Partition namens boot müsstest Du sehen. :shy:

  • Dann solltest Du entweder den Cardreader oder das OS austauschen oder einen funktionierenden SD-Adapter nehmen, denn die Partition namens boot müsstest Du sehen. :shy:

    Ja klar, die FAT Partition sollte in jedem Fall zu sehen sein. Win10 jault aber trotzdem, weil es nicht klar kommt.

    • Official Post

    Win 7 bringt bei mir die selbe Meldung ich solle formatieren bei bestimmten Adaptern. Der Einzige der funktioniert ist einer, der einer Transe Transcend beilag. Das ist der Punkt, denn vermutlich ist dieser Adapter etwas dicker und kommt an alle Kontakte meines Billigcardereaders. :denker:

  • Hallo Bernd,

    nein, leider wieder auf Feld eins:

    Wollte ein Script schreiben mit Python, nach Unterbruch plötzlich eine Reihe von Fehlermeldungen, konnte

    Script nicht regulär beenden, RPI reagierte auf keinen Befehl, nach Stromunterbruch kein booten möglich.

    Langsam habe ich die Nase voll.
    Beginne nochmals von vorne.

    P.S. Mein card reader funktioniert (für Fotos) und ich verwende Transcend Adapters.
    Luemar.

  • ...das geht leider auch nicht mehr, mein W10 verweigert die erneute Formatierung um Rasbian nochmals neu zu

    laden.


    Eine andere SD-Karte wird jetzt als Laufwerk boot(G:) erkannt und zeigt eine Reihe Dateien (whs. entzipte) an mit 2 Datenträgerimages: kernel.img und kernel7.img aber der RPI bootet nicht damit.

    Versuche den neu zu formatieren und mit Rasbian zu laden.
    Luemar.

  • Hallo Bernd, es wird immer chaotischer:

    1. der Karten Halter war abgebrochen, der RPI 3 wird ersetzt.

    2. SD_Karten:

    2.1 Die SD Karte(1) die beim "Absturz" verwendet wurde wird von W10

    als SD Card (G:) angezeigt, ist nicht mehr formatierbar, kann nicht geöffnet werden und kann meinen anderen RPI 2B+ nicht booten, die grüne LED leuchtet konstant.


    2.2 Eine neue SD Karte(2) wird von W10 korrekt angezeigt mit Logo boot (G:) mit den Dateien

    die ich oben erwähnte. Allerdings konnte ich den RPI 2B+ erst nach wiederholtem Schreiben des raspbian-stretch.imgmittels Etcher booten, hatte nach dem ersten Schreiben bzw. Validieren

    die Meldung (abgekürzt): "Schreiben erfolgreich, potentielle Daten Korruption entdeckt, Empfehlung das image auf einen anderen Drive zu schreiben"


    2.3 Aber jetzt bricht der boot Vorgang mit der genuinen RPI-2B+-Karte im RPI 2B+ immer an der selben Stelle ab, da ist wohl Chaos !!!
    ?????


    3. Weiteres Vorgehen:

    3.1Ich kann a) eine neue SD Karte besorgen und nochmals von vorne anfangen, das hat ja schon mehrmals funktioniert oder b) ich kann mir eine mit NOOPS vorinstallierte Karte besorgen.


    3.2 Wenn der RPI 3 dann wieder "läuft" werde ich den internen WLAN Adapter in /boot/overlays mit dtoverlay=rpi3-disable-wifi ausschalten, den EDIMAX anschliessen und in /etc/network/interfaces eingeben


    Code
    auto lo
    iface lo inet loopback
    
    iface eth0 inet Manual
    
    allow-hotplug wlan0
    iface wlan0 inet Manual
    wireless power off
    wpa-ssid "meine Netzwerk ssid"
    wpa-psk "mein Netzwerk Passwort"
    1. ist das so richtig richtig ? Luemar