Raspberry 3 als Bridge (Wlan zu Lan)

  • Danke für deine Unterstützung, aber es funktioniert nicht.

    Wahrscheinlich mache ich irgendetwas grundsätzlich falsch. Ich habe zum testen mein Laptop mit dem RPi per LAN Kabel verbunden.

    Das Laptop bekommt aber keine IP Adresse zugewiesen.

    Mein Gateway (FritzBox) 192.168.178.1

    Der RPi hat eine feste IP 192.168.178.12 WLan

    Die Lan Buchse eth0 sollte dann eine IP aus dem Bereich 192.168.178.15 bis 192.168.178.20 bekommen.

    Code
    dhcp-range=192.168.178.15,192.168.178.20,24hdhcp-option=option:dns-server,192.168.178.1

    Frage, müsste der DNS-Server für das Lan nicht eigentlich der RPi sein? Nach der obigen Konfiguration ist es ja meine Fritzbox.

    Files

    • ifconfig.txt

      (2.56 kB, downloaded 90 times, last: )

    Raspberry pi 3 Model B , Zero WH , NodeMCU

  • Nein, denn der dnsmasq wird nur als dhcp Server benutzt. Auch macht es i.d.R. keinen Sinn mehrere dns Server in einem HeimNetz zu haben. Deshalb steht da Dein Heimserver als dns drin ;)


    Der dnsmasq schreibt in /var/log/syslog wenn er einen dhcp Request von Deinem Lappi reinbekommt und welche IP er rausgibt. Sieh mal nach was Du da im Log findest.

    Sichere Deine Raspbberry regelmäßig mit raspiBackup . Sicher ist sicher ;-)


    Darum gebe ich keinen Support per PN


    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Benedict Torvalds, 28.9.2003


  • wenn ich die syslog richtig interpretiere 192.168.3.1

    Das kann aber nicht sein.

    Ich kontrolliere gleich mal die dnsmasq.conf

    * * *

    EDIT: Fehler gefunden, in der dhcpcd.conf war noch ein alter Eintrag mit static ip für eth0

    Das habe ich gelöscht.

    Trotzdem wird eth0 keine IP aus dem Adressbereich 192.168.178.XX zugewiesen.

    Sobald ich mein Laptop verbindet bekommt eth0 die IP 169.254.93

    Files

    • syslog.txt

      (3.85 kB, downloaded 99 times, last: )

    Raspberry pi 3 Model B , Zero WH , NodeMCU

    Edited 2 times, last by RalleB ().

  • Nein. Das ist OK. Das ist Dein eth0 Interface was die 192.168.3.1 IP bekommt. Ich habe mich vertan :blush: Die Meldungen siehst Du nur wenn Du manuell den dnsmaq startest. Also:

    Code
    sudo service dnsmasq stop
    sudo dnsmasq -dd -C /etc/dnsmasq.conf

    Sichere Deine Raspbberry regelmäßig mit raspiBackup . Sicher ist sicher ;-)


    Darum gebe ich keinen Support per PN


    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Benedict Torvalds, 28.9.2003


  • Das sagt mir nichts:


    dnsmasq: gestartet, Version 2.76, Cachegröße 150

    dnsmasq: Übersetzungsoptionen: IPv6 GNU-getopt DBus i18n IDN DHCP DHCPv6 no-Lua TFTP conntrack ipset auth DNSSEC loop-detect inotify

    dnsmasq-dhcp: DHCP, IP-Bereich 192.168.178.16 -- 192.168.178.20, Lease Zeit1d

    dnsmasq: lese /etc/resolv.conf

    dnsmasq: Benutze Namensserver 192.168.178.1#53

    dnsmasq: /etc/hosts gelesen - 5 Adressen

    Raspberry pi 3 Model B , Zero WH , NodeMCU

  • Das sind die Startmeldungen. Wenn Du Deine Lappi anschliesst kommen keine weiteren Meldungen? Was hast Du denn auf Deinem Lappi am laufen? Windows? Kann es sein dass die FW die DHCPRequests zur Raspi blocked? Ist vielleicht das Kabel nicht in Ordnung?

    Sichere Deine Raspbberry regelmäßig mit raspiBackup . Sicher ist sicher ;-)


    Darum gebe ich keinen Support per PN


    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Benedict Torvalds, 28.9.2003


  • Ja, da läuft Windoof 10. Ich teste das nachher mal mit meiner IP Kamera. Die müsste das ja die IP 192.168.178.16 bekommen.

    Dafür muss ich aber erst mal ein paar umbauten machen.

    Raspberry pi 3 Model B , Zero WH , NodeMCU

  • Haralds FYI: Diesen Kommentar schreibe ich über eine Ethernet -> WLAN Bruecke. Es geht also :bravo2:


    Dazu habe ich aber ziemlich viel manuell an der Raspi umkonfigurieren muessen. Jetzt muss ich mal sehen wie man dass alles einfach erklärt und vor allen Dingen persistiert. Sobald ich meine Raspi jetzt restarte tut nichts mehr :no_sad:


    Da Dein Thema ja nichts mehr mit dem Originalproblem (LAN zu WLAN Router) zu tun hat möchte ich Dich bitten einen neuen Thread mit dem richtigen Titel zu erstellen (LAN zu WLAN Bruecke). Ich werde dann dort weiter berichten ;)

    Sichere Deine Raspbberry regelmäßig mit raspiBackup . Sicher ist sicher ;-)


    Darum gebe ich keinen Support per PN


    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Benedict Torvalds, 28.9.2003


  • Ich habe jetzt einiges getestet, aber der RPi gibt keine IP Adresse an eth0 im Bereich192.169.178.xx

    sondern diese IP 169.254.xxx.xxx

    Wo die herkommt weiß ich nicht.

    dhcpcd.conf und /etc/network/interfaces habe ich kontrolliert aber nichts auffälliges gefunden.

    Raspberry pi 3 Model B , Zero WH , NodeMCU

  • Die IP bekommt Dein Lappi wenn der DHCP Request nicht erfolgreich ist. Du hast ja auch keinen Request gesehen als Du den dnsmasq manuell gestartet hast. Bist Du sicher dass Dein Kabel OK ist? Als ich das bei mir für Stretch getestet habe hatte ich auch erst aus Versehen ein ISDN Verbindungskabel erwischt wo nicht alle Anschluesse durchgeschleift waren und mich gewundert dass kein DHCP request in die Raspi reinkommt :wallbash:

    Sichere Deine Raspbberry regelmäßig mit raspiBackup . Sicher ist sicher ;-)


    Darum gebe ich keinen Support per PN


    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Benedict Torvalds, 28.9.2003


  • Das Netzwerkkabel habe ich vorsichtshalber getauscht, daran liegt es leider nicht.

    Ich habe morgen etwas Zeit und werde dann Stretch noch mal neu auf die SD-Karte kopieren und das ganze noch einmal versuchen.

    Wenn es bei dir funktioniert sollte es auch bei mir gehen. Wenn nicht dann :@

    Raspberry pi 3 Model B , Zero WH , NodeMCU

  • Bei mir funktioniert es. Hilft Dir nicht - ich weiss;) aber um ganz sicher zu gehen gehe ich meine Anleitung auch noch mal auf einem nackten Stretch durch.

    Sichere Deine Raspbberry regelmäßig mit raspiBackup . Sicher ist sicher ;-)


    Darum gebe ich keinen Support per PN


    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Benedict Torvalds, 28.9.2003


  • Mir ist aufgefallen dasss ich eine Sache noch vergessen hatte zu beschreiben :blush: Du musst in Deinem Internetrouter noch eine statische Route zu Deinem Raspberry Router fuer das 192.168.3.0/24 er Netz vornehmen. Ansonsten können Deine angeschlossenen Clients nicht ins Internet, denn sie finden nicht ihren Weg zurück ins Subnetz. Diesen Fakt habe ich eben noch in der Anleitung ergänzt.

    Sichere Deine Raspbberry regelmäßig mit raspiBackup . Sicher ist sicher ;-)


    Darum gebe ich keinen Support per PN


    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Benedict Torvalds, 28.9.2003


  • framp,

    vielen Dank für deine geduldige Unterstützung aber ich komme nicht richtig voran und beende das ganze erst ein mal obwohl ich schon fast auf der Zielgeraden bin.

    Ich kann mein Windows-Laptop das am eth0 angeschlossen ist von meinen PC anpingen. Allerdings mit 50% Verlust. Mit dem Laptop ins I-Net geht allerdings nicht.

    Jetzt hast du ja ein ganz ähnliches Thema Kabel zu WLAN Brücke beschrieben. Auf dem ersten Blick ist es eine andere Methode aber das selbe Ziel.

    Ich denke es ist ein Versuch wert :danke_ATDE:

    Raspberry pi 3 Model B , Zero WH , NodeMCU

  • EDIT: Meine vorherige Anwtort war Bullshit da ich zwei Threads verwechselt habe.


    Warum Du Verlust hast verstehe ich nicht. Warum Du nicht ins Internet kommst: Hast Du eine Route in Deinem Internetrouter zu Deiner Raspi definiert? Ohne die geht es nicht.


    Die Bruecke hat so wie ich es beschrieben habe Performanceprobleme. Ich muss mir das genauer ansehen und die Ursache finden. Der Normallfall ist auch ein Router - keine Bruecke.

    Sichere Deine Raspbberry regelmäßig mit raspiBackup . Sicher ist sicher ;-)


    Darum gebe ich keinen Support per PN


    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Benedict Torvalds, 28.9.2003


    Edited once, last by framp ().

  • RalleB Wie sieht es aus. Funktioniert der Router nun bei Dir?

    Sichere Deine Raspbberry regelmäßig mit raspiBackup . Sicher ist sicher ;-)


    Darum gebe ich keinen Support per PN


    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Benedict Torvalds, 28.9.2003


  • Entschuldige aber mich hat es die letzten Tage gesundheitlich ziemlich stark erwischt. Daher konnte und wollte ich mich nicht mit dem Pi beschäftigen. Aber jetzt geht es weiter.

    Zu deiner Frage, nein läuft leider immer noch nicht. Was mir allerdings aufgefallen ist das du in deiner Anleitung bei den iptables wlan und nicht wlan0 steht. Daher werde ich meine iptable gleich mal von wlan zu wlan0 ändern.

    Parallel werde ich auch mal diese Anleitung testen.

    Die ist zwar genau andersherum also von eth0 zu wlan, aber das kann ich ja in den iptables ändern.

    Raspberry pi 3 Model B , Zero WH , NodeMCU

  • :blush: das muss wlan0 heissen. Ist ein typo :blush:


    Die andere Anleitung scheint mir ziemlich mit meiner zu übereinstimmen. Nur eben anders herum.

    Sichere Deine Raspbberry regelmäßig mit raspiBackup . Sicher ist sicher ;-)


    Darum gebe ich keinen Support per PN


    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Benedict Torvalds, 28.9.2003


  • ja ist ähnlich aber

    bei Punkt 18.


    Code
    sudo service dnsmasq start

    kommt auch schon die erste Fehlermeldung. dnsmaq startet nicht

    "Job for dnsmasq.service failed because the control process...."


    und gleich mal mit "systemctl status -l dnsmasq.service" nachgesehen.

    "... a lightweight DHCP and caching DNS server"


    wenn ich versuche

    sudo dnsmasq

    bekomme ich die Fehlermeldung

    "unbekonnte Schnittstelle eth0"


    Ich verstehe jetzt nix mehr.


    Edit:

    in der dnsmasq.conf

    interface=eth0 auf interface=wlan0

    geändert.

    ich denke das war der Fehler

    Edit 2:

    Nein, das war der Fehler nicht.

    Raspberry pi 3 Model B , Zero WH , NodeMCU

    Edited 2 times, last by RalleB ().