Installation Moode Audio 4.0

  • Hallo zusammen,


    bin neu im Thema Raspberry und habe momentan Volumio laufen.

    Die Installation und Einrichtung hat bis auf eine Kleinigkeit gut funktioniert.

    Jetzt wollte ich gerne Moode Audio Player testen aber ich weiß nicht, wie ich das installieren soll.

    Ich hoffe mir kann einer helfen.

    Vielen Dank vorab!!!

  • Hallo zusammen,


    schade, dass hier nicht mehr geschrieben wurde. Falls da was hilfreiches stand, ist es leider nicht mehr da. Der Verweis auf die Homepage ist nicht wirklich hilfreich. Das hatte ich zuvor auch schon gefunden und bin mit der Installation nicht weiter gekommen.


    Das grundsätzliche Problem bei der 4.0 ist ja, dass es kein Installations-Image mehr gibt. Stattdessen muss man sich mit dem mosbuilder seine SD Karte selbst betanken. Dafür ist es notwendig, ein vorhandenes Raspi-OS zu nutzen.


    Ich selbst habe es mit Dietpi versucht und bin kläglich gescheitetert. SD-Betankung bricht ab mit Fehlermeldungen (nicht vorhandene Verzeichnisse /home/pi/mosbuilder). Die Verzeichnisse habe ich angelegt und das Script auch mit Root-Rechten gestartet.


    Alternativ habe ich den Pfad in einer der Dateien angepasst - funktioniert leider auch nicht. Dann habe ich es mit einem frischen Volumio-OS versucht - auch das bricht trotz angepasster Config immer mit den gleichen Fehlern ab.


    Heute Abend werde ich es mal mit Raspi Stretch (Lite) versuchen,


    Hat hierzu noch irgendjemand eine Idee?

  • Hallo ohinrichs,


    eigentlich hat dbv alles geschrieben

    Download Moode -> Support

    wie du selbst schreibst, bist du ja auf dem richtigen Weg.

    Da steht aber eindeutig!

    Zitat

    Raspbian Stretch Lite release 2017-11-29.


    Also halte dich dran!!! Experimente kannst du machen, wenn du firm bist.

    Dauert etwas die Karte zu kreieren. Nicht beenden!!!

    Einmal editiert, zuletzt von paulaner () aus folgendem Grund: Rechtschreibung

  • Das grundsätzliche Problem bei der 4.0 ist ja, dass es kein Installations-Image mehr gibt. Stattdessen muss man sich mit dem mosbuilder seine SD Karte selbst betanken. Dafür ist es notwendig, ein vorhandenes Raspi-OS zu nutzen.

    Wenn du den langen Thread von Tim Curtis lesen würdest, wüstest du warum das jetzt so ist.

  • Oh Mann...stimmt. Das habe ich tatsächlich irgendwie überlesen. Sorry und danke!


    Warum das so ist, weiß ich, denke ich: Macht wohl zu viel Arbeit.


    Wie auch immer... Bin gerade ziemlich optimistisch, dass ich heute Abend erfolgreich sein werde.

  • paulaner


    Ich komme bei der aktuellen Version aber auch nicht weiter.


    1. Raspbian Stretch Lite release 2017-11-29 geladen

    2. --> install via win32diskimager, ssh Datei angelegt.

    3. Pi starten und Putty Zugriff.

    4. Befehle wie im Support angegeben, eingegen. Soweit keine Fehlermeldung aber es passiert auch nichts weiter.

    Die Console steht jeweils wenige sec. danach wieder zur Eingabe zur Verfügung.

    Und den Thread mit über 1350 Seiten zu lesen finde ich jetzt übertrieben. Zumal er leider auch nicht den ersten Post pflegt.

    Zu Version 4 geht es ab hier: http://www.diyaudio.com/forums…-pi-1294.html#post5324316

    los.


    Was fehlt mir??


    Muss ich die Version 4 irgendwo auf der SD Karte vorher ablegen, entpacken oder was auch immer?

    Einmal editiert, zuletzt von Doni ()

  • Hallo,


    mal kurz,


    man lädt das, führt es aus und bekommt alles was man machen muß gesagt.

    Start the Image Builder sudo ./mosbuild.sh


    Man braucht eine 2. SD Karte, der Builder schreibt ein moode-image da drauf, wenn er fertig ist tauscht man die Karten.

    Ich habe die 2. SD-Karte per USB-Adapter eingebunden.

    2 Mal editiert, zuletzt von paulaner ()

  • paulaner Thx das mit der zweiten Speicherkarte war der entscheidende Hinweis. Steht so leider nicht auf der Homepage und ohne tut sich sonst nichts.


    Für alle intressierten:


    Es ist übrigens egal ob SD-Karte oder ein USB Stick benutzt wird (richtige Formatierung vorrausgesetzt).

    Sobald eines von beidem im Pi steckt und die Befehle entsprechend eingibt, startet der Mosbuilder und führt dann, wie paulaner schon sagte, durch das Prozedre.

    Man muss dafür also keine zweite SD-Karte opfern, der USB Stick kann auch als temporäres Laufwerk genutzt werden und die Installation geht direkt auf die primäre SD Karte wo das Raspian Lite installiert ist.

    Nach einem Neustart wird die SD Karte entsprechen konfiguriert.


    Die Sprache ist aber weiterhin nur englisch soweit ich bisher gesehen habe. Einige Einstellungen haben sich seit der 3.1, welche ich bisher genutzt habe, verändert.

    Da muss ich mich auch erstmal durcharbeiten.


    paulaner Du hast nicht zufällig schon eine Seite gefunden, welche die neuen Einstellungen ausführlich erklärt?

  • Hallo Doni,


    Configure -> Timezone

    Keyboard

    Layout


    Einstellungen sind wie bei einer älteren Version, dafür reichen meine Englischkenntnisse, ansonste empfehle ich DeepL als Übersetzter.

    Weiteres Deutsch gibt es auch bei der Version nicht.


    Ich habe damals die SD Karte getauscht, das weis ich 100% da mir durch meine Ungeduld ein kaputt gegangen ist.

    Man kann das Image da drauf lassen und weitere beschreiben.

    Aber ich lasse mich auch da belehren.


    Hat aber nichts damit zu zu tun, das man mit einem RPi 3B auch vom USB Stick booten kann.

    2 Mal editiert, zuletzt von paulaner ()

  • Hallo @all,


    Der mosbuilder stellt 2 verschiedene Varianten zur Verfügung.

    Ich habe die Version der zusätzlichen Karte gewählt, erschien mir sicherer.


    The build can be written directly to the boot SDCard or "to a second SDCard plugged into the Raspberry Pi using a" USB-SDCard drive."


    Auch ist der Builter von damals, als die 4.00 beta12 aufgekommen ist nicht mehr der heutige.

    Build Recipe v2.3, 2018-01-26


    2 Mal editiert, zuletzt von paulaner ()

  • Zur 3.1 hat sich einiges geändert und ich sah für mich jetzt keinen Nutzen darin, bei jedem Build das ganze zu updaten. Da sich die alte Version aber inzwischen auf der SD Karte verabschiedet, wollte ich den Anlass nutzen und komplett die aktuelle Verison nehmen.


    Mein Englisch ist soweit auch brauchbar, nur einige Begrifflichkeiten sagen mir einfach nichts. Aber das wird sic h sicherlich beheben lassen. :-)

  • Hallo,


    damit es auch Aussenstehende richtig verstehen,

    'Doni' spricht von Moode Player Version 3.1.

    Ich von dem Builder v2.3.


    Ich weiß noch das ich 10€ bezahlt habe für einen Key, das ich das Image entpacken konnte.

  • Korrekt paulaner


    Also für alle:

    Anleitung zur Installation für Moode Player 4.0


    1. Raspbian Stretch Lite release 2017-11-29 laden (Nur das, nichts anders, laut Entwickler!!)

    2. Image install via win32diskimager, ssh Datei auf der SD Karte anlegen.

    3. Pi starten und Putty Zugriff. Klappt alles? Ok dann wieder runterfahren.

    4. 2te SD Karte mit Adapter oder USB Stick an den PI hängen. (Wichtig!!!! sonst passiert nichts bei der Eingabe der Befehle)

    5. Pi starten (Standart Passwort eingeben)

    6. Befehle eingeben und ausführen:


    1. cd /home/pi
    2. sudo wget -q http://moodeaudio.org/downloads/mos/mosbuild.sh -O /home/pi/mosbuild.sh
    3. sudo chmod +x /home/pi/mosbuild.sh
    4. sudo ./mosbuild.sh


    7. Befolge alle weiteren Fragen die dann über Putty zu sehen sind.

    8. Neustart und dann Geduld ~1h bis der Build erstellt wurde.

    9. Neustart (nicht unbedingt nötig aber ich mache ihn)

    10. Zugriff über Browser --> IP des Pi oder http://moode.local

    11. fertig in der Weboberfläche konfigurieren und Spass haben

  • Hab momentan das Problem, dass die moode 4 Oberfläche nicht mehr reagiert, sobald ich in den Systemeinstellungen etwas ändere und bestätige.

    Hab jetzt nochmals ein neues Image erstellt aber es hat sich nichts geändert.


    Es hilft nur ein "Hardware" Neustart und das ist ja bekanntlich eher ungut. Ideen? SD-Karte ist ok und mit SD-Card-Formatter neu formatiert und vorher mit h2test_1.4 kontrolliert worden.


    Bei der 3.1 keinerlei derartige Probleme.

  • Tritt z.B. bei Änderung der MDP- Volume Control auf Disabled auf oder beim Auswählen der Zeitzone. Oder auch deaktivieren des BT Adapters. (ja, kann ich auch in der config machen aber sollte trotzdem so nicht sein) Quasi immer wenn ich den Set Button drücke hängt er sich auf.