Kein aktuelles Raspbian auf Pi1

Ein neuer Artikel wurde veröffentlicht
  • Hallo,


    ich versuche gerade einen alten RPi1 zu einem Infrarot-Receiver zu machen. Hab erst zwischenzeitlich gemerkt, dass es ein RPi1 ist. Bisher diente er als Bluetooth-Receiver da mein A/V-Receiver kein Bluetoth hatte. Da lief bisher auch Raspbian Jessie drauf von Mitte 2017. Ich habe versucht die aktuelle Stretch zu installieren, da kam beim booten die Meldung:


    Code
    1. Kernel Panic- not syncing: Requested init /usr/lib/raspi-config/init_resize.sh failed (error -20)


    Das soll angeblich auf Fehler der SD-Karte hinweisen, der Bluetooth-Receiver lief bisher problemlos, auch danach gab es keine Probleme. Auch bootet ein aktuelles Jessie, es bleibt aber stehen und es erscheint ein Bildschirm


    Zitat

    Willkommen beim Raspberry Pi Desktop (oder Raspbian Desktop)


    Der geht nach einer Weile auber auch weg. Eine IP bekommt der Pi nicht (angeschlossen per LAN), daher kann ich auch per SSH nichts machen.


    Braucht der Pi ein spezielles Image oder läuft hier nur eine bestimmte Version?

  • Moin Richard,


    ich kann es bestätigen. Auf einem RPi 1 rennt das aktuelle Raspbian Stretch mit Desktop. Bei mir zumindest.


    Aber denke dran, die SD-Karte sollte größer 4GB sein.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein "Like"

  • Die Karte ist 4GB groß und kann nicht defekt sein, sonst würde ja mein Image von 2017 nicht laufen.

    Du hast leider nicht geschrieben, welches Image Du verwendest. Aus der Fehlermeldung des Jessie rate ich mal, dass es auch ein Stretch mit Pixel ist. Und zumindest das passt nicht mehr auf eine 4GB Karte. Ein Stretch lite sollte in jedem Fall fehlerfrei laufen.


    Gruß, STF

  • Wollte schreiben die ist GRÖSSER als 4GB. 8 oder 16.


    Hab das letzte Stretch versucht, da kam der Kernel Panic-Error und das letzte Jessie, da kam diese Desktop-Meldung.


    Mein Jessie als Bluetooth-Receiver läuft problemlos. Daher kann die Karte eigentlich nicht defekt sein.

  • Nun, da es auf etlichen Pi funktioniert, muss ein Fehler vorliegen. Hexenwerk isses jedenfalls nicht.


    Willst Du dem auf den Grund gehen? Dann wäre für den Anfang wichtig, zu wissen, wie genau Du beim Schreiben des neuen Images vorgegangen bist, welchen Entpacker und welches Programm zum kopieren Du verwendet hast.


    Gruß,STF