Pilight automatisch starten beim Neustart vom Raspberry

  • Hallo. Ich bin so langsam am verzweifeln.

    Ich habe mir das pilight eingerichtet welches auch soweit funktioniert.

    Wenn ich es mit (sudo service pilight start) starte geht alles.

    Wie bekomme ich es hin, das es Automatisch gestartet wird wenn der Raspberry gestartet wird? :helpnew:


    Ich habe das Stretch drauf.

  • hat leider nicht geklappt :-(

    Der pilight Webserver ist nicht erreichbar nach dem Neustart.


    Erst nachdem ich wieder das eingegeben habe.:(


    pi@raspberrypi:~ $ sudo service pilight start

  • Nach dem Neustart kommt das nach dem Befehl.


    1. sudo systemctl status pilight.service


    < ● pilight.service - pilight

    Loaded: loaded (/etc/systemd/system/pilight.service; enabled; vendor preset: enabled)

    Active: failed (Result: exit-code) since Sun 2018-02-11 15:11:26 CET; 2min 7s ago

    Process: 315 ExecStart=/usr/local/sbin/pilight-daemon (code=exited, status=0/SUCCESS)

    Main PID: 374 (code=exited, status=1/FAILURE)


    Feb 11 15:11:24 raspberrypi systemd[1]: Starting pilight...

    Feb 11 15:11:26 raspberrypi systemd[1]: Started pilight.

    Feb 11 15:11:26 raspberrypi systemd[1]: pilight.service: Main process exited, code=exited, s

    Feb 11 15:11:26 raspberrypi systemd[1]: pilight.service: Unit entered failed state.

    Feb 11 15:11:26 raspberrypi systemd[1]: pilight.service: Failed with result 'exit-code'. >



    und nach dem manuellen Start mit

    <sudo service pilight start>


    <

    pi@raspberrypi:~ $ sudo service pilight start

    pi@raspberrypi:~ $ sudo systemctl status pilight.service

    pilight.service - pilight

    Loaded: loaded (/etc/systemd/system/pilight.service; enabled; vendor preset: enabled)

    Active: active (running) since Sun 2018-02-11 15:15:44 CET; 5s ago

    Process: 1072 ExecStart=/usr/local/sbin/pilight-daemon (code=exited, status=0/SUCCESS)

    Main PID: 1073 (pilight-daemon)

    CGroup: /system.slice/pilight.service

    └─1073 /usr/local/sbin/pilight-daemon


    Feb 11 15:15:44 raspberrypi systemd[1]: Starting pilight...

    Feb 11 15:15:44 raspberrypi systemd[1]: Started pilight. >

  • Ok. Kannst du bitte mal den Inhalt von pilight.service (cat /etc/systemd/system/pilight.service) posten? Diesmal bitte wirklich als Code formatieren! Oben im Editor den </> Button verwenden.


    Evtl. braucht Pilight das Netzwerk, was beim Autostart noch nicht oben ist, bei einem manuellen Start schon. Müsste dann etwa so aussehen:

    Code
    1. ...
    2. [Unit]
    3. Wants=network-online.target
    4. After=network-online.target
    5. ...

    Ich kenne Pilight nicht, sehr wohl aber Systemd. Du verwendest Stretch mit Systemd, da würde ich dir systemctl statt service empfehlen, auch wenn letzteres aus Kompatibilitätsgründen noch funktioniert.

  • Code
    1. [Unit]
    2. Description=pilight
    3. After=network-online.target
    4. [Service]
    5. ExecStart=/usr/local/sbin/pilight-daemon
    6. Type=forking
    7. [Install]
    8. WantedBy=multi-user.target

    Ich bin leider noch absoluter Neuling und weis nicht was systemct1 oder service ist :conf:

  • Dann füge mal noch das Wants=... mit ein. Dann neu starten. Wenn das nicht hilft, mach es so:

    Edit: nach jeder Bearbeitung noch ein

    Code
    1. sudo systemctl reenable pilight.service
  • Es hat geklappt :danke_ATDE::danke_ATDE::danke_ATDE:


    1000 dank für deine schnelle Hilfe.


    Der Wants.... Befehl hatte nicht gereicht.

    Habe die Konfiguration von dir genommen und es klappt nach dem Neustart.


    ( Hätte ich mich mal gleich hier angemeldet , als 2 Tage erfolglos bei Google zu suchen:lol: )