Kaufempfehlung Relais die etwas aushalten

  • warum er vom GPIO einen 1,8k Ohm in Reihe zum Relais legt wenn das Datenblatt vom Relais eine Mindestspannung von 3V vorschreibt

    Weil du wie so oft nicht richtig ließt. Im Schaltplan ist das Prinzip verdeutlicht. Der 1k8 ist bereits im Relais verbaut, gehört also nicht noch davor. Passiert mir auch ab und an, deswegen dieser nette Hinweis von mir.

    Der 1k8 ist im Relais verbaut, der braucht also nicht extra davorgesetzt werden. Ist nur eingezeichnet, damit die Schaltung schlüssig ist.

    Also alles im Lot, oder?

  • Also alles im Lot, oder?

    dann ja, hoffen wir mal das TO das ohne 1,8k umgesetzt hat.

    (PS. besser wäre der richtig Plan gewesen, denn auch andere haben es falsch aufgefasst, sowas kommt eben von "Prinzipbilder")

    Weil du wie so oft nicht richtig ließt.

    persönlich werden musst du nicht, besser nächstes mal richtige Schaltbilder einstellen


    Die Frage bleibt, was hat der TO aufgebaut, mit 1,8k ist es kein Wunder das es klemmt.

    lasst die PIs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Die Frage bleibt, was hat der TO aufgebaut, mit 1,8k ist es kein Wunder das es klemmt.

    Leute wo sind wir denn? Einmal im Schaltplan beschrieben und einmal im Text. Sorry, aber das ist nun wahrlich unmissverständlich.


    Elektronische Relais haben oft das Probkem, dass LEDs trotz "offenem" Kontakt noch schwach Leuchten. Sollte man mit einem Kondensator hinbekommen.

  • Hallihallo!


    So, schön dass das Forum hier wieder funktioniert. Und danke Euch!


    Also ich habe das Ganze korrekt verlötet, habe den Plan verstanden. Trotzdem waren die GIPOs von Raspberry zu schwach die schweren Relais zu schalten. Das habe ich inzwischen gelöst, denn ich hatte noch genügend "Billig Relais" frei, diese schalten nun einen separaten 5V-Kreislauf der dann die "großen" Relais schaltet. Alles kein Problem, funktioniert sehr gut. Ein altes USB-Netzteil erledigt das.


    Probleme hatte ich nur mit mehreren 10 Meter langen LED-Lichterketten. Diese ziehen auch relativ viel Saft, bei einem Versuch habe ich damit sofort so ein "kleines Relais" zerstört. Bei großen Relais dann hatte ich immer wieder ein kurzes aufblitzen der Lichterkette, weil diese SSR nicht ganz trennen.


    Die Lösung war auch ziemlich einfach: Einfach das Billig-Stecker-Netzteil (das schnell sehr heiss wurde) der Lichterkette durch etwas solideres https://www.amazon.de/gp/product/B00UEUWN06/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1 (Affiliate-Link) (das auch nach einer Stunde noch kalt bleibt) ersetzen. Problem gelöst.


    Es funktioniert nun alles!


    Wenn ich nun in meinem Kinokeller gehe, dann schalte ich nur noch einen stinknormalen Lichtschalter ein. Dieser startet den Raspberry und dieser wiederum schaltet mir die ganze Musikanlage, Beamer, Beleuchtung und Lüftungsanlage ein. Sinnvoll der Reihe nach.


    Im Kino selber habe ich einen Fußtaster zum Beleuchtung hochfahren/herunterfahren, es startet sich ein kleines Shellscript das die Lampen von vorne nach hinten ein- bzw. ausschaltet. Sehr edel!


    Ich möchte mich bei Euch ganz herzlich bedanke, ihr habt mir sehr geholfen.


    Und wen das Kellerkino interessiert, ich baue da schon Jahre dran rum, demnächst gibt es dann neue Fotos: https://www.beisammen.de/index…hts-ist-so-gut-wie-ein-p/


    :wink:

  • Und wen das Kellerkino interessiert, ich baue da schon Jahre dran rum

    scheint mir eher wie "der Weg ist das Ziel"


    erinnert mich an einen vor 30 Jahren der in einer Mietwohnung die Dielen ausgebaut hat um ein einfach gefaltetes Klipschhorn zwischen den Tragbalken zu versenken :lol:

    lasst die PIs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Es funktioniert nun alles!


    Wenn ich nun in meinem Kinokeller gehe, dann schalte ich nur noch einen stinknormalen Lichtschalter ein. Dieser startet den Raspberry und dieser wiederum schaltet mir die ganze Musikanlage, Beamer, Beleuchtung und Lüftungsanlage ein. Sinnvoll der Reihe nach.

    Freut mich, wenn du zufrieden bist. Aber mit dem was du schreibst, erweckt es bei mir den Eindruck, dass du die Beere nur per Lichtschalter bedienst und nicht ordnungsgemäß runter fährst. Wenn das so ist, solltest du darüber nachdenken, das zu ändern.

    Über warm werden oder "zu schwere Relais" sag ich nichts mehr, ich erinnere nur an eine gute Versicherung.

    Ich habe eine Raspi Beere 3 und freue mich, dass sie läuft. Ich programmiere gern und freue mich wenn es auch funktioniert. Aber grundsätzlich hab ich keine Ahnung davon :conf:

    Bitte löscht nie dieses Forum! Hier steht alles drin was ich mir merken muss!

  • Ja, ich habe tatsächlich die Bodenplatte entfernt um den großen Subwoofer unter zu bringen, die Position dort ist alles andere als zufällig. Man sitzt auf einem entkoppeltem, versenkten Podest. Bei Bassgewittern/Schüssen etc. hat man deutlich spürbaren Körperschall weil das Podest angeregt wird (Podest sitzt auf Federn/Dämpfer und kann entkoppelt frei schwingen)... :shy:


    Das Ganze hatte immer schon ein durchdachtes Konzept, nur die Ansprüche/Möglichkeiten/Technik ändert sich mit den Jahren.


    Die Fotos auf der genannten Seite sind schon länger nicht mehr aktuell, inzwischen haben wir schon mehrere tausend Stunden auf der Beamerlampe. Ich will nur noch die letzten Details fertigstellen, bevor ich das das mal abschließe.


    Bild und Sound bekommt man zu Hause deutlich besser hin als es die großen "echten" Kinos bieten können. Vorausgesetzt natürlich man hat einen Raum und die Nachbarn weit genug weg. :lol:


    Macht auf jeden Fall Spaß so ein eigenes Kino und wird auch so gut wie täglich genutzt.

  • Freut mich, wenn du zufrieden bist. Aber mit dem was du schreibst, erweckt es bei mir den Eindruck, dass du die Beere nur per Lichtschalter bedienst und nicht ordnungsgemäß runter fährst. Wenn das so ist, solltest du darüber nachdenken, das zu ändern.

    Über warm werden oder "zu schwere Relais" sag ich nichts mehr, ich erinnere nur an eine gute Versicherung.

    Da kann ich Dich beruhigen!


    Der Raspberry fährt brav runter, wenn ich einen weiteren Taster drücke. Erst schaltet er alle Relais wieder in den Ursprungszustand zurück (=aus), dann fährt er brav runter. In der Zwischenzeit habe ich Getränke weggeräumt und aufgeräumt, und ich kann danach den Raspberry vom Stromnetz trennen (mit eben dem von Dir genannten Schalter).


    In der Praxis: Bei hochfahren ein "Autostart-Shellscript" das alles einschaltet. Dann zwei weitere im Hintergrund die ständig die Taster abfragen.


    Der Ganze 230V-Teil wurde nun von einem Elektromeister geprüft und für gut befunden, im Sicherungskasten des Hauses selbst komplett neu angeschlossen/abgesichert. Rauchmelder sind vorhanden, FI usw. alles auf neuestem Stand. In der Versicherung ist das Heimkino auch extra aufgeführt. Sollte also alles passen. Danke trotzdem dass Du Dir Sorgen um meine Sicherheit machst.

  • Bild und Sound bekommt man zu Hause deutlich besser hin als es die großen "echten" Kinos bieten können

    zumindest kann man sich die Mitgucker aussuchen, keine Chiptütenknisterer, niemand der einem in den Rücken tritt, kein Hampelmann nebenan, kein Nachplaperer von Szenen usw. usf.


    Ich arbeite ja noch an meinem Kinozimmer, verkabelt ist alles, aber die Regalbretter, der Bodenbelag und die Sessel fehlen noch


    Macht auf jeden Fall Spaß so ein eigenes Kino und wird auch so gut wie täglich genutzt.


    daran glaube ich noch nicht bei mir :lol:

    lasst die PIs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • daran glaube ich noch nicht bei mir :lol:

    Ich bin ja seit etwa 2003 in dem anderen Forum das sich nur mit Heimkino beschäftigt. Dort gibt es eindeutig die "Gucker", die bauen ein Mal und haben dann Spaß dran. Veränderungen selten. Dazu gehöre ich.


    Und dann gibt es die "Tüftler", diese bauen nur und gucken wenig. Die optimieren und messen und diskutieren...


    Egal, Hauptsache man hat ein schönes Hobby!

  • Egal, Hauptsache man hat ein schönes Hobby!

    sag ich doch


    "der Weg ist das Ziel"

    lasst die PIs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Geile Sache auf jeden Fall! Vor allem, wenn nix passieren kann...

    Nun fehlen nur noch aktuelle Bilder vom fertigen Kino:shy:

    Ich habe eine Raspi Beere 3 und freue mich, dass sie läuft. Ich programmiere gern und freue mich wenn es auch funktioniert. Aber grundsätzlich hab ich keine Ahnung davon :conf:

    Bitte löscht nie dieses Forum! Hier steht alles drin was ich mir merken muss!

  • Ich möchte dieses Thema zu den Solid-State Relais gern nochmal aufgreifen. Ich benutze bauähnliche Relais und zwar diese:


    https://www.pollin.de/p/solid-…-3-32-v-20-a-240-v-340470

    (Datenblatt ist in dem genannten Link einzusehen)


    Nach ersten Test´s funktionieren und schalten meine drei verwendeten SSR´s, direkt an den GPIO´s angeschlossen, einwandfrei. Nun bin ich mir nicht ganz sicher ob ich die Relais auf dauer direkt an den GPIO´s betreiben kann.


    Ich habe mal die Stromaufnahme der Relais gemessen und die lag bei allen drei verwendeten Relais bei etwa 5mA. (Laut Datenblatt 6-25mA)


    Da so ein GPIO Pin ja durchaus bis etwa 16mA ausgelegt ist, sehe ich da erstmal kein Problem.


    Nun werde ich allerdings bis zu 8 Relais verwenden. Da komm ich dann auf gut 40mA insgesamt. Ich hatte mal irgendwo gelesen das der Gesamtstrom aller GPIO´s 50mA nicht übersteigen sollte.


    Nun zu meiner eigentlichen Frage, muss ich eine Transistor Schaltung, Diode oder ähnliches vor jedes dieser Solid-State Relais setzen oder nicht? Es funktioniert ja, aber ich habe Bedenken ob der Pi das auf dauer mitmacht. Wann würde so ein Relais bis zu 25mA Strom ziehen? Hängt das von der Schaltleistung ab?


    Vielen Dank schonmal für eure Ratschläge.

  • Nun zu meiner eigentlichen Frage, mussich eine Transistor Schaltung, Diode oder ähnliches vor jedes dieser Solid-StateRelais setzen oder nicht? Es funktioniert ja, aber ich habe Bedenkenob der Pi das auf dauer mitmacht. Wann würde so ein Relais bis zu25mA Strom ziehen? Hängt das von der Schaltleistung ab?

    ein ULN2803a ist kein Fehler entlastet die GPIO deutlich und der Treiberstrom muss auch nicht aus dem GPIO kommen der in Summe nur 50mA kann

    Die Relais werden mit einer Bandbreite der üblichen Fertigungsstoleranzen angegeben, manche brauchen eben wenig, aber schon das nächste kann deutlich mehr brauchen, vor allem bei Ersatz wenn aus einer anderen Serie, ist wie bei Bio Eier Aldi zu Lidl wenn man nicht auf die Gewichtsklasse schaut oder nicht mal verschiedene angeboten werden.

    lasst die PIs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Nun zu meiner eigentlichen Frage, mussich eine Transistor Schaltung, Diode oder ähnliches vor jedes dieser Solid-StateRelais setzen oder nicht? Es funktioniert ja, aber ich habe Bedenkenob der Pi das auf dauer mitmacht.

    Bei deinen 8 Relais würde ich definitiv eine Transistorstufe dazwischen schalten. Da gibt es auch fertige Treiber-ICs, z.B. ULN 2803 mit 8 Kanälen.

    Wann würde so ein Relais bis zu25mA Strom ziehen?

    Bei den angegebenen 32V für die Ansteuerung.

  • Super, vielen Dank für eure flotten Antworten. Dann werde ich mich mal dem ULN 2803 widmen. Muss dann nur mal schauen wie ich das ganze hübsch in den Schaltkasten auf eine Din/Hutschiene bekomme. Sollte ich an dem einen Pi mal über 8 Relais verwenden wollen, kann ich dann ja sicherlich einfach einen zweiten Treiber Baustein dazuhängen!?