Farben richtig kalibrieren - Ambilight Pi3

  • Hallo liebe Forengemeinde,


    ich habe mir vor einem gutem Jahr ein Ambillight-System nachgebaut.

    Allerdings habe ich dort das Problem, dass die Farben nicht richtig dargestellt werden, und ich diese auch nicht richtig einstellt bekomme.

    Ich habe mir zusätzlich die Hyperion App erworben, allerdings kann ich dort zwar die Farbe so verändern, dass mir diese gefällt, dann ist aber wieder die nächste Farbe völlig verstellt.


    Ich nutze einen Raspi Pi 3 mit der Software Openelec in der Version 8.x

    Ich habe Hyperion auf dem Raspi installiert und aktiviert.

    Der Pi ist mit meinem Receiver verbunden.


    Könnt ihr mir sagen, an welchen Reglern ich schrauben muss, damit die Farben noch echter aussehen?

    Bei den gezeigten Bildern handelt es sich um ganz normale Testbilder, alle Werte sind auf Standart.

  • Hallo


    Ich habe mich damals an die Anleitung aus dem Hyperion Wiki gehalten. Arbeite dich Punkt für Punkt durch.


    Hier der Link zur Farbkalibrierung.


    Danach solltest du schon ein gutes Ergebnis haben.


    Gruß

    Oliver

  • Hallo,


    vielen Dank für den Hinweis. Ich gehe davon aus, dass Du folgendes Wiki meinst:

    https://hyperion-project.org/wiki/HyperCon:SSH-Tab

    Allerdings habe ich das schon mehrfach versucht, der Effekt ist oben beschrieben.

    Sobald ich dies erste Farbe über die Farbkalibierung ändere, angenommen die weiße Farbe, passt direkt eine andere Farbe nicht mehr.

    Die Tests nehme ich mit der Hyperion App vor, allerdings würde ich es gerne auch einmal mit Hyperion selber probieren (im SSH-Tab), hier sehe ich jedoch keine Veränderung am TV-Gerät.


    Hyperion selbst spuckt nur folgende Meldung aus:


    ssh out: hyperion-remote -c ffff68

    ssh out: sh: hyperion-remote: not found

  • Steinardo Link? :conf:

    Sorry, er hat den Hyperlink nicht übernommen als ich vom Handy geantwortet hatte.


    Hier der Link


    https://hyperion-project.org/wiki/Farbkalibrierung



    uti-pepe Funktionert deine SSH Verbindung? Wenn nein dann musst du das erst mal in den Griff bekommen. Da bin ich aber raus, davon habe ich keine Ahnung.



    Wenn deine SSH Verbindung OK ist, starte mit dem Weißwert (und nur mit dem Weißwert). Wenn du eventuelle Farbstiche beseitigt hast und dir das Ergebnis gefällt machst du mit dem Gamma wert weiter.

    Wenn du das hinter dir hast machst du mit den Farbkanälen. Das kann etwas Dauern. Ich habe da ca 6 Stunden dran gesessen bis es einigermassen gepasst hat (ich habe immer noch einen leichten Rotstich in einigen Brauntönen). Danach überprüft du noch mal Gamma.

    Jetzt hast du die Grundeinstellung vorgenommen und kannst wenn du willst weiter machen mit den Einstellungen für Helligkeit, Sättigung....


    Wenn du willst kann ich dir auch mein config File geben. Die musst du aber auf dein System anpassen (Anzahl LED usw.).


    Gruß


    Oliver

  • Hallo


    Jetzt habe mir ein Ambillight-System nachgebaut.

    Allerdings ist es wie beim uti-pepe das die Farben nicht so richtig wollen.

    In dunklen Szenen Leuchten die LED 's manchmal, aber nicht immer, Blau.


    Habe den Raspi Pi 3, Openelec 8, Led ws2801 und ein separates Netzteil, Hyperion ist drauf, SSH geht auch.


    Steinardo: könntest Du mir deine config per PM zukommen lassen? In der Hoffnung das die besser funktioniert.


    Gruss Andi

  • So habe Mal umprogrammiert und muss sagen es passt besser, noch nicht perfekt aber das wird.

    Danke mal an Steinwerk.

    Gruss Andi

  • Hallo Steinardo,


    Ich bin gerade selber am justieren bei mir und habe über Google dieses Forum gefunden :). Habe mir deine config runtergeladen und wollte mal fragen,ob du auch deine Einstellungen hochladen könntest(dat).Dann könnte ich in Hyperion direkt die LEDs einstellen.Vielen dank falls dies möglich wäre.LG Dennis