DHT22 Funktioniert nicht mehr

  • Hallo zusammen

    Habe den Sensor DHT 22 am Rasberry angeschlossen und zum laufen bekommen.


    Temperatur und Feuchtesensor worden richtig angezeigt!!

    Nach dem ich den Rasberry neu gestartet habe und sonst nix verändert habe, bekomme ich jetzt folgenden Fehler angezeigt:


    Traceback (most recent call last):

    File "sensor12.py", line 65, in <module>

    humidity, temperature = Adafruit_DHT.read_retry(sensor, gpio)

    File "build/bdist.linux-armv7l/egg/Adafruit_DHT/common.py", line 94, in read_retry

    File "build/bdist.linux-armv7l/egg/Adafruit_DHT/common.py", line 81, in read

    File "build/bdist.linux-armv7l/egg/Adafruit_DHT/Raspberry_Pi_2.py", line 34, in read

    RuntimeError: Error accessing GPIO.


    Meine Frage ist:

    Was muss ich machen damit das Programm wieder lauft?:danke_ATDE:

  • Nein am Rasberry habe ich vor den abschalten nix geändert.

    Ich habe auf meinen Router einen update/upgrade bekommen, danach habe ich den Rasberry neu gestartet, damit der Rasberry seine neu IP von Router bekommt.

    Jetzt wird wieder Der Rasberry mit IP im Router angezeigt, vor her nicht!!


    Nach den neu Start von Rasberry bekomme ich die Fehlermeldung s.o.!!!

  • Du hast sicherlich "vor langer Zeit" mal ein Update gemacht....

    und nun stimmen die Pfade nicht mehr !!

    build/bdist.linux-armv7l/egg/Adafruit_DHT/common.py

    such doch mal wo dieses common.py ist !!

    Und evtl. von ADA... die Quellen neu holen und übersetzen

  • Du hast sicherlich "vor langer Zeit" mal ein Update gemacht....

    und nun stimmen die Pfade nicht mehr !!

    build/bdist.linux-armv7l/egg/Adafruit_DHT/common.py

    such doch mal wo dieses common.py ist !!

    holgerble Blödsinn, es steht doch im Traceback, das Python in der Datei schon drin war:

    ...

    File "build/bdist.linux-armv7l/egg/Adafruit_DHT/common.py", line 94, in read_retry

    File "build/bdist.linux-armv7l/egg/Adafruit_DHT/common.py", line 81, in read

    ...

    Bitte solche Aussagen etwas mit Fakten unterfüttern.

  • Ich habe auf meinen Router einen update/upgrade bekommen

    ??? Was ist damit gemeint?


    danach habe ich den Rasberryneu gestartet, damit der Rasberry seine neu IP von Router bekommt.

    Jetzt wirdwieder Der Rasberry mit IP im Router angezeigt, vor her nicht!!

    Was hat das mit dem DHT Problem zu tun? Konntest Du denn in der Zwischenzeit per ssh/vnc auf den RPi? Poste mal bitte Deine config.txt, nicht dass Du meherere Programme/Overlays auf gleiche GPIO zugreifen lässt.


    Grüße, STF

  • Hallo zusammen

    Ich war bzw. bin immer noch Krank!!! Darum hatte ich leider keine Zeit für mein Rassberry!!!

    Auf deine Frage Schallschraubenzieher

    Mein DHT Problem und Router einen update/upgrade bekommen habe nix mit einander zu tun.

    Aber: Mein Telefon Anbieter hat mit eine neue Software für meine Router gegeben, mit anderen Worten ich konnte nicht mehr auf den Rasberry zugreifen per putty wegen IP stimmt nicht mehr!!!

    Nach neuem Start von Rasberry hatte ich eine neue IP für putty und alles war wieder gut!!!


    Auf deine frage holgerble

    Du hast glaub recht!!!

    Adafruit_DHT habe ich glaub vor langer Zeit wo andere hin kopiert

    Gibt es eine Möglichkeit nachzusehen wo der Ordner Adafruit_DHT war?

    Ich kenne mich mit Rasberry noch nicht so gut an!!!


    Danke für die Antwort!!!

  • Du hast glaub recht!!!

    Adafruit_DHT habe ich glaub vor langer Zeit wo andere hin kopiert

    Gibt es eine Möglichkeit nachzusehen wo der Ordner Adafruit_DHT war?

    Hallo moby dick,


    da ich ungern zitieren möchte, was Terry Pratchett eine seiner Figuren über die Nutzung multipler Ausrufezeichen sagen lässt, eine Bemerkung von mir: Es ist sehr unschön, nahezu jeden Satz mit mehreren Ausrufezeichen enden zu lassen, es lässt den Eindruck entstehen, dass Du hier rumschreien musst. Dem ist nicht so. /OT


    Das „vor langer Zeit...kopiert“ passt weder zu der Fehlermeldung noch zu Deinen Aussagen.



    Also nochmal. Der auslösende Fehler steht genau hier drüber.

    - In der library steht: only tested with Python 2.6/2.7. Du nutzt Python 2.x?

    - Wie sieht die config.txt aus, gibt es overlays, die ebenfalls GPIO22 belegen?


    Grüße,STF

  • Das „vor langer Zeit...kopiert“ passt weder zu der Fehlermeldung noch zu Deinen Aussagen.

    :thumbup::richter:

    - In der library steht: only tested with Python 2.6/2.7. Du nutzt Python 2.x?

    Das sollte nichts zur Sache tun, ich habe vor etwa einem Jahr genau diese Bibliothek mit genau diesem Hinweis mit einem DHT22 am Pi verwendend, und zwar unter Python 3.5. Kein Wunder, es gab einen Commit mit dem Titel "Add python 3 support" (https://github.com/adafruit/Ad…9cc002e3655f64d727a28ac92), viele folgten, nur das README wurde nie aktualisiert.