Probleme mit Zugriffsrechten bei FHEM Installation

  • Hallole,


    bin absoluter Neuling und brauche eure Hilfe.


    habe ein RPi3 und habe fhem installiert.


    Gsetern habe ich mir ein CUL selbst gelötet und einen Ordner 433 MHZ-Utilities wurde erstellt.

    Nun geht plötzlich mit meinem fhem gar nichts mehr!!

    Wollte in update durchführen - nun kommt folgende Meldung:


    pi@raspberrypi:~ $ apt-get update

    Paketlisten werden gelesen... Fertig

    W: chmod 0700 of directory /var/lib/apt/lists/partial failed - SetupAPTPartialDirectory (1: Die Operation ist nicht erlaubt)

    E: Sperrdatei /var/lib/apt/lists/lock konnte nicht geöffnet werden. - open (13: Keine Berechtigung)

    E: Das Verzeichnis /var/lib/apt/lists/ kann nicht gesperrt werden.

    W: Problem beim Entfernen (unlink) der Datei /var/cache/apt/pkgcache.bin - RemoveCaches (13: Keine Berechtigung)

    W: Problem beim Entfernen (unlink) der Datei /var/cache/apt/srcpkgcache.bin - RemoveCaches (13: Keine Berechtigung)


    Frage: was ist schief gelaufen?? Kann mir irgendjemand helfen was jetzt passiert ist?? Wie kann ich meine Berechtigungen verwalten?? Habe leider nicht viel Ahnung von Programmierung!


    Danke Ralf


    [Blocked Image: https://forum.fhem.de/Themes/fhem-curve-green/images/icons/modify_inline.gif]

  • Das ist jetzt wieder ein komplett anderes Problem. Ist 192.168.2.107 denn die richtige IP-Adresse Deines Pi?


    Wie ist die Ausgabe von systemctl status fhem.service?

  • systemctl status fhem.service

    ● fhem.service - LSB: FHEM server

    Loaded: loaded (/etc/init.d/fhem; generated; vendor preset: enabled)

    Active: active (running) since Mon 2018-03-12 11:23:24 CET; 2h 56min ago

    Docs: man:systemd-sysv-generator(8)

    Process: 340 ExecStart=/etc/init.d/fhem start (code=exited, status=0/SUCCESS)

    CGroup: /system.slice/fhem.service

    └─486 perl fhem.pl fhem.cfg


    Mär 12 11:23:20 raspberrypi systemd[1]: Starting LSB: FHEM server...

    Mär 12 11:23:23 raspberrypi fhem[340]: Starting fhem...

    Mär 12 11:23:24 raspberrypi systemd[1]: Started LSB: FHEM server.

  • Die IP Adresse müsste stimmen... Das FHEM lief bereits zu Testzwecken. Nachdem ich den CUL gestartet habe ist alles anders...

    Edited once, last by Egbert ().

  • Aber es funzt immer noch nicht. Was mache ich falsch??

    Diese Website ist nicht erreichbar

    http://192.168.2.107:8083 ist nicht erreichbar.

    ERR_ADDRESS_UNREACHABLE


    update:


    So - habe nun im meinem Router die IP - Adressen kontrolliert: 192.268.2.108 finde ich den RPI auf dem Wlan - 192.168.2.109 im Network cable. 192,168.2.107 - da lief bisher mein FHEM - ist mittlerweile mit einem Tablett meiner Tochter belegt.


    Bei beiden (...108 / 109) kommt - wenn ich :192.168.2.:8083 plötzlich wieder die FHEM Startbildschirm.


    Danke für die Hilfe

    Edited once, last by Egbert ().

  • Auf dem RPi3:

    netstat -tulpen |grep 8083

    ip a s


    Von einem anderen Rechner aus:

    ping -c5 192.168.2.107

    "si tacuisses, philosophus mansisses" [frei nach Boethius]

  • Wie sind denn die Ausgaben von ip addr und von sudo lsof -p 486|grep TCP?

    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1

    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00

    inet 127.0.0.1/8 scope host lo

    valid_lft forever preferred_lft forever

    inet6 ::1/128 scope host

    valid_lft forever preferred_lft forever

    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000

    link/ether b8:27:eb:02:c2:38 brd ff:ff:ff:ff:ff:ff

    inet 192.168.2.109/24 brd 192.168.2.255 scope global eth0

    valid_lft forever preferred_lft forever

    inet6 2003:c6:43f1:a942:d073:35fc:a0df:c0f0/64 scope global mngtmpaddr noprefixroute dynamic

    valid_lft 604798sec preferred_lft 86398sec

    inet6 fe80::29a4:db30:a94b:48c9/64 scope link

    valid_lft forever preferred_lft forever

    3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000

    link/ether b8:27:eb:57:97:6d brd ff:ff:ff:ff:ff:ff

    inet 192.168.2.108/24 brd 192.168.2.255 scope global wlan0

    valid_lft forever preferred_lft forever

    inet6 2003:c6:43f1:a942:d2ee:dcf:c4f7:5bb0/64 scope global mngtmpaddr noprefixroute dynamic

    valid_lft 604798sec preferred_lft 86398sec

    inet6 fe80::f39:2dd0:4d79:2171/64 scope link

    valid_lft forever preferred_lft forever

  • Bei beiden (...108 / 109) kommt - wenn ich :192.168.2.:8083 plötzlich wieder die FHEM Startbildschirm.

    Du solltest den Net(zwerk)-Admin wechseln, der bisherige hat Dein Netzwerk nicht im Griff.



    Servus !

    RTFM = Read The Factory Manual, oder so

  • netstat -tulpen |grep 8083

    (Es konnten nicht alle Prozesse identifiziert werden; Informationen über

    nicht-eigene Processe werden nicht angezeigt; Root kann sie anzeigen.)

    tcp 0 0 0.0.0.0:8083 0.0.0.0:* LISTEN 999 10558 -

  • Wenn dein fhem-Server unter wechselnden IP-Adressen im Netz verfügbar ist, solltest du entweder

    - dein DNS fixen, damit er wenigstens unter einem Hostnamen erreichbar bleibt oder

    - statische IP-Adressen nutzen, um das Problem gar nicht erst zu haben

    "si tacuisses, philosophus mansisses" [frei nach Boethius]