FTP Verbindung konfigurieren bei motionEye FTP Server und FritzBox 7390

  • Hallo zusammen,


    an meiner FritzBox 7390 habe ich einen FAT32 USB-Stick (Name = LEXAR) angeschlossen, NAS aktiviert, auf dem NAS einen Ordner "Kamera" erstellt und einen Benutzer mit Lese.- und Schreibrechten für diesen Ordner angelegt.


             


    In motionEye machte ich nachfolgende Einträge.



    Wobei ich in Location schon

    ./

    /Kamera/

    /fritz.nas/LEXAR/Kamera/

    /LEXAR/Kamera/


    eingetragen hatte erhalte ich beim Testen immer

    Accessing the upload service failed: [Errno 111] Connection refused!


    Ich hoffe es kann mir noch geholfen werden.


    Viele Grüße

    Ich Bins

  • Hallo,


    der Name des Sticks tut nichts zur Sache, Du hast vielmehr ein Unterverzeichnis LEXAR (warum auch immer) angelegt und in diesem das Verzeichnis Kamera. Für letzteres hast Du explizit Rechte vergeben, was die Sache nicht einfacher macht, wenn man nicht genau weiß, was man tut. Dein angelegter Nutzer bekommt mangels Rechten den Ordner LEXAR nie zu "Gesicht", daher ist die Angabe als Pfad schonmal falsch. Vielmehr startet er unterhalb Kamera. Wenn die Zugangsdaten des angelegten Nutzers richtig und korrekt in motionEye hinterlegt sind, dann reicht es, ein / als Pfad anzugeben, mehr sieht der Nutzer eh nicht (woher hast Du das mit dem Punkt davor?). Und schon funktioniert's.


    Bitte beschäftige Dich einmal mit grundlegenden Dingen (Linux/Rechte/ftp/ssh usw.) und vor allem Programmdokumentationen. Das hilft Dir ungemein beim Verständnis.


    Grüße, STF

    "And now for something completely different."


    Hofeis guide to: Wie frage ich nach Hilfe? *** Mein nagelneuer Raspberry Pi 3B+ zeigt nur ein buntes Bild. (Ab)Hilfe.

  • Accessing the upload service failed: [Errno 111] Connection refused!

    Connection Refused bedeutet normalerweise, dass auf der angegebenen Adresse / dem angegebenem Port nichts lauscht.

    Mach bitte mal ein

    nmap -p21 192.168.178.1

    The S in IoT stands for Security

  • Hallo STF,


    wenn ich Dich nicht hätte.

    Mein USB-Stick erhielt vermutlich vom Hersteller die Volumenbezeichnung LEXAR. Vor der Verwendung an der Fritz!Box formatierte ich den USB-Stick und änderte die Volumenbezeichnung nicht. Vermutlich ist auf diese Weise das Unterverzeichnis entstanden. Aktiv habe ich diesen Namen nicht vergeben.

    Die Fritz!Box hat auch selbsständig unter dem Ordner LEXAR den Ordner Fritz angelegt.

    ./ habe ich von hier https://www.youtube.com/watch?v=VVdwTzHIo-8 und von https://www.youtube.com/watch?v=P0XXZsh1vAA übernommen.


    In der Fritz!Box deaktivierte ich NAS, löschte den "FTP-Benutzer", entfernte den USB-Stick und formatiert ihn ohne Volumenbezeichnung.

    USB-Stick wieder rein in die Fritz!Box, NAS aktiviert.

    FTP-Benutzer agelegt und Verzeichnis auswählen. An dieser Stelle bietet mir die Fritz!Box die nachfolgende Auswahl an.



    Meine Wahl traf dieses mal auf Lexar-USBFlashDrive-01.

    Jetzt funzt auch das Testen in motionEye mit diesen Einstellungen.


    PS: das Grüne Bild ist nach Klick auf Apply nun wieder okay, aber das Einstellungen Menü ist wieder unvollständig. Ein Klick oben rechts auf motionEye, neu mit admin anmelden und das das Einstellungen Menü ist wieder komplett. !?!?!?!?


    Viele Grüße

    Ich Bins

  • wenn ich Dich nicht hätte.

    Ja, und die keinen Kartoffeln.... Wie meine Großeltern zu sagen pflegten...:P

    Ich habs ja schon immer gesagt, niemand braucht so Videozeuch. Alles so neumodischer Krams...(; Neee, ich hab nur mal kurz geguckt, die Beschreibung ist ja für eine ganz andere Kamera. Was wissen wir denn, was genau die dort mit den Einstellungen treiben... Wie hat der Gnom die Tage so formuliert: "Guck beim Schmied und nicht beim Schmiedl." Recht hatter.


    Den ftp Zugang hättest Du gar nicht neu machen müssen. Aber wenns jetzt funktioniert, ist es ja in Ordnung. Was das PS angeht, hatte ich gerade auch - nach dem aktuellen Update. Ansonsten wüsste ich jetzt nicht, dass man ausgeloggt wird bei Inaktivität. Mustte mal beobachten, ob das öfter passiert, dann würde ich eher auf ein Browserproblem tippen.


    Grüße, STF

    "And now for something completely different."


    Hofeis guide to: Wie frage ich nach Hilfe? *** Mein nagelneuer Raspberry Pi 3B+ zeigt nur ein buntes Bild. (Ab)Hilfe.

  • Oh, da muss ich dementieren - das war nicht ich, sondern RTFM (wenn ich das recht recherchiert habe). Ich kenn' den Spruch auch nur als: Geh zum Schmitt und nicht zum Schmittchen.

  • Oh, da muss ich dementieren - das war nicht ich, sondern RTFM (wenn ich das recht recherchiert habe). Ich kenn' den Spruch auch nur als: Geh zum Schmitt und nicht zum Schmittchen.

    Och ja, da haste recht. Aber Du kennst den Spruch auch, also musst Du jetzt trotzdem herhalten...(;

    "And now for something completely different."


    Hofeis guide to: Wie frage ich nach Hilfe? *** Mein nagelneuer Raspberry Pi 3B+ zeigt nur ein buntes Bild. (Ab)Hilfe.

  • Hallo zusammen,


    aktuell arbeitet mein Raspi mit motionEye recht stabil im Futterhäuschen.

    Mich wundert allerdings, dass oft kein Video aufgezeichnet wurde obwohl Besuch da war.


    Viele Grüße

    Ich Bins