Raspberry Pi 3 (Debian Jessie) startet nur im Emergency Mode

  • Moin,


    kurz vorweg möchte ich sagen, dass ich von dem Raspberry Pi 3 und dem Debian Jessie nicht wirklich viel Ahnung habe. Ich habe mir durch einfach gehaltene Anleitung damit einen Plex Media Server gezaubert, der einwandfrei funktioniert hat. Vor kurzem haben ich den Raspberry neugestartet und komme seitdem nur in den Emergency Mode:


    Welcome to emergency mode! After logging in, type "journalctl -xb" to view
    system logs, "systemctl reboot" to reboot, "systemctl default" to try again
    to boot into default mode.
    Give root password for maintenance
    (or type Control-D to continue):


    Keiner der angegeben Kommandos funktioniert. Control-D gibt nur eine neue Zeile raus und sonst kann ich auch gar keinen Text da rein schreiben.

    Ich hatte mich versucht etwas mit Google darüber zu informieren, nur leider kommen meistens Seiten auf englisch raus die für mich wie Informatiker Spanisch sind. Ich bin irgendwann drauf gestoßen, dass es etwas mit den fstab zu tun haben muss. Ich habe durch die Eingabe in NOOBS in der cmdline.txt "init=/bin/sh" quasi die console wieder geöffnet, die mir erlaubt mit "nano /etc/fstab" die fstab zu sehen (siehe Bild). Nun habe ich aber leider keine Ahnung was ich ändern müsste um dieses Problem zu lösen, da vorher ja auch alles funktioniert hat und das alles für mich Fach Chinesisch ist. Hatte auch versucht die neue fstab mal zu speichern, aber leider geht das auch nicht da ich die nicht überschreiben kann oder muss ich dort einen neuen Namen geben? Ist das überhaupt der richtige Lösungsansatz oder bin ich komplett auf dem Holzweg?


    Würde mich über jede Hilfe freuen, da ich momentan nicht über meinen Plex Server zugreifen kann und ich am verzweifeln bin...


    Danke im Voraus


    MfG Sascha :)



  • Hallo,


    bin mir nicht sicher ob das in diesem Fall der Grund ist, aber wenn nicht alle vier Deiner externen Laufwerke am RPi hängen, dann dürfte booten nicht funktionieren. :conf: Mehr kann ich dazu mangels Noobs nicht schreiben.

    "Alles, was wir sind, ist Sand im Wind, Hoschi."

  • Sind allle 4 Festplatten/USB-Sticks am RPi angeschlossen? Benutzt Du einen aktiven USB-Hub dafür?

    Noch zur Info: Die fstab darf nur root bearbeiten, also muss mit sudo aufgerufen werden.

    "Alles, was wir sind, ist Sand im Wind, Hoschi."

  • Das Problem hat sich gerade erledigt. Er hat scheinbar einer der Festplatten nicht erkannt. Nun erkennt er sie wieder und dann fährt er auch ganz normal wieder hoch. Hätte nicht gedacht das der Raspberry Pi alle externen Festplatten erkennen muss beim hochfahren. Ziemlich trivialer Fehler gewesen... trotzdem vielen Dank :) Dein tipp hat mir gut geholfen!

  • Hätte nicht gedacht das der Raspberry Pi alle externen Festplatten erkennen muss beim hochfahren

    Du sagst ihm in der /etc/fstab welche Dateisysteme er beim Start automatisch einbinden soll. Fehlt eines davon, ist das ein Fehler und der unterbricht zu Recht den Startvorgang (es könnten ja für den Betrieb wichtige Daten auf dem fehlenden Dateisystem liegen).

    Um das zu verhindern, setze z.B. die Option "noauto". Dann musst du aber anschliessend händisch mounten oder dies einem Script überlassen, dass auch gleich das Vorhandensein des Dateisystems prüft.

    The S in IoT stands for Security

    2 Mal editiert, zuletzt von llutz ()