Raspberry Pi B+ bootet nicht mehr

  • Hallo,

    nachdem ich meinen Raspberry endlich soweit am laufen hatte, mit Lan, Wlan, Pi control, wollte ich nun ein Binding über Open Hab installieren. Leider funktionierte das nicht. Nun habe ich gesehen, das ich per Remotedesktop keine zugriff mehr auf den Raspberry habe. Nachdem ich ihn dann vom Netz getrennt habe, bootet er leider nicht mehr. Die rote Powerleuchte ist an, die grüne LED flackert ein paar mal und geht dann aus.

    Am Bildschirm angeschlosssen sehe ich folgendes:



    ich hoffe es ist erkennbar.

    Die SD Karte ist am PC noch lesbar. Ein gesichertes Image hatte ich vorher leider nicht gemacht.

    Ich hoffe es ist nur eine Kleinigkeit.

    Ich würde mich über Hilfestellung sehr freuen.

  • Hallo joe cocker,


    so, wie es aussieht, hat es Schäden am Dateisystem gegeben. Als erstes mach trotzdem mal ein Backup. Danach starte einen filesystem check der Partition (Karte im Kartenleser am PC z.B.) aus einem laufenden Linux System (das kann auch ein Livesystem auf (D)einem PC sein) versuche damit, die Fehler zu beheben. Wenn Du Glück hast, lässt sich das System wieder starten.


    Gruß, STF

  • Hallo STF,

    Danke schonmal für Ihre Antwort.

    Gibt es für diese Vorgehenweise mit Kartenleser am PC und Windows 10 auf dem Rechner eine hilfreiche Anleitung ?


    Gruß joe

  • Hmm.....

    Ich stehe noch etwas auf dem Schlauch.

    Das Live Linux muss ich wo installieren, auf meinem Windows PC, oder auf eine neue SD Karte und dann in den RPi ?

    Oder auf die vorhandene SD Karte, von wo aus der RPi eingentlich starten soll ?

    Wo bekomme ich dieses Live Linux ?


    Sorry, Gruß joe

  • Möglichkeit 1: starte Deinen RPi mit einer neu geflashten weiteren SD Karte (wenn vorhanden) mit Raspbian lite und steck nach dem Start die zu reparierende Karte im Kartenleser an den Pi, repariere so wie angegeben

    Möglichkeit 2: Lade Dir ein Live Linux für den PC herunter (sowas hier z.B.) installiere das auf einen Stick und starte den PC davon, darauf installiert werden muss gar nichts, das ist ja das schöne

  • Hallo,

    bin leider nicht eher zum Testen gekommen.

    Ich habe nun eine 2. SD Karte mit Raspbian lite geflasht. Dies hat soweit gut geklappt, der RPi bootet wieder.

    Wenn ich aber über den Kartenleser die originale (defekte?) Karte, auf der ich die Dateien dann sehen kann, reparieren lassen will, Kommt eine Meldung, von wegen gemounted.

    An diesem Punkt hänge nun leider.....


    VG joe

  • Vermutlich musst du vorher abmelden (umount). Siehe auch man umount. Nach dem "unmounten" kannst du das mit dem reparieren nochmal versuchen.

  • Raspberry 3B+ startet nicht.


    Hallo,

    ich hatte fast das gleiche Problem, nur das der PI 3B+ gleich in der Startphase (Colorbild) stecken blieb und die grüne LED immer 4x kurz hintereinander blinkte.

    Daraufhin schrieb ich die Fa. Pollin an, von der ich diesen gekauft hatte, die mir eine neue ( bcm2710-rpi-3-b-plus.dtb ) mitschickten, die ich in den Bootordner kopieren sollte.

    Dann hatte ich mit aus dem Internet noch einmal das neuste Raspian herunter geladen und die mitgelieferte Datei in den Boot-Ordner kopiert.

    Nach dem ich dann die Mikro-SD-Karte in den neuen 3B+ gesteckt hatte, erschien wieder nur diese bunte Farbtafel und der 3B+ blieb stecken.


    Danach probierte ich die gleiche SD-Karte in einem 3B aus und dort startete der Raspi anstandslos.


    Dann kam ich auf die Idee, mit dem 3B ein Update und Upgrade durchzuführen und das System auf den neusten Stand zu bringen.

    Nachdem ich diese aktualisierte Version auf der SD-Karte in den 3B+ gesteckt hatte, startete dieser endlich zum ersten mal.


    Offensichtlich fehlt bei dem originalen Raspian irgend eine Datei, dass den 3B+ in der Startphase zum Stillstand kommen lässt.

    Ich als Laie kann allerdings nicht sagen, woran das liegt. Aber leider wird nicht jeder einen zweiten Raspberry zu Hause haben um so dieses Problem zu lösen.


    Gruß Tommy


    Wo man singt, da lass Dich nieder,

    schlechte Menschen haben keine Lieder.

  • Hallo Tommy0,


    diese Erfahrung kann ich so nicht bestätigen. Dein Problem deutet tatsächlich auf eine alte Raspbian Version hin. Die auf der Homepage seit 14.3. verlinkten Versionen NOOBS 2.7.0 (vom 14.3.2018) und Raspbian (lite) Version March 2018 (vom 13.3.2018) starten anstandslos und sofort auf dem RPi3B+. Ein Upgrade einer älteren Stretch Version tut’s natürlich auch, allerdings brauchst Du, wie Du ja selbst festgestellt hast, einen der älteren RPi.


    Grüße, STF

  • Hallo,

    leider habe ich keinen Erfolg bei dem Problem.


    Mit sudo fdisk -l habe ich überprüft, ob die Karte im Kartenleser erkannt wird - alles korrekt.

    Dann habe ich das Dateisystem ausgehängt, mit sudo umount /dev/sda2 - hat funktioniert.

    Anschließend Reparatur, sudo fsck -y /dev/sda2 - scheint auch funktioniert zu haben.

    Danach mit sudo fsck.vfat -r /dev/sda1 den Remove dirty bit mit 1 bestätigt (beseitigt).

    Reparierte Karte wieder eingesteckt, bootet immer noch nicht.

    Von der reparierten Karte mal ein Image erstellt, passte leider nicht ganz auf eine andere SD-Karte (Image 7,42 GB, andere Karte komischerweise nur 7,4 GB). Karte trotzdem mal getestet, ohne Erfolg. Image noch mal auf die alte Karte gespielt, auch ohne Erfolg.

    Was könnte ich jetzt noch machen ? Nochmal eine größere SD-Karte besorgen und testen? Oder kann sich jemand mal mein Image anschauen und testen, falls ich es irgendwie schicken kann ?

    Bin gerade etwas ratlos........


    Gruß joe