Benutzer einrichten funktioniert nicht

  • Hallo,


    ich bin neu im Forum und beschäftige mich seit zwei Wochen mit einem Raspberry PI 3.


    Wenn ich einen Benutzer mit adduser anlegen will kommt die Fehlermeldung


    cannot lock /etc/group; try again later


    Benutze ich useradd wird in der gleichen Form die passwd angemeckert.


    Die Dateien group, passwd und shadow stehen ohne Endungen im Verzeichnis /etc. Es sind auch sonst keine Dateien mit der Endung .lock vorhanden.


    Vielleicht hat jemand eine Lösung für das Problem.


    Schonmal danke und viele Grüße

    Heinz

  • Hallo Apop,


    das funktioniert genau so wenig wie mit adduser unter root. Danke für den Hinweis und den Link, nur reicht dafür mein Englisch nicht.


    Gruß Heinz

  • Hey Heinz


    Wäre ja auch zu einfach gewesen ;) .

    Finde jetzt leider auf die schnelle auch nichts was dir so helfen könnte. Hab ein einem Beitrag gelesen dass es helfen könnte die Rootpartition erneut mit rw-rechten zu mounten, dieser war jedoch aus dem Jahr 2011 daher würd ich da nicht zu viel Hoffnung rein setzen.


    group passwd und shadow stehen bei mir auch ohne Endung im Verzeichnis, denke also daran wirds kaum liegen.

    Ich suche nicht nach einer fertigen Lösung sondern nach dem Weg dahin ;)

    Edited once, last by Apop85 ().

  • dass es helfen könnte die Rootpartition erneut mit rw-rechten zu mounten,

    Das ist nicht zielführend!


    Was soll denn die "Root-Partition" sein? (Die gibt es nicht!)


    Es gibt ein /root - Verzeichnis, das gehört den User "root" und wer das mit rw-Rechten für "other" versieht, dem gehört der Rechner aus der Hand...:wallbash:


    Zum Anlegen eines User wird (wie schon beschrieben) das Kommando


    sudo adduser "NeuerBenutzerName" 


    verwendet. (Hochkommas weglassen)


    Du wirst zuerst nach einem Password gefragt (dass Passwort des Users, mit dem du gerade eingeloggt bist).

    Wenn das nicht der Fall ist, gibt es 2 Möglichkeiten:

    1. du hast innerhalb der letzten 5 Minuten schon einmal ein sudo abgesetzt (dann wird das Kommando sofort ausgeführt)

    2. Eine Fehlermeldung: der User hat keine Berechtigung, sudo zu verwenden.


    Hilfreich wäre es, deine Kommandos und die Ergebnisse auf der Kommandozeile hier zu posten.

  • Hilfreich wäre es, deine Kommandos und die Ergebnisse auf der Kommandozeile hier zu posten.

    Die Fehlermeldung hat er bereits im ersten Post beigefügt: cannot lock /etc/group; try again later

    Leider war das von mir erwähnte die einzige was Google im Zusammenhang mit Benutzer anlegen und dieser Meldung ausgespuckt hat. Habe es leider fehlerhaft übernommen (Habs korrigiert, danke fürs darauf aufmerksam machen... hätte man auch respektvoller erwähnen können mmn). Aber dass das wohl nicht die passende Lösung ist habe ich ja im selben Atemzug auch erwähnt.

    https://www.google.de/search?q…/group%3B+try+again+later

    Ich suche nicht nach einer fertigen Lösung sondern nach dem Weg dahin ;)

    Edited 2 times, last by Apop85 ().

  • Hallo,


    ich habe das Betriebssystem Raspbian auf eine andere Karte aufgespielt und nach dem Kartenwechsel und Neustart auf dem Raspberry Update und Upgrade laufen lassen. Dann konnte ich problemlos Benutzer anlegen.


    Also muss nach der Basiskonfiguration der ursprünglichen Karte beim Anlegen der Mount-Verzeichnisse und/oder Einbinden des USB-Sticks etwas passiert sein. Das Problem trat bei der ersten Benutzereingabe auf. Damit ist eigentlich auszuschließen, dass irgendwelche Sperren, die einen gleichzeitigen Mehrfachzugriff auf die in Frage kommenden Dateien verhindern, wirksam sind (siehe datei.lock und meinen ersten Beitrag).


    Danke für die Informationen
    Gruß Heinz

  • Hallo Zentris,


    in der Anlage findest Du meine Eingaben und die Ergebnisse mit "adduser" und "useradd". Das Ergebnis ist beim Benutzer pi und bei root gleich. Wie im ersten Beitrag von mir schon geschrieben sind unter /etc keine Dateien gelockt.


    Gruß Heinz

  • Man müsste erst mal wissen was der error code 10 bedeutet. Vielleicht mal adduser mit --debug aufrufen. Ich vermute es ist der Abbruch code. Das die Datei /etc/group nicht "gelockt" werden kann, deutet auf ein anderes Programm hin, welches diese Datei gerade in Benutzung hat. Es gibt vielleicht ein Systemmonitor, der das anzeigen kann, oder ein "unlock" Tool. Eine Kopie von /etc/group machen und dann versuchen die original Datei zu löschen, dürfte nicht funktionieren, wenn die Datei "gelockt" ist. Die Datei /etc/adduser.conf überprüfen, könnte auch nicht schaden.

  • Hallo daxb,


    in der Anlage ist die schrittweise Abarbeitung des "adduser" Kommandos. Die Datei kann ich weder als "pi" noch als "root" kopieren, siehe nachstehende Fehlermeldung.


    cp: cannot create regular file system 'tmp/group': Read-only file system


    Außerdem habe ich den Inhalt der adduser.conf als Text eingestellt. Leider kann sagt mir der Inhalt der Datei wenig, bzw. ich kann nicht erkennen, ob da Unregelmäßigkeiten drin stehen.


    Ob es einen Systemmonitor oder ein Unlock-Tool gibt entzieht sich meiner Kenntnis. Ein Kommando unlock <Datei> gibt es nicht, das habe ich ausprobiert.


    Gruß Heinz

  • Hallo Manul,


    bei mount -a kommt folgende Meldung


    mount: /etc/fstab: parse error at line 2 -- ignored


    Im Anhang ist der Inhalt der /etc/fstab


    Gruß Heinz


    PS: Auf den Datenstick kann ich zugreifen

  • Hallo Manul,


    mein Problem ist, dass ich die fstab nach der Änderung nicht abspeichern kann. Es kommt die Meldung


    Error writing /etc/fstab: Read-only file system


    Gibt es eine Möglichkeit die Dateiattribute auf "rw" zu setzen?


    Gruß Heinz

  • Hallo Manul,


    mit Deiner Anweisung konnte ich die fstab ändern und habe das Gerät rebootet. Das ursprüngliche Problem mit dem Anlegen von Benutzern ist allerdings geblieben.


    Ich würde das System ja neu machen, habe aber Bedenken, dass das Problem dann trotzdem wieder auftritt.


    Gruß Heinz


    Ich sehe gerade, dass das root-system wieder auf read-only gesetzt ist. Das muss nach dem Reboot passiert sein. Danach habe ich auch versucht einen Benutzer anzulegen.

    Edited once, last by FlatFog53140: Nachtrag ().