Keine Wlanverbindung mit stretch lite + Raspi Zero w

  • Hallo,


    bisher habe ich meine Raspi´s eigentlich immer einrichten können und wenns mal Probleme gab, habe ich hier immer eine Lösung gefunden. Aber mit dem Zero W komme ich einfach nicht weiter und somit ist dies mein erster Post hier.


    Ich versuche schon den ganzen Tag das Wlan auf dem Zero W zu aktivieren, leider blieben alle Versuche erfolglos.


    Folgendes habe ich getan:


    1. Das aktuelle "2018-03-13-raspbian-stretch-lite.img" runtergeladen und entpackt.


    2. Mit applePI-backer (nutze einen Mac) die Micro-SD-Karte formatiert und das o. g. Image auf die Karte geschrieben.


    3. Dann habe ich mit dem Texteditor vom Mac auf meinem Desktop einmal die "ssh"-Datei ohne Dateiendung erstellt sowie die Datei "wpa_supplicant.conf" mit folgendem Inhalt und gleichem Format:


    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

    update_config=1

    country=DE



    network={

    ssid="Homi-4“

    psk="mein Wlan Passwort"

    key_mgmt=WPA-PSK

    }


    4. Beide Dateien habe ich dann im Finder vom Mac ins Root-Verzeichnis der Karte kopiert, danach die Karte ordnungsgemäß ausgeworfen und in den Zero W gesteckt, den Zero W mit dem Netzteil verbunden und gestartet.


    Das wars dann auch, der Zero verbindet sich nicht mit dem Router. Im Router selber sind keine Anmeldesperren, Mac-Filter oder dergleichen eingerichtet. Ferner habe ich auch noch mit einen zweiten Router getestet, alles ohne erfolg.


    Liegt es evtl. daran, dass ich die "Lite-Version" des Image genommen habe (die Vollversion benötige ich eigentlich nicht)?


    Es ist doch richtig, dass mein Wlan Passwort sowie die SSID incl. der Anführungszeichen angegeben werden muss.


    Ich hoffe jemand hat ne Idee für mich, ich zweifel langsam an mir selbst.


    Viele Grüße

    Ranti



    Edit:

    Bei der ganzen Testerei ist mir noch aufgefallen, dass die o. g. Dateien, nachdem ich sie abändern wollte, manchmal auf der Karte nicht mehr vorhanden waren?!?

    ____________________

    Gruß, Ranti

    Edited once, last by Ranti ().

  • Moin Ranti,


    erstmal: Herzlich Willkommen im Forum!


    Liegt es evtl. daran, dass ich die "Lite-Version" des Image genommen habe (die Vollversion benötige ich eigentlich nicht)?

    Nein, die Lite-Version hat nur das ganze X-Kram nicht. Alles andere ist identisch.



    Bei der ganzen Testerei ist mir noch aufgefallen, dass die o. g. Dateien, nachdem ich sie abändern wollte, manchmal auf der Karte nicht mehr vorhanden waren?!?

    Beide Dateien müssen nach dem Start verschwunden sein. Die leere ssh ist nur als Hinweis gedacht, das ssh freigegeben werden soll. Ist sie nicht da bleibt ssh aus.

    Die wpa_supplicant.conf wird nach /etc/wpa_supplicant verschoben.


    Es ist doch richtig, dass mein Wlan Passwort sowie die SSID incl. der Anführungszeichen angegeben werden muss.

    Ja, richtig.


    Ich würde noch pairwise=CCMP vor der Klammer einfügen Eventuell auch noch proto=RSN.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Und das ganze natürlich mit einen Linux kompatiblen Editor und nicht z.b. dem Windows Editor.

    Der Unterschied zwischen Genie und Wahnsinn definiert sich im Erfolg.

  • Hallo,


    vielen Dank für die freundliche Begrüßung und Eure Hilfe!


    Also, ich hab es jetzt auch mit den Parametern von Bernd666 (pairwise=CCMP   proto=RSN) versucht, ...kein Erfolg.


    Die "ssh" und die "wpa_supplicant.conf" Dateien habe ich mit Notepad++ im Unix_Format erstellt, das sollte eigentlich OK sein.


    Momentan muss ich wohl davon ausgehen, dass das Wlan-Modul des Pi defekt ist.


    Ich habe mir über die Anleitung bzw. den Link hier Forum, die USB-Schnittstelle auf dem Zero aktiviert und kann per SSH auf den Zero zugreifen. Gibt es eine Möglichkeit, so das Wlan-Modul des PI zu testen bzw. abzufragen?


    EDIT:

    Zu früh gefreut. Kann den Zero im Terminal zwar mit "ssh raspberrypi.local" ansprechen, ...ABER das Standard-Passwort "raspberry" wird nicht akzeptiert. :conf::wallbash:

    ____________________

    Gruß, Ranti

    Edited once, last by Ranti ().

  • Hallo hyle,


    habs eben getestet.


    Mit scan_ssid=1 gehts leider auch nicht.


    z/y bei der PW-Eingabe zu tauschen geht auch nicht.


    Danke für Eure Hilfe, aber ich glaube der Zero ist defekt.

    ____________________

    Gruß, Ranti

  • Moin,


    ich muss noch einmal kurz stören.


    Kann ich, um z. B. einen anderen Router zu testen, einfach eine neue "wpa_supplicant.conf" Datei anlegen?


    Um Fehler zu vermeiden habe ich bisher immer ein neues Image geflasht und dann eine neue "wpa_supplicant.conf" angelegt. Bei der ganzen Testerei ist das ziemlich nervig.

    ____________________

    Gruß, Ranti

  • Kann ich, um z. B. einen anderen Router zu testen, einfach eine neue "wpa_supplicant.conf" Datei anlegen?

    Das brauchst Du nicht, denn Du kannst in der "wpa_supplicant.conf", mehrere network-blocks eintragen (evtl. mit unterschiedlicher priority-Konfiguration):

    Code
    1. # priority: Priority group
    2. # By default, all networks and credentials get the same priority group
    3. # (0). This field can be used to give higher priority for credentials
    4. # (and similarly in struct wpa_ssid for network blocks) to change the
    5. # Interworking automatic networking selection behavior. The matching
    6. # network (based on either an enabled network block or a credential)
    7. # with the highest priority value will be selected.
  • Hallo rpi444,


    OK, das würde aber voraussetzen das ich Zugriff auf den Pi habe um die Datei editieren zu können. Den habe ich ja nicht, weil ich das WLAN nicht zum Leben erwecken kann. Oder stehe ich da gerade auf der Leitung?

    ____________________

    Gruß, Ranti

  • Das schon, aber so wie ich das verstanden habe wird die Datei wpa_supplicant.conf nach /etc/wpa_supplicant verschoben und da komme ich rein über die Karte ja nicht hin.

    ____________________

    Gruß, Ranti

  • Hmm OK, das wusste ich nicht. Dann werde ich das mit einem Linux mal ausprobieren.


    Danke für die Info:thumbup:

    ____________________

    Gruß, Ranti

  • So, ich habe nun Ubuntu in einer VM am laufen. Auch dort wird mir die gleiche Ordnerstruktur angezeigt wie sonst auch?!?


    Da komme ich nicht nach /etc/wpa_supplicant! Wie auch, das Verzeichnis wird doch erst nach Start des Systems angelegt???


    Ich bin irritiert...

    ____________________

    Gruß, Ranti

  • Moin Ranti,


    du musst einmal den Raspberry mit der neuen Karte starten.

    Dann liegt die wpa_supplicant in dem richtigen Ordner.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Oder selbst anlegen, oder? Gruß, STF

    Das andere ist aber einfacher UND man hat gleich die richtige Zugriffsrechte und Eigentümer gesetzt.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Moin,


    da bin ich wieder und jetzt wird´s richtig merkwürdig.


    Ich hab mir vom Nachbarn eine Fritzbox 7360 ausgeliehen die er mom. nicht nutzt.


    Hab die /etc/wpa_supplicant angepasst und auf das neue Image kopiert ...und siehe da, der Pi bekommt eine IP zugewiesen:





    Aber ich kann Ihn nicht anpingen und komme somit auch nicht mit SSH nicht weiter???:






    Hat da einer eine Idee?

    ____________________

    Gruß, Ranti

  • Moin Ranti,


    ein anderes Gerät im gleichem Wlan lässt sich anpingen?

    Nur um auszuschliessen, das es nicht an der Box liegt.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.