Fehlermeldung beim mounten von SMB NAS: mount error(112): Host is down

  • System ist RPi3B mit Raspian Stretch Desktop: Linux raspberrypi 4.14.30-v7+ #1102 SMP Mon Mar 26 16:45:49 BST 2018 armv7l GNU/Linux. Der RPi ist per Ethernet an der Fritzbox 4790 angeschlossen, sowie die NAS USB Festplatte.


    Seit kurzem bekomme ich beim mounten des NAS die Fehlermeldung mount error(112): Host is down. Den genauen Zeitpunkt seit wann das so ist, kann ich leider nicht sagen. Da ich "nichts" geändert habe ausser Update/Upgrade, vermute ich das ein Upgrade dafür verantwortlich ist. Es gibt viele Treffer, wenn man nach der Fehlermeldung im Internet sucht. Oft sei ein Windows oder Linux Update der Grund. Eine Lösung des Problems war z.B. vers=1.0 im Mount Aufruf. Das funktioniert hier auch und ist quasi die Lösung. Die Fritzbox 4790 unterstützt laut AVM Homepage nur SMB V1.0.


    In der /etc/fstab habe ich also folgende Zeile geändert:

    //fritz.box/FRITZ.NAS/Maxtor /home/pi/NAS cifs ,credentials=/home/pi/.smbcredentials,uid=pi,gid=pi 0 0

    in

    //fritz.box/FRITZ.NAS/Maxtor /home/pi/NAS cifs vers=1.0,credentials=/home/pi/.smbcredentials,uid=pi,gid=pi 0 0


    Da nach /var/log/apt/history.log es Updates von den Paketen mount und samba gab (hier am 13.03 und 18.03), habe ich in Hoffnung einer Erklärung die Changelogs gelesen. Leider kann ich damit keine Erklärung herstellen. Da auch ein Kernel Update in der Zeit lag, liegt die Ursache vielleicht wo anders. Im Moment kann ich nur Vermutungen anstellen.


    Hat irgend jemand eine Erklärung, oder kann etwas Licht ins Dunkel bringen?

    ps: Gibt es ausführlichere Changelogs als die in /usr/share/doc?

  • Return Code = 112 = 64 + 32 + 16

    16 = problems writing or locking /etc/mtab

    Möglicherweise ist beim Abarbeiten von /etc/fstab das Netzwerk noch nicht bereit für den cifs-mount (siehe "man mount" ... _netdev Option)


    Kannst Du Deinen NAS anpingen ? Dann probiere ein < sudo mount -a > (allenfalls nach einem umount -a), oder mach ein manuelles sudo mount -t cifs ... mit allen Deinen Optionen.



    Servus !

    RTFM = Read The Factory Manual, oder so

  • Die Fehlermeldung kommt ja auch, wenn ich auf dem Desktop eine Shell öffne und dann versuche manuell das NAS zu mounten. Das der NAS da ist und funktioniert habe ich als erstes geprüft. Wenn ich LibreElec boote, funktioniert der Zugriff auch das NAS ganz normal. Und der geänderte Mount Befehl wie oben beschrieben (vers=1.0) in der fstab oder manuell mount funktioniert. Die Vermutung ist das mit einem Update/Upgrade sich etwas geändert hat und die Angabe von vers=1.0 nötig macht. Normal sollte doch automatisch ermittelt werden, welche Samba Version die richtige ist. So war das ja vorher auch. Vielleicht (ich rate) wird durch ein Sicherheitsupdate Samba V1.0 nicht mehr automatisch nutzbar und man muss es manuell aktivieren?

    • Official Post

    Ich weiss aus der Windowswelt, das mit dem 1709er - Fall Creators Update SMB V1 deaktiviert wurde. Vielleicht ist das im Zuge dessen auch in der Linuxwelt passiert (oder andersrum)

  • Moin daxb,


    ich weiss, es hört sich blöd an, aber ich habe auch schon mal stundenlang nach einen Fehler gesucht.

    Alle konnten meinen Nas(nicht FB) nur ein RPI nicht.


    Ende vom Lied, FB resetet. Alles gut!!


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Eine Suche nach der Fehlermeldung im raspberrypi.org Forum ergibt einige Treffer. U.A. diesen, nur sind da die Fragesteller nicht sehr mitteilsam.Dort wird auch vers=x.x vorgeschlagen. Laut man mount.cifs ist SMB V1.0 die standard Einstellung. Theoretisch müsste ich also nicht manuell vers=1.0 angeben. Möglicherweise ist die Anleitung nicht mehr gültig?


    Aus man mount.cifs:

    Code
    vers=
    SMB protocol version. Allowed values are:
    ·   1.0 - The classic CIFS/SMBv1 protocol. This is the default.
    ·   2.0 - The SMBv2.002 protocol. This was initially introduced in Windows Vista Service Pack 1, and Windows Server 2008. Note that the initial release version of Windows Vista spoke a slightly different dialect (2.000) that is not supported.
    ·   2.1 - The SMBv2.1 protocol that was introduced in Microsoft Windows 7 and Windows Server 2008R2.
    ·   3.0 - The SMBv3.0 protocol that was introduced in Microsoft Windows 8 and Windows Server 2012.
    Note too that while this option governs the protocol version used, not all features of each version are available.

    Edited once, last by daxb ().

  • System ist RPi3B mit Raspian Stretch Desktop: Linux raspberrypi 4.14.30-v7+ #1102



    Da nach /var/log/apt/history.log es Updates von den Paketen mount und samba gab (hier am 13.03 und 18.03), habe ich in Hoffnung einer Erklärung die Changelogs gelesen. Leider kann ich damit keine Erklärung herstellen. Da auch ein Kernel Update in der Zeit lag, liegt die Ursache vielleicht wo anders.

    Lt. release notes der r-pi foundarion, http://downloads.raspberrypi.org/raspbian/release_notes.txt

    Wird ab 18.3.2018 der Kernel 4.9.88+ ausgeliefert.


    Dein Kernel 4.14.30 ist als stable wahrscheinlich noch gar nicht freigegeben.


    Wie hast Du Dein Kernel Update durchgeführt ?




    Servus !

    RTFM = Read The Factory Manual, oder so

  • Ich hoffe mal das der Kernel ein stable release ist, denn die sind über apt-get upgrade installiert worden (/etc/apt/sources.list habe ich auch nicht geändert):

    Es scheint aber wirklich so, das der Kernelupate für das Problem verantwortlich ist. Im /var/log/syslog habe ich folgendes gefunden:

    Code
    Apr  5 13:17:11 raspberrypi kernel: [   16.160171] No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3 (or SMB2.1) specify vers=1.0 on mount.
    Apr  5 13:17:12 raspberrypi kernel: [   16.448706] CIFS VFS: cifs_mount failed w/return code = -112

    Wenn ich es richtig verstanden habe, dann hat sich der Default Wert von V1.0 auf V2.1 geändert. Könnt ihr das bestätigen?

  • Ich hoffe mal das der Kernel ein stable release ist, denn die sind über apt-get upgrade installiert worden

    Eher nicht, der offizielle Kernel ist derzeit Linux raspberrypi 4.9.80-v7+ #1098 SMP Fri Mar 9 19:11:42 GMT 2018 armv7l GNU/Linux.

    rpi-update hat das hier am 26.3. eingespielt... dort wird's wohl eher hergekommen sein. Fehler inclusiv.


    Commits on Mar 26, 2018

    kernel: Bump to 4.14.30

     [Blocked Image: https://avatars3.githubusercontent.com/u/1053730?s=60&v=4]

    popcornmix

    committed 10 days ago

  • Moin!


    ist schon komisch.

    Code
    pi@bernd-test-lite:~ $ uname -a
    Linux bernd-test-lite 4.14.30-v7+ #1102 SMP Mon Mar 26 16:45:49 BST 2018 armv7l GNU/Linux

    So sieht es bei mir aus.

    Ich habe keinen rpi-update gemacht!!


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Ich habe auch kein rpi-update gemacht wie man auch am Log sehen kann. Das ist über apt-get upgrade reingekommen. Nicht stable kommen doch nicht ohne eigenes Zutun zustande, oder?

  • Moin daxb,


    das will ich mal stark hoffen!

    Laut /var/log/apt/history.log habe ich folgendes raspberrypi-kernel:armhf (1.20180313-1, 1.20180328-1) bekommen.


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.