Raspberry Pi 3 Model B+ (Fritzbox+USB) Festplatte Mounten

  • Hallo zusammen,


    auch ich habe das Problem, dass ich meine Fritzbox 7390 mit einem eingestecktem USB-Stick als Festplattenserver leider nicht mounten kann.

    Unter "df" zeigts mir mein Raspi 3 Model B+ (mit Raspbian Stretch + Desktop) weder die Fritz, noch den USB an. Da scheint das Mounten einfach nicht geklappt zu haben.. nur "was" ist falsch?

    Habe meinen Lexar-USBFlashDrive-01 mit dem Dateisystem NTFS formatiert, an der Fritzbox 7390 an der Rückseite angesteckt und dort an Heimnetz aktiviert.

    In der Fritzbox ist auch ein neuer Benutzer unter System > Fritz!Box Benutzer eingerichtet.

    Die Netzwerkfreigabe sollte unter /media auf dem Raspi zugreifbar sein. Deshalb habe ich einen Ordner erstellt..


    sudo mkdir -vp /media/fritzbox-usb


    Habe dann eine Credentials Datei angelegt, welcher Benutzer und Passwort speichert

    cd /home/pi
    nano .smbcredentials


    username=xyz
    password=xyz


    Wollte dann in der fstab Datei die Zeile eintragen, dass automatisch gemounted werden kann


    //192.168.178.1/fritzbox/Lexar-USBFlashDrive-01 /media/fritzbox-usb cifs username=xyz,password=xyz,x-systemd.automount,noauto,uid=1000,gid=1000d=1000,iocharset=utf8 0 0


    sudo reboot


    ... doch bekomme ich keine Verbindung zum USB.


    Ich möchte nicht nerven.. Nach der Anleitung unter Tutorials hat es leider nicht funktioniert, weshalb ich um Eure Hilfe freundlichst bitte.

    Vielen Dank

  • Hallo hyle, hallo DG8BR,


    habt zunächst vielen Dank, dass Ihr mir helfen möchtet!!


    Ich habe meinen obigen Eintrag aus der fstab entfernt und versucht, über den einmaligen Weg zu mounten.


    sudo mount -t cifs -o username=xyz,password=xyz //192.168.178.1/Lexar-USBFlashDrive-01 /media/fritzbox-usb

    mount error(112): Host is down

    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)


    Wenn der Host doch down ist, kann es nicht funktionieren. Aber als Host ist doch der Stick gemeint oder? Dieser wird mir aktiv in der Fritzbox gezeigt, als auch im Heimnetz unter Windows.

    Ich vermute (warum auch immer), dass der Pfad nicht stimmt.

    Die 192.168.178.1 passt genau zur Fritzbox. Doch bin ich mir nicht sicher, ob dahinter gleich der Lexar-USBFlashDrive-01 kommt, oder zuvor noch fritz.nas?

  • Ich vermute (warum auch immer), dass der Pfad nicht stimmt.

    ich auch


    die FB Jungs haben die Pfade verändert, jedenfalls von der 3270 zur 7580, also befrage deine Fritzbox wie das fritz-box-Nas anzusprechen ist

    lasst die PIs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Der Pfad von hyle müsste funktionieren. Hier mit der FritzBox 7490 ist jedenfalls fritz.nas im Pfad nötig. Das ist der Ort des internen Speichers. In der FritzBox Weboberfläche kannst du auch dein USB Stick sehen und drauf zugreifen. Wenn das funktioniert, ist der Host auch nicht down.


    Wenn du den aktuellen Kernel 4.14.30-v7+ installiert hast, dann ist ggf. die Option vers=x.x im Mount Befehl nötig. Näheres siehe hier.


    Mein Eintrag zum mounten des Fritz NAS sieht so aus (Maxtor ist der Speicher am USB Anschluss):
    //fritz.box/FRITZ.NAS/Maxtor /home/pi/NAS cifs vers=1.0,credentials=/home/pi/.smbcredentials,uid=pi,gid=pi 0 0

    Edited once, last by daxb ().

  • Quote

    In der FritzBox Weboberfläche kannst du auch dein USB Stick sehen und drauf zugreifen. Wenn das funktioniert, ist der Host auch nicht down.


    Wenn du den aktuellen Kernel 4.14.30-v7+ installiert hast, dann ist ggf. die Option vers=x.x im Mounte Befehl nötig.

    Hallo :)

    Ja in der Fritzbox Weboberfläche kann ich meinen USB-Stick sehen. Deswegen war meine Theorie auch, dass der Host auch nicht down sein kann.

    Auf dem Raspi 3 B+ ist der Kernel auch der aktuelle 4.14.30-v7+ installiert.


    Ich kann allerdings erst morgen früh testen, ob eure Einträge funktionieren.

    Diese kommen dann aber in der fstab Datei?


    Ich müsste die Zeile dann von


    Quote

    //fritz.box/FRITZ.NAS/Maxtor /home/pi/NAS cifs vers=1.0,credentials=/home/pi/.smbcredentials,uid=pi,gid=pi 0 0

    ändern in

    //fritz.box/FRITZ.NAS/Lexar-USBFlashDrive-01 /media/fritzbox-usb cifs vers=1.0,credentials=/home/pi/.smbcredentials,uid=pi,gid=pi 0 0


    Hoffentlich funktioniert es dann auch.

    Ich werde selbstverständlich berichten!

  • Das hattest du ja schon erwähnt gehabt hyle, entschuldige bitte :/


    Ich werd bestimmt meine Schwierigkeiten mit dem Versuch des mountens bekommen, da ich nicht genau weiß, wo ich mein Pfad, sprich /media/fritzbox-usb setzen soll :/


    Ich versuche es in der früh dann mal so und schaue was mir angezeigt wird:


    sudo mount -t cifs -o username=xxx,password=xxx //fritz.box/fritz.nas/Lexar-USBFlashDrive-01 /home/pi/media/fritzbox-usb cifs vers=1.0,credentials=/home/pi/media/fritzbox-usb/.smbcredentials,uid=pi,gid=pi 0 0

  • Wenn der Pfad /media/fritzbox-usb (/home/pi/media/fritzbox-usb meinst Du sicher nicht) existiert und der angemeldete Nutzer dort Rechte hat, dann geht es entweder so:


    Code
    sudo mount -t cifs -o username=xxx,password=xxx,vers=1.0 //fritz.box/fritz.nas/Lexar-USBFlashDrive-01 /media/fritzbox-usb


    Oder so:


    Code
    sudo mount -t cifs -o vers=1.0,credentials=/home/pi/media/fritzbox-usb/.smbcredentials,uid=pi,gid=pi //fritz.box/fritz.nas/Lexar-USBFlashDrive-01 /media/fritzbox-usb

    Wobei die credentials unterhalb des Mountpoint zu speichern schon "mutig" ist. Weiß nicht, ob das so funktioniert. Die Credentials kannst Du dort lassen oder besser mit chmod 700 in /root speichern (Pfad beim mounten anpassen!). Die Fritz!Box ist standardmäßig unter fritz.box,fritz.nasoder ihrer IP zu erreichen. Den weiteren Teil (bei Dir fritz.nas) kannst Du auch selbst bestimmen und in der Box eintragen. So sieht es selten blöd und unlogisch aus, wie es sich die Programmierer bei AVM gedacht haben.


    Grüße, STF

  • Guten Morgen und wie zugesagt, versuch ich jetzt zu mounten. Ich danke auch dir STF ganz herzlich für deine Hilfe!!


    Beim ausführen des 1. Code steht:


    sudo mount -t cifs -o username=xxx,password=xxx,vers=1.0 //fritz.box/fritz.nas/Lexar-USBFlashDrive-01 /media/fritzbox-usb

    Retrying with upper case share name

    mount error(6): No such device or address

    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)


    Beim 2. Code:


    sudo mount -t cifs -o vers=1.0,credentials=/home/pi/media/fritzbox-usb/.smbcredentials,uid=pi,gid=pi //fritz.box/fritz.nas/Lexar-USBFlashDrive-01 /media/fritzbox-usb

    error 2 (No such file or directory) opening credential file /home/pi/media/fritzbox-usb/.smbcredentials

  • sudo mount -t cifs -o username=xxx,password=xxx,vers=1.0 //fritz.box/FRITZ.NAS/Lexar-USBFlashDrive-01 /media/fritzbox-usb

    Retrying with upper case share name

    mount error(6): No such device or address

    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)


    Das ist wahrscheinlich nur eine kleinigkeit woran es nicht will... ich starte die Geräte vielleicht alle mal neu..

  • Dann stimmt die Freigabe nicht, sieh mal in der Fritte nach: Heimnetz -> Speicher (NAS) Das sollte irgendwie so aussehen.


    Und Deine Freigabe muss natürlich auch korrekt (so ähnlich wie im Bild) sein:


    Edit:

    Achso, und der Benutzer (System -> Fritz!Box Benutzer) sollte es natürlich auch dürfen (für alles so wie im Bild, bzw. einzelne Verzeichnisse angeben):


  • Zugang hab ich auch aktiviert gehabt



    Aber das OS... es scheint veraltet zu sein... 06.51

    Da guck ich rasch mal nach einem Update!


    Installiertes FRITZ!OS: 06.51

    Neues FRITZ!OS: 06.83 <<< werds rasch installieren

  • Wenn Du die grafische Oberfläche auf Deinem Pi aktiviert hast, kannst Du im Dateimanager auch folgendes eingeben: smb://fritz.nas/ Dies sollte die Freigaben anzeigen und auch einen Dialog zur Eingabe des Nutzers. Passiert da was?



  • Die Freigaben sind seitens AVM mal irgendwann verändert worden. Könnte sein, dass dies bei 6.51 noch die alte Version war, dann müsste es wie folgt funktionieren (Name im Netz oder IP der Box ohne spitze Klammern und Name/PW musste wieder selbst eintragen):

    Code
    sudo mount -t cifs -o username=xxx,password=xxx,vers=1.0 //<IP_der_Fritz!Box>/Lexar-USBFlashDrive-01 /media/fritzbox-usb