TFT Touchscreen, Kuman 3.5 Zoll TFT LCD geht nicht

  • Hallo zusammen und grüße aus Bayern,

    ich habe leider nichts zu meinem Thema gefunden bzw. komme damit nicht weiter.

    Aktuell habe ich einen Pi V3 mit Touchscreen TFT Touchscreen, Kuman 3.5 Zoll TFT LCD zusammengebaut und installiert.

    Der Rasspberry V3 geht soweit, nur leider stimmt der Touchscreen nicht. Kalibriert habe ich auch schon.


    Der Touch verhält sich 90 Grad versetzt, also gehe ich nach unten bewegt sich der Pfeil nach rechts, usw.


    Was kann ich tun? Bin ein Neuling in der Materie


    Für die Unterstützung bedanke ich mich im Vorraus

  • Moin 4omen,


    bist du nach einer Anleitung vorgegangen? Wenn ja, dann, bitte, den Link postem!

    Hast du die Darstellungsweise des Displays geändert? Sprich gedreht?


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

  • Ich bin nach der Anleitung vom Hersteller.

    Habe raspianbian-stretch installiert und die config datei mit dem Code von github ausgefüllt:

    github.com/goodtft/LCD-show/blob/master/boot/config-35-480x320.txt

    Danach habe ich noch ein Kalibierungprogramm installiert nur es gab keine Besserung.

    Wie kann ich den Bildschirm drehen?

    Per USB Maus kann ich den Raspberry auf dem Touch Monitor einwandfrei bedienen!?

  • Hallo,


    wirklich weiterhelfen kann ich nicht, aber ... Wenn man sich die von Dir genannte config ansieht, dann ist klar zu erkennen das der Autor keine Lust oder keine Ahnung hatte. Allein, dass drei mal hdmi_force_hotplug=1 enabled ist spricht jedenfalls dafür. :shy:


    Nachtrag: Evtl. hilft Dir das hier weiter: https://www.raspberrypi.org/do…ation/config-txt/video.md insbesondere lcd_rotate=?!

    "Alles, was wir sind, ist Sand im Wind, Hoschi."

  • Moin 4omen,


    Danach habe ich noch ein Kalibierungprogramm installiert nur es gab keine Besserung.

    Warum hast du das gemacht?

    Weil, wenn ich mir die letzten 20 Zeilen vin https://github.com/goodtft/LCD-show/blob/master/LCD35-show ansehe,

    wird es von dem Script automatisch erledigt.


    Dann stellt sich mir die Frage, welches Kalibrierungsprogramm hast du installiert?ß


    Gruss Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

  • Viele der anderen configs haben ein rotate in ihrem DeviceTree Overlay

    dtoverlay=tft9341:rotate=270


    vielleicht klappt das ja bei dir auch so

    dtoverlay=tft35a:rotate=180

    Der Unterschied zwischen Genie und Wahnsinn definiert sich im Erfolg.

  • Servus 4omen ,

    ist das ein HDMI-Display?

    Das Problem hatte ich auch mal.

    Probier mal folgende Einträge in der /etc/X11/xorg.conf.d/99-calibration.conf:


    Code
    1. Section "InputClass"
    2. Identifier "calibration"
    3. MatchProduct "ADS7846 Touchscreen"
    4. Option "Calibration" "112 3976 3826 76"
    5. Option "SwapAxes" "1"
    6. Option "InvertX" "true"
    7. EndSection


    ciao,

    -ds-