NAS Anbindung geht nach jeden neustart verloren

  • Hallo zusammen,


    mein Plan war es mit meinem PIs auf mein NAS zuzugreifen und dann mit Hilfe von KODI Videos etc. zusehen. Mithilfe der ersten Google Treffern und einigen Anpassungen meinerseits, habe ich es auch mit den folgenden Eintrag in der Fstab geschafft das der PI mein NAS nach einen Neustart findet/mountet:

    Code
    //192.168.XXX.YYY/video /home/pi/NAS cifs username=NAME,password=PASSWORT,uid=pi,gid=pi,vers=2.0 0 0


    Natürlich habe ich XXX.YYY, NAME und PASSWORT durch die korrekte Daten ersetzt.

    Den NAS Ordner unter /home/pi habe ich natürlich auch erstellt.


    Anschließend hat auch alles wie gewünscht funktioniert. Allerdings nur bis zum nächstens Neustart...dann hat der PI das NAS wieder nicht gefunden. Ich hatte nichts geändert, weder am PI OS noch am NAS. Da es auch nach mehrfachen Neustarten nicht mehr funktioniert hat, habe ich erneut ein wenig recherchiert und es in die Folgende Zeile geändert:

    Code
    //192.168.XXX.YYY/video /home/pi/NAS cifs x-systemd.automount,username=NAME,password=PASSWORT,uid=pi,gid=pi,vers=2.0 0 0

    Auch hier hat der PI das NAS nach einem neustart gefunden und gemountet.


    Allerdings findet er es (nach einen Neustart) jetzt natürlich wieder nicht. Und ich glaube langsam nicht mehr, dass es an einen Fehlerhaften Eintrag in der Fstab liegt.

    Anderen Geräte wie mein Laptop und Desktop PC finden das NAS problemlos nach jedem neustart. Die IP des NAS ist statisch, daran kann es also auch nicht liegen.


    Hat jemand eine Idee woran es liegt bzw. was ich falsch mache?


    :danke_ATDE:

  • chuCKY187

    Changed the title of the thread from “NAS” to “NAS Anbindung geht nach jeden neustart verloren”.
  • Kleiner Nachtrag:

    Nachdem ich dann meine Aktuelle Zeile in der Fstab einmal auskommentiert, neugestartet, "einkommentiert" und wieder neugestartet habe, funktioniert es wieder...Aber woran liegt das und was ist die Lösung dafür?


    Danke & Grüße

  • Aus < man mount > ab Zeile 643:


    _netdev

    The filesystem resides on a device that requires network access

    (used to prevent the system from attempting to mount these

    filesystems until the network has been enabled on the system).


    ...cifs username=NAME,password=PASS.... mach mal

    cifs _netdev,username=NAME,password=PASS....



    Servus !

    RTFM = Read The Factory Manual, oder so

  • vielleicht wartet er nicht aufs Netzwerk, in der PI config gesetzt?


    mein eintrag ab passwd sieht so aus


    rw,file_mode=0777,dir_mode=0777,x-systemd.automount,x-systemd.requires=network-online.target 0 0


    über RW und mode 777 kann man trefflich streiten, mag ich aber nicht.

    lasst die PIs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)

  • Hi,


    ich hab gerade dein Änderungs Vorschlag umgesetzt und seitdem funktioniert gar nichts mehr... Nach dem Neustart bootet er zwar noch aber ganz am ende kommt:

    "You are in emergency mode. After logging in...

    try again to boot into default mode.

    Give root password for maintenance

    (or press Control-D to continue):"


    wenn ich mich dann mit dem Root einlogge und die fstab in den alten Status zurück ändern möchte kommt immer

    "Fehler beim Lesem der Sperrdatei /etc/fstab.wp Nicht genügend Daten gelesen"


    Was ist jetzt bitte passiert?

  • Hallo chuCKY187,


    was passiert, wenn Du Control-D drückst? Kannst Du Dich dann normal einloggen? Sorry für die blöde Frage, aber ich hatte den emergency mode (zum Glück) noch nicht.


    Falls Du es irgendwie hinbekommen solltest die fstab bearbeiten und speichern zu können, dann füge bitte die Option nofail ein, dadurch wird bei nicht verfügbar sein eines Laufwerks der Bootvorgang zumindest nicht unterbrochen.

  • Im emergency mode probiere nach dem root-login zuerst ein < umount -a > und dann mit vi/nano in /etc/fstab die CIFS Zeile auskommentieren (#). Danach ein < reboot -now >.


    Servus !


    Edit: nofaill geht narürlich auch, aber Du musst die Optionen mit einem Beistrich ohne Leerzeichen davor trennen.

    RTFM = Read The Factory Manual, oder so

    Edited once, last by RTFM ().

  • Hallo chuCKY187,


    was passiert, wenn Du Control-D drückst? Kannst Du Dich dann normal einloggen? Sorry für die blöde Frage, aber ich hatte den emergency mode (zum Glück) noch nicht.


    Falls Du es irgendwie hinbekommen solltest die fstab bearbeiten und speichern zu können, dann füge bitte die Option nofail ein, dadurch wird bei nicht verfügbar sein eines Laufwerks der Bootvorgang zumindest nicht unterbrochen.

    Hallo hyle,


    das hab ich dann auch getan. Unter /etc hab ich mir dann den Inhalt ausgeben lassen und siehe da, es gab eine fstab und eine fstab.save. Die fstab war die mehr der oben beschriebenen Fehlermeldung. Ich habe dann die fstab's umbenannt/getauscht.

    Merkwürdig war nur, dass er nach ein paar Sekunden immer den Bildschirm abgeschaltet hat. Warum kA, aber nach ein paar Versuchen war ich dann schnell genug die defekte in fstab.old um zu benennen und die neue in nur fstab.

    Jetzt funktioniert es wieder! Und sogar das NAS hat er gemountet. Was ein Schreck zu der späten Stunde....


    Allerdings funktioniert jetzt meine Mini-Tastatur nicht mehr

    https://www.amazon.de/Sonderangebotswoche-drahtlose-Leelbox-Port%EF%BC%88deutschem-Tastaturlayout/dp/B01M0T71NF/ref=sr_1_5?ie=UTF8&qid=1524086228&sr=8-5&keywords=mini+tastatur (Affiliate-Link)


    Gestern hat sie noch problemlos funktioniert und jetzt weder direkt per Kabel noch mit Funk.


    Und ich befürchte dass das Problem mit dem NAS auch noch nicht geklärt ist, da ich ja noch nichts geändert habe.

  • vielleicht wartet er nicht aufs Netzwerk, in der PI config gesetzt?


    mein eintrag ab passwd sieht so aus


    rw,file_mode=0777,dir_mode=0777,x-systemd.automount,x-systemd.requires=network-online.target 0 0

    Leider hast du die Antwort von jar ignoriert!

    Ich tippe auch schwer darauf, dass du "einfach" nur auf das Netzwerk warten musst.

  • Leider hast du die Antwort von jar ignoriert!

    Ich tippe auch schwer darauf, dass du "einfach" nur auf das Netzwerk warten musst.

    Hallo Hofei,


    nein, nicht ignoriert. Tut mir leid, wenn das so rüber gekommen ist. Ich wollte lediglich den ersten Tipp "ausprobieren" und bin dann durch den Fehler noch nicht dazu gekommen, mir die anderen Antworten diesbezüglich anzuschauen/umzusetzen :).

  • Hallo,


    entschuldigt die späte Rückmeldung.

    Momentan sieht es so aus dass ich gar nicht mehr dazu kommen die Zeile anzupassen.

    Wenn ich auf dem PI die Konsole öffne und "sudo nano /etc/fstab" eingebe, so wie vorher auch immer, kommt folgende Fehlermeldung:

    "Fehler beim Lesen der Sperrdatei /etc/.fstab.swp: Nicht genügend Daten gelesen".

    Wenn ich dann mit cd/fstab und anschließend nano fstab eingebe öffnet sich zwar die Datei und ich kann mich daran bewegen, aber wenn ich sie ändere und speicher möchte kommt der Fehler: "Fehler beim Schreiben von fstab: Keine Berechtigung".


    Also mit den normalen User kann ich sie ganz normal öffnen und der Inhalt ist korrekt, kann sie aber nicht speicher. Mit root kann ich die Datei nicht mal öffnen.


    Woran kann das liegen?


    Gruß & Danke

  • Hi fredo0815,


    danke für den Tipp. ls -a hat dann insgesamt 5 verschiedene fstab zum Vorschein gebracht. Also noch 3 versteckte zu meinen zwei bekannten.

    Die verstecken hab ich nach Kontrolle dann entfernt. Jetzt geht es wieder und ich habe wie von "jar" beschrieben, folgende Zeile eingefügt:

    Code
    //192.168.XXX.YYY/video /home/pi/NAS cifs rw,file_mode=0777,dir_mode=0777,x-systemd.automount,x-systemd.requires=network-online.target 0 0,username=NAME,password=PASSWORT,uid=pi,gid=pi,vers=2.0 0 0

    Hoffe dass war auch so von ihn gemeint.

    Werde berichten, ob das NAS jetzt zuverlässig hinzugefügt wird :).


    Hat jemand vielleicht noch eine Idee, warum meine Funktastatur/Maus nicht mehr erkennt werden? Hat vor kurzen noch tadellos funktioniert...

    Raspbian 9.1 mit allen verfügbaren updates.


    Danke & Grüße

  • Neues Thema erstellen, neues Glück! ;)

    Hallo hyle,


    ok, dann erstelle ich einen neue =) .


    Dieses Thema würde ich, wenn das ok ist, solange auflassen bis ich sichergehen konnte das alles funktioniert.

    Sobald es ein paar mal "funktioniert" hat, werde ich ihn als Erledigt markieren.

  • Code
    //192.168.XXX.YYY/video /home/pi/NAS cifs rw,file_mode=0777,dir_mode=0777,x-systemd.automount,x-systemd.requires=network-online.target 0 0,username=NAME,password=PASSWORT,uid=pi,gid=pi,vers=2.0 0 0

    Meine neuste Befehlszeile funktioniert leider gar nicht. Der ganze Dateimanager lädt nun nicht.

    Ich vermute, es liegt daran dass ich den Vorschlag von jar falsch umgesetzt habe....


    Wo genau muss die Ergänzung hin?

    rw,file_mode=0777,dir_mode=0777,x-systemd.automount,x-systemd.requires=network-online.target 0 0



    Danke & Grüße


    Edit: Interessanter weiße ist der alte NAS Ordner unter home/pi jetzt nur noch eine Datei wo ich nach dem starten gefragt werden, wie ich diese Datei öffnen möchte O_O

    Edited 2 times, last by chuCKY187 ().

  • Wo genau muss die Ergänzung hin?

    mein eintrag ab passwd sieht so aus

    was ist an "AB PASSWD" nicht zu verstehen?

    -> rw,file_mode=0777,dir_mode=0777,x-systemd.automount,x-systemd.requires=network-online.target 0 0


    also neuer Versuch:

    ,passwd=xxxxxxxx,rw,file_mode=0777,dir_mode=0777,x-systemd.automount 0 0


    nun frage aber bittte nicht was "xxxxxxxx" hinter ",passwd=" bedeutet.


    dein alter Eintrag war ja:

    //192.168.XXX.YYY/video /home/pi/NAS cifs username=NAME,password=PASSWORT,uid=pi,gid=pi,vers=2.0 0 0


    der Neue sollte dann hoffentlich so aussehen:


    //192.168.XXX.YYY/video /home/pi/NAS cifs username=NAME,password=PASSWORT,rw,file_mode=0777,dir_mode=0777,x-systemd.automount,x-systemd.requires=network-online.target 0 0


    ich würde ja trotzdem in /mnt ein DIR anlegen das NAS heisst oder besser einen Namen des Teil bekommt


    mein Inhalt von /mnt (mnt steht für mount)


    Fritz_Box_TOSHIBA-USB2-5--HDD-01

    osmcPI2_WDpassport3TB

    Qnap453a


    dann sieht man gleich wer da spielt

    lasst die PIs am Leben !
    Energiesparen:
    Das Gehirn kann in Standby gehen. Abschalten spart aber noch mehr Energie, was immer mehr nutzen. Dieter Nuhr
    (ich kann leider nicht schneller fahren, vor mir fährt ein GTi)