Fehlermeldung in syslog | CIFS VFS: ioctl error in smb2_get_dfs_refer rc=-2

  • Bei der routinemässigen Überprüfung des syslog habe ich nach den letzteren Installationen folgende Einträge die ich früher nicht hatte.

    Hier dürfte es doch bei den letzteren Jessie Stretch Lite Änderungen gegeben haben.

    Code
    No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3 (or SMB2.1) specify vers=1.0 on mount.
    CIFS VFS: ioctl error in smb2_get_dfs_refer rc=-2

    Wo muss ich diese Sicherheits Änderungen durchführen?

    Im Netzwerk befinden sich nur Windows 2008 R2 64Bit Server.

    Lg


    Chris


    Raspberry Pi 2/2+/3/3+

    Stretch|Buster Lite, FHEM
    RFXtrx433E, SIGNALduino, nanoCUL433MHz & 868MHz, HomeMatic

    FS20, IT, HomeMatic, WMR200, TEK603, YouLess, APC, SUSV, Resol VBUS, Fronius DataloggerWeb2

  • Wo muss ich diese Sicherheits Änderungen durchführen?

    Im Netzwerk befinden sich nur Windows 2008 R2 64Bit Server.

    In den Optionen des mount Befehles misst Du die Samba Versions Nummer jetzt mitgeben, da mount cifs defaultmässog nur mehr Samba 3.0 mountet. Es geht um die Verschlüsselungsstätke.


    Edit: Wenn sich ein Programm geändert hat, hat sich automatisch auch die man-page dazu geändert.



    Servus !

    RTFM = Read The Factory Manual, oder so

    Edited once, last by RTFM ().

  • Wie sieht dazu die Definition in der smb.conf aus für den Eintrag der Versionsummer?

    Lg


    Chris


    Raspberry Pi 2/2+/3/3+

    Stretch|Buster Lite, FHEM
    RFXtrx433E, SIGNALduino, nanoCUL433MHz & 868MHz, HomeMatic

    FS20, IT, HomeMatic, WMR200, TEK603, YouLess, APC, SUSV, Resol VBUS, Fronius DataloggerWeb2

  • Edit: Wenn sich ein Programm geändert hat, hat sich automatisch auch die man-page dazu geändert.

    Kannst du mal die Änderung raus suchen? Unter man mount und man mount.cifs konnte ich nichts finden. Oder, welches Programm hat sich geändert wo ich nachsehen kann? Es ist ja eine Kerneländerung. man <kernel>?

  • Mount options for cifs

    See the options section of the mount.cifs(8) man page (cifs-utils package must be installed).


    Da musst Du selbst in < man mount.cifs > nachschauen, ich habe schon lange kein Windows mehr.



    Servus !.

    RTFM = Read The Factory Manual, oder so

  • Ich habe dazu einen Hinweis gefunden und eine Eintrag unter [Mount] ergänzt der die error Meldung beheben sollte.


    Windows verwendet die folgenden Versionen:

    SMB 1.0 ..: Windows 2000

    SMB 2.0 ..: Windows Server 2008 und Windows Vista SP1

    SMB 2.1 ..: Windows Server 2008 R2 und Windows 7

    SMB 3.0 ..: Windows Server 2012 und Windows 8

    SMB 3.0.2 : Windows Server 2012 R2 und Windows 8.1 (NICHT nutzbar!)

    SMB 3.1.1 : Windows Server 2016 und Windows 10 (NICHT nutzbar!)

    Zu beachten sind die fett gedruckten Versionen (ab cifs-utils Version 4.5) die zulässig sind. Unter Mount ist zusätzlich der Parameter vers=2.1 einzutragen.


    Um die Versionsnummer abfragen zu können ist ain der Console smbd –version einzugeben .

    In meinem Fall bekomme ich die

    Version 4.5.12-Debian

    angezeigt.

    Code
    [Mount]
    What=//NAS/FHEM
    Where=/media/hdd
    Options=username=<user>,password=<name>,rw,domain=<domain>,iocharset=utf8,dir_mode=0777,file_mode=0666
    Type=cifs
    vers=2.1

    Leider behebt die Ergänzung vers=2.1 ncht die error Meldung.

    Lg


    Chris


    Raspberry Pi 2/2+/3/3+

    Stretch|Buster Lite, FHEM
    RFXtrx433E, SIGNALduino, nanoCUL433MHz & 868MHz, HomeMatic

    FS20, IT, HomeMatic, WMR200, TEK603, YouLess, APC, SUSV, Resol VBUS, Fronius DataloggerWeb2

    Edited once, last by Burny ().

  • Zu beachten sind die fett gedruckten Versionen (ab cifs-utils Version 4.5) die zulässig sind. Unter Mount ist zusätzlich der Parameter vers=2.1 einzutragen.

    Options=username=<user>,password=<name>,

    rw,domain=domain>,iocharset=utf8,dir_mode=0777,file_mode=0666,vers=2.1



    Servus !

    RTFM = Read The Factory Manual, oder so

  • Es ist ja eine Kerneländerung.

    Ich hab es mal zufällig in den Releasenotes von raspbian gelesen.Was die Kommunikation "schwerwiegender" Änderungen angeht nehmen sich Linux und Windows nichts. Es gibt ein Update - und nachher muss man googeln warum etwas nicht mehr funktioniert.

    Der Unterschied zwischen Genie und Wahnsinn definiert sich im Erfolg.

  • Quote

    Options=username=<user>,password=<name>,

    rw,domain=domain>,iocharset=utf8,dir_mode=0777,file_mode=0666,vers=2.1

    Bei mir wurden Scripts erstellt um sicher zu stellen das beim mount das Netzwerk schon zur Verfügung steht.

    Dadurch wurde keine zusätzlichen Definitionen in der fstab vorgenommen.

    Ich hatte immer das Problem das die Funktion auf Netzwerk warten unter raspi-config nicht einwandfrei funktionierte, was anschließend den mount verhinderte.

    Dafür wurden neue Datein mit Script erstellt.

    sudo nano /usr/local/bin/network_wait_online

    sudo nano /etc/systemd/system/network_wait_online.service

    sudo nano /etc/systemd/system/media-hdd.mount

    Bei dieser Ausführung hatte ich Unterstützung aus einem Forum.

    Vielleicht hilft diese Ausführung auch anderen Usern weiter.


    Leider hat die Änderung mit dem Parameter vers=2.1 noch nicht vollständig den error im syslog behoben.

    Code
    FS-Cache: Netfs 'cifs' registered for caching
    Key type cifs.spnego registered
    Key type cifs.idmap registered
    CIFS VFS: ioctl error in smb2_get_dfs_refer rc=-2
    crng init done

    Hier bedarf es leider noch einer Anpassung um den Eintrag

    CIFS VFS: ioctl error in smb2_get_dfs_refer rc=-2

    zu entfernen.

    Unter [Mount] ist noch eine Anpassung notwendig. Der EIntrag

    Code
    [Mount]
    What=//<Fileserver IP>/<Datei Verzeichnis>
    Where=/media/hdd
    Options=username=<user>,password=<name>,rw,domain=<domain>,iocharset=utf8,dir_mode=0777,file_mode=0666,vers=2.1
    Type=cifs

    ist auf

    Code
    [Mount]
    What=//<Fileserver IP>/<Datei Verzeichnis>
    Where=/media/hdd
    Options=username=<user>,password=<name>,rw,domain=<domain>,iocharset=utf8,dir_mode=0777,file_mode=0666,vers=2.1,Type=cifs

    zu ändern.

    Es ist zwar kein error Eintrag in der Syslog vorhanden dafür funktioniert aber der mount nicht mehr.

    Ist hier eine andere Schreibweise notwendig damit der mount wieder funktioniert?

    Lg


    Chris


    Raspberry Pi 2/2+/3/3+

    Stretch|Buster Lite, FHEM
    RFXtrx433E, SIGNALduino, nanoCUL433MHz & 868MHz, HomeMatic

    FS20, IT, HomeMatic, WMR200, TEK603, YouLess, APC, SUSV, Resol VBUS, Fronius DataloggerWeb2

    Edited 4 times, last by Burny ().

  • Ich kann es drehen wie ich will.

    Ich bekomme den error Eintrag

    CIFS VFS: ioctl error in smb2_get_dfs_refer rc=-2

    in der syslog nicht weg auch wenn ich die Reihungen ändere.

    Code
    [Mount]
    What=//<Fileserver IP>/<Datei Verzeichnis>
    Where=/media/hdd
    Type=cifs
    Options=vers=2.1,username=<user>,password=<name>,rw,domain=<domain>,iocharset=utf8,dir_mode=0777,file_mode=0666


    Lg


    Chris


    Raspberry Pi 2/2+/3/3+

    Stretch|Buster Lite, FHEM
    RFXtrx433E, SIGNALduino, nanoCUL433MHz & 868MHz, HomeMatic

    FS20, IT, HomeMatic, WMR200, TEK603, YouLess, APC, SUSV, Resol VBUS, Fronius DataloggerWeb2

  • Hast Du die Service Unit auch neu gestartet und den alten Eintrag aus /etc/fstab entfernt ?


    Funktioniert ein manueller mount -t cifs -o ver..... fehlerfrei ?



    Servus !

    RTFM = Read The Factory Manual, oder so

  • Ich habe nach der Änderung immer einen kompletten Neustart des Systems gemacht.

    In der fstab steht nur das darin was die Installation automatsich einträgt.

    Code
    proc /proc proc defaults 0 0
    PARTUUID=1038f195-01 /boot vfat defaults 0 2
    PARTUUID=1038f195-02 / ext4 defaults,noatime 0 1

    Ein manueler mount liefert den gleichen Fehler in der syslog.

    sudo mount -t cifs //<Fileserver IP>/<Datei Verzeichnis> /media/hdd -o domain=<domain>,vers=2.1,user=<user>,password=<name>

    Code
    CIFS VFS: ioctl error in smb2_get_dfs_refer rc=-2

    Der Zugriff auf das Verzeichnis funktioniert.

    Lg


    Chris


    Raspberry Pi 2/2+/3/3+

    Stretch|Buster Lite, FHEM
    RFXtrx433E, SIGNALduino, nanoCUL433MHz & 868MHz, HomeMatic

    FS20, IT, HomeMatic, WMR200, TEK603, YouLess, APC, SUSV, Resol VBUS, Fronius DataloggerWeb2

  • Im Netzwerk befinden sich nur Windows 2008 R2 64Bit Server.

    Also mehrere.

    Der Fehlerhinweis wird jedenfalls von der Windows Domain verursacht. Wenn Dein Fileserver jetzt wieder funktioniert würde der Verursacher eher in der Windows Domain, oder seinem Controller zu suchen sein.

    Du kannst den manuellen mount auch nur mit vers,user,passwd beginnen und immer mehr Oprionen dazunehmen und schauen, ab wann die Fehlermeldung auftaucht.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • Nur was soll ich noch weniger eingeben als ich bei der manuellen Eingabe gemacht habe.


    Na das ist ja fein.

    Immer diese Änderungen wo man sich alles zusammensuchen muss.

    Lg


    Chris


    Raspberry Pi 2/2+/3/3+

    Stretch|Buster Lite, FHEM
    RFXtrx433E, SIGNALduino, nanoCUL433MHz & 868MHz, HomeMatic

    FS20, IT, HomeMatic, WMR200, TEK603, YouLess, APC, SUSV, Resol VBUS, Fronius DataloggerWeb2

    Edited once, last by Burny ().

  • Nur was soll ich noch weniger eingeben als ich bei der manuellen Eingabe gemacht habe.

    z.B.


    mount -t cifs -o vers=2.1,username=<user>,password=<name> //Server/Dir /mount/point


    mount -t cifs -o vers=2.1,username=<user>,password=<name>,rw,iocharset=utf8 //Server/Dir /mount/point


    mount -t cifs -o vers=2.1,username=<user>,password=<name>,rw,iocharset=utf8dir_mode=0777,file_mode=0666 //Server/Dir /mount/point


    mount -t cifs -o vers=2.1,username=<user>,password=<name>,rw,iocharset=utf8dir_mode=0777,file_mode=0666,domain=<domain> //Server/Dir /mount/point


    Servus !

    RTFM = Read The Factory Manual, oder so

  • Na das ist ja fein.

    Immer diese Änderungen wo man sich alles zusammensuchen muss.

    Die Änderungen hast Du Redmond (Windows) zu verdanken. Samba.org kann dafür nichts, die haben nicht einmal einen Source Code von dem Windows Zeugs.



    Servus !

    RTFM = Read The Factory Manual, oder so

  • Bei der manuellen Eingabe von

    mount -t cifs -o vers=2.1,username=<user>,password=<name> //Server/Dir /mount/point

    habe ich ja schon den Eintrag CIFS VFS: ioctl error in smb2_get_dfs_refer rc=-2 in der syslog.

    Weniger kann ich nicht mehr eingeben.


    Ich habe auch Windows damit gemeint und nicht Linux.

    Unter Linux findet man zumindest Hilfen wo unter Windows eine Ewigkeit nichts zu finden ist.

    Lg


    Chris


    Raspberry Pi 2/2+/3/3+

    Stretch|Buster Lite, FHEM
    RFXtrx433E, SIGNALduino, nanoCUL433MHz & 868MHz, HomeMatic

    FS20, IT, HomeMatic, WMR200, TEK603, YouLess, APC, SUSV, Resol VBUS, Fronius DataloggerWeb2

  • Du hast recht.

    Mit vers=1.0 gibt es keinen error Eintrag in der Syslog.

    Dann unterstützen mit der derzeitigen Konfiguration der Windows 2008 R2 64Bit Server derzeit keine vers=2.1.

    Lg


    Chris


    Raspberry Pi 2/2+/3/3+

    Stretch|Buster Lite, FHEM
    RFXtrx433E, SIGNALduino, nanoCUL433MHz & 868MHz, HomeMatic

    FS20, IT, HomeMatic, WMR200, TEK603, YouLess, APC, SUSV, Resol VBUS, Fronius DataloggerWeb2