Anmelden an Desktop nicht möglich

  • Hallo zusammen


    ich mich nach dem Booten plötzlich nicht mehr am Desktop anmelden

    weder mit meinem Benutzer noch mit Pi

    Über ssh an Sitzung geht die anmeldung


    Grüße aus Bayern Otto

  • Die Frage war welches OS


    IOS Raspian

    Hardware Raspi 3


    Tja dann kann mir wohl keiner helfen

    Das hat man davon wenn man ein Linux System verwendet,

    Allein zum Fragen muss man schon Profi sein :-(

  • Das hat man davon wenn man ein Linux System verwendet,

    Allein zum Fragen muss man schon Profi sein :-(

    Nein, das ist falsch. Ich behaupte allerdings, dass man als Linux-User lesen können muss. Und du hast den Link aus #2und #3 entweder nicht richtig gelesen, und auf jeden Fall nicht genügend Infos nachgereicht: Fehlermeldungen, verwendete Eingabegeräte (=Tastatur), evtl Sonderzeichen im PW, welche Sprache eingestellt?


    Beispiel:

    wenn du ein "y" im PW hast, dein Pi noch auf Englisch gestellt ist und du mit einer Deutschen Tastatur tippst ist das Y auf der Tastatur ein Z. Bei SSH ist das nicht der Fall, da das Hostsystem das korrekt handhabt (vermutl. deutsches Windows mit deutscher Tastatur?).

    :wink:

  • Lass dich nicht ärgern, einige können ihr kluges Getue einfach nicht ablegen. Aber egal. Musstest du dich schon immer am Desktop anmelden? Das ist eigentlich ungewöhnlich. Hast Du ein Passwort, wo evtl. ein "y" drin ist, dann versuch es mal mit "z".


    Edit: Ach, nun wird ja doch vernünftig geholfen!

  • Nee, man muss kein Profi sein. Wenn man erst mal ein wenig Grundwissen geschafft hat, dann läuft es besser (bin selbst noch Anfänger). Die Lernkurve ist zu Beginn ein wenig steil. Je mehr Informationen du liefern kannst, desto bessere kann dir jemand helfen. Im Moment müssten die meisten wohl raten mit den gegebenen Informationen. Daher auch die Nachfragen. Nicht aufgeben, dann klappt das schon.

  • Lass dich nicht ärgern, einige können ihr kluges Getue einfach nicht ablegen.

    Die Frage nach einer genauen Fehlermeldung als "kluges Getue" abzutun, finde ich schon ziemlich grenzwertig. Solange die Fehlerbeschreibung auf dem Niveau "geht nicht" bleibt, kann man m.E. nur raten, wo das Problem liegen könnte – und das völlig unabhängig vom verwendeten Betriebssystem. Raten führt nach meiner Erfahrung nur in den seltensten Fällen zum Ziel, daher halte ich ein gezieltes Nachfragen nicht nur für vernünftige, sondern sogar für die einzig vernünftige Art der Hilfe.

  • kein z kein y

    Verwende den Rasp eben zum Kennenlernen als Desktop läuft immer in den Desktop

    Anfangs ohne Anmeldung nach Umstellung mit raspi-config auf "mit Anmeldung" geht nix mehr.

    Auch nach Umstellung "ohne Anmeldung"

  • genau so steht es da, Nach booten kommt Eingabemaske

    benutzer pi

    kennwort

    gebe ich dann ein

    Bild wird kurz schwarz

    dann kommt wieder eingabemaske

    Bei Eingabe eines falschen Kennworts kommt eine entsprechende Meldung

    und dann wieder die Eingabemaske

  • Erledigt

    Kommt aber wieder GUI mit Passwort und geht nicht

    Wenn wieder die GUI kommt, ist das Umstellen auf Booten ins CLI offenbar nicht erledigt. Poste mal bitte die Ausgabe von systemctl get-default. Wenn da "graphical.target" rauskommt, ist Booten in die GUI eingestellt. Nach Umstellen auf CLI sollte "multi-user.target" rauskommen.

  • Guten Morgen zusammen


    system get-default bringt graphical.target


    monut

    /dev/mmcblk0p2 on / type ext4 (rw,noatime,data=ordered)

    devtmpfs on /dev type devtmpfs (rw,relatime,size=469532k,nr_inodes=117383,mode=755)

    sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)

    proc on /proc type proc (rw,relatime)

    tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)

    devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)

    tmpfs on /run type tmpfs (rw,nosuid,nodev,mode=755)

    tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)

    tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)

    cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)

    cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)

    cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)

    cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)

    cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)

    cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)

    cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)

    systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=22,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)

    mqueue on /dev/mqueue type mqueue (rw,relatime)

    debugfs on /sys/kernel/debug type debugfs (rw,relatime)

    configfs on /sys/kernel/config type configfs (rw,relatime)

    fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)

    /dev/mmcblk0p1 on /boot type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro)

    tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=94776k,mode=700,uid=1000,gid=1000)

    tmpfs on /run/user/109 type tmpfs (rw,nosuid,nodev,relatime,size=94776k,mode=700,uid=109,gid=114)


    Die Karte ist ca 1 Jahr im Einsatz war aber die Raspi war aber die meiste Zeit aus