Kodi unter Raspbian Stretch - Screensaver Aktivierung über Homekit?

  • Hallo liebes Forum,


    hoffentlich positioniere ich meine Frage an der richtigen Stelle.


    Ich habe einen Raspberry 3, auf dem Raspbian Stretch werkelt. Im Hintergrund sind über Homebridge sämtliche Geräte in meiner Wohnung in Homekit integriert sowie ein USB-Datenträger über einen Samba Server als Netzwerklaufwerk bereitgestellt. Der Raspberry ist mitsamt offiziellem 7“ Touch Display und Kameramodul in einem Gehäuse und tut seinen Dienst als Infodisplay/Mediacenter mit laufendem Kodi 17 in meiner Küche.


    Nun kommen wir zu meinem Problem. Da ich die Lebenszeit des Display nicht unnötig verkürzen möchte, deaktiviere ich die Hintergrundbeleuchtung über einen Screensaver. Entweder nutze ich den „TurnOff“ Screensaver in Kodi oder ich schalte ihn über „xscreensaver“ im Hintergrund. Bei letzterem lässt sich das Display jedoch nicht mehr über Touch aktivieren, sondern der Screensaver muss über SSH („xscreensaver-command -deactivate“) deaktiviert werden. Beim Kodi Screensaver reicht ein „Touch“, aber in beiden Fällen ist das Ergebnis das Selbe: Komme ich morgens in die Küche, ist das Display dunkel..


    Nun endlich meine Frage: Seht ihr eine Möglichkeit, die Hintergrundbeleuchtung des Panel über homebridge in Homekit zu integrieren? -> Einfacher Switch (on/off)


    Bewegungssensoren sind vorhanden und integriert, ich könnte das Panel somit über eine Automation anschalten lassen.

    Ich dachte hier vielleicht an das homebridge-cmdswitch2 plugin, versuche ich dort allerdings den oben stehenden Befehl (siehe Klammer oben), geschieht nichts.


    Ich wäre daher dankbar für eure Hilfe. Auch alternative Ideen zur Lösung sind natürlich willkommen.


    Viele Grüße

  • Sebbo187

    Changed the title of the thread from “Kodi unter Raspbian Stretch - Aktivierung über Homekit?” to “Kodi unter Raspbian Stretch - Screensaver Aktivierung über Homekit?”.
    • Official Post

    Hallo Sebbo187,


    willkommen im Forum!

    hoffentlich positioniere ich meine Frage an der richtigen Stelle.

    Ja und Danke das Du darauf geachtet hast!


    Bewegungssensoren sind vorhanden und integriert, ich könnte das Panel somit über eine Automation anschalten lassen.

    Evtl. könnte da Linus (wo ist das "g"? :conf:) bzw. sein rpi-backlight-Projekt eine mögliche Hilfe sein. :denker: 

  • Zuerst einmal Danke für die schnelle Antwort zu später Stunde.

    Ich muss dazu sagen, dass die Bewegungssensoren nicht mit dem Raspberry verbunden, sondern direkt in Homekit eingebunden sind (Logitech Circle 2 & Eve Motion). Daher wäre eine Einbindung in Homekit die optimale Lösung für mich. Auf das Projekt von Linus bin ich auch bereits gestoßen, finde dort aber leider nichts, was mir auf dem Weg in Homekit hilfreich sein könnte. Interessant ist es trotzdem allemal, jedoch habe ich über SSH oder Kodi direkt ja bereits die Möglichkeit, das Backlight auszuschalten (wenn es auch sicherlich eleganter geht), das automatische Einschalten bereitet mir Kopfzerbrechen.. ;)

  • Es gibt das oben erwähnte Plugin (homebridge-cmdswitch2), welches offenbar ermöglicht, Kommandozeilenbefehle über Homekit auszusenden. Für dessen Nutzung bin ich aber anscheinend zu unbedarft. Den ps4-waker zur Einbindung meiner Playstation bekomme ich darüber noch einwandfrei gestartet (on_cmd: "ps4-waker", off_cmd: "ps4-waker standby"), den Screensaver aber leider nicht. Hier sitzt das Problem meiner Vermutung nach vor der Tastatur, es macht aber einfach nicht „Klick“.. ;)

  • Da beginnt das Problem mit dem Plugin, einen einfachen Befehl, der in der Konsole normal ausgeführt wird (optional auch mit sudo, hab versucht, testweise einen Button für „apt-get update“ anzulegen), 1zu1 zu übertragen, bewirkt leider nichts..

    Wäre meine Hilfesuche eventuell im Homekit/Hombridge Bereich dieses Forums passender (war unsicher bei der Erstellung)?

  • Im Log von homebridge ist nach Betätigen des erstellten Schalters (hinterlegter Text: "

    xscreensaver-command -activate bzw. -deactivate") folgendes zu lesen:


    "xscreensaver-command: can't open display :0.0

    No protocol specified

    xscreensaver-command: warning: $DISPLAY is not set: defaulting to ":0.0"."


    Das selbe Kommando direkt in die Konsole getippt, bewirkt jedoch das Erwünschte, das Aktivieren und Deaktivieren des Screensaver...:/

    • Official Post

    Wäre meine Hilfesuche eventuell im Homekit/Hombridge Bereich dieses Forums passender (war unsicher bei der Erstellung)?


    Ok, habe es verschoben.


    //Edit: Linus Ups! ;) Aber IMHO ist das ein Grenzfall zwischen Multimedia und Heimautomatisierung von daher...

  • Genau das Plugin meine ich, der andere Forumeintrag geht genau in die Richtung, die ich im Kopf hatte. Nur ein passender (und funktionierender) Befehl will sich nicht finden lassen.

    Versuche ich es mit "echo 1 > /sys/class/backlight/rpi_backlight/bl_power",erhalte ich nur die Meldung „Keine Berechtigung"...

  • Auch mit sudo erscheint die Meldung „keine Berechtigung“.. An anderer Stelle habe ich gelesen, dass die Installation von xscreensaver die bisherigen bl_power Parameter verändert. Möglicherweise liegt die Lösung dann doch im Steuern von xscreensaver. Wie gesagt:"xscreensaver-command -deactivate" direkt in der Konsole funktioniert, über das homebridge plugin leider nicht. Kann dies vielleicht mit den Berechtigungen von homebridge zu tun haben oder muss der Befehl angepasst werden (Display definiert)?

  • Auch mit sudo erscheint die Meldung „keine Berechtigung“

    "echo 1 > /sys/class/backlight/rpi_backlight/bl_power"

    das liegt am "redirect".

    Code
    pi@raspberrypi4:~ $ sudo echo 1 > /sys/class/backlight/rpi_backlight/bl_power
    -bash: /sys/class/backlight/rpi_backlight/bl_power: Permission denied

    so gilt das sudo nur für das "echo",

    aber nicht für das Schreiben in die "Datei" /sys/class/backlight/rpi_backlight/bl_power

    Code
    osmc@osmc:~$ ls -l /sys/class/backlight/rpi_backlight/bl_power
    -rw-r--r-- 1 root root 4096 May  9 15:23 /sys/class/backlight/rpi_backlight/bl_power

    nur owner root darf schreiben.

    also richtig: sudo sh -c "echo 1 > /sys/class/backlight/rpi_backlight/bl_power"

    Schönen Gruß, kle


    PS: mein origial 7" Touchscreen läuft unter OSMC

    Edited 3 times, last by kle: Syntaxhervorhebung -> Code ls command eingefügt ().

  • Ich werd verrückt, das war die Lösung.:danke_ATDE:


    Jetzt funktioniert es tatsächlich so, wie ich es mir gewünscht hatte, ich danke allen Beteiligten für den tollen und schnellen Support. Macht euch einen schönen Feiertag.