Raspberry Pi 3 Debian Stretch Lite Wlan Statische IP Subnetmask

  • Hallo Leute!


    Ich besitze einen Pi3 mit aufgespielten Debian Stretch Lite. Das WLan habe ich mit einer statischen IP konfiguriert, da ich ansonsten keine Verbindung zusammengebracht habe. Jetzt kann ich übers Wlan zugreifen, jedoch wenn ich ein paar stunden nichts mache, komm ich nicht mehr drauf.


    Powermanagement des Wlan habe ich bereits deaktiviert.


    was mir nun aufgefallen ist, dass das Wlan, die falsche Subnetmask hat.

    Kann es daran liegen? Wenn ja, wo trage ich die richtige ein, bzw. warum bekommt er vom router nicht die richtige?


    hab folgende Einträge in der dhcpcd.conf gemacht:


    interface wlan0

    static ip_addr=1.0.0.12/24

    static router=10.0.0.138

    static domain_name_servers=10.0.0.138 8.8.8.8

    inform 10.0.0.12


    Beim Aufruf von ifconfig erhalte ich dann folgende Info:

    beim Aufruf von service



    Beim Aufruf von service dhcpcd status kommt folgendes:




    Hier sieht es aus, als würde er 10.0.0.12/8 verbinden und damit die Subnetmask 255.0.0.0. meine richtige Subnetmask ist aber 255.255.255.0!


    Vielleicht liegt es aber auch gar nicht daran, das die subnetmask falsch ist. Aber ich denke doch, das es die gleiche wie des restlichen Netzwerkes sein sollte, oder?


    Vielleicht kann mir hier jemand weiterhelfen, werde schon wahnsinnig!


    Danke!

  • Code
    interface wlan0
    static ip_addr=1.0.0.12/24
    static router=10.0.0.138
    static domain_name_servers=10.0.0.138 8.8.8.8
    inform 10.0.0.12

    BTW: An der netmask liegt es evtl. nicht. Aber "inform" braucht man nur für ein "fallback static profile" und dann auch mit der netmask, aber mit einer anderen IP-Adresse. Z. B.:

    Code
    inform 10.0.0.11/24

    D. h, lasse "inform 10.0.0.12" mal weg.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden