MotionEye installieren

  • Hallo zusammen,


    weil ich meine Untermieter im Nistkasten nicht belästigen möchte habe ich zum Experimentieren einen zweiten Raspi mit identischem Zubehör zugelegt.

    Habe das 2017-11-29-raspbian-stretch.img wie beim ersten Raspi installiert und


    sudo apt-get update

    sudo apt-get upgrade


    durchgeführt. Weil ich ein paar Fehlermeldungen bemerkte machte ich noch ein

    sudo apt-get dist-upgrade


    Wenn ich mich nicht irre habe ich dadurch ein Upgrade auf Version 2018-04-18-raspbian-stretch gemacht. Wie dem auch sei.


    Mein Versuch motionEye nach bewährter Weise zu installieren scheitert nun bereits beim ersten Kommando.


    sudo apt-get install ffmpeg v4l-utils


    mit nachfolgender Meldung.


    Und nun ?


    Viele Grüße

    Ich Bins

  • Hilf mir mal bitte auf die Sprünge. Was war der Grund, warum Du selbst installieren und nicht motionEyeOS nehmen willst?


    Weil ich ein paar Fehlermeldungen bemerkte machte ich noch ein

    sudo apt-get dist-upgrade

    Aha, das ist logisch. Nicht. Welche Fehlermeldungen waren das denn? Könnte ja eventuell wichtig gewesen sein und im schlechten Fall weiteres Ungemach nach sich ziehen?!


    Durch up(d)/(g)rade hast Du im Idealfall ein aktuelles System erhalten. Sonst hast Du nichts weiter eingegeben?


    Ergänzung: Wie ist die Ausgabe von

    Code
    1. dpkg --print-foreign-architectures

    (da darf keine kommen) und


    Code
    1. uname -mi

    (die sollte armv7l unknown sein)


    auf Deinem RPi?

    "And now for something completely different."


    Hofeis guide to: Wie frage ich nach Hilfe? *** Mein nagelneuer Raspberry Pi 3B+ zeigt nur ein buntes Bild. (Ab)Hilfe.

    3 Mal editiert, zuletzt von STF ()

  • Hallo STF,


    vielen Dank für Deine Antwort.

    Hilf mir mal bitte auf die Sprünge. Was war der Grund, warum Du selbst installieren und nicht motionEyeOS nehmen willst?

    Das lag daran, dass ich nach vielen erfolglosen und frustrierenden Versuchen es nicht geschafft habe, mein Wlan (USB-Stick) im motionEyeOS zum Laufen zu bringen. Siehe Motion + MotionEye installieren.


    Leider weiß ich es nicht mehr welche Meldungen beim sudo apt-get upgrade hochgekommen sind.


    dpkg --print-foreign-architectures

    Liefert nichts.

    uname -mi ist armv7l unknown


    Was ich zuvor so alles gemacht habe war Neuen Benutzer erstellen und Standardbenutzer „pi“ entfernen und

    Inbetriebnahme Kamera-Modul (ohne Motion – Installation & Konfiguration).


    Vll. habe ich mir mit der Inbetriebnahme Kamera-Modul die Installation von ffmpeg vermurkst. Denn damit werden die Module Module v4l2_common und bcm2835-v4l2 geladen. Weil nach dem Neustart /dev/video0 nicht zurückgegeben wurde schaute ich in meinem Nistkasten-Raspi in der /etc/modules nach und darin war nur bcm2835-v4l2. Also tat ich das gleiche beim neuen Raspi und nach dem Neustart wurde /dev/video0 zurückgegeben.


    Wenn ich mich nicht irre habe ich auch im März, vor der Installation von motionEye, auch die Inbetriebnahme Kamera-Modul durchgeführt.


    Wenns an den Modulen v4l2_common und bcm2835-v4l2 und liegen könnte, wie werde ich die wieder los ?


    Viele Grüße

    Ich Bins

  • Was ich zuvor so alles gemacht habe war Neuen Benutzer erstellen und Standardbenutzer „pi“ entfernen und

    Inbetriebnahme Kamera-Modul (ohne Motion – Installation & Konfiguration).

    Warum? Das macht es unnötig komliziert, wenn Du Dich nicht wirklich gut auskennst.


    Ich habe mal probiert, einen externen WLAN Adapter am Pi3 mit motionEyeOS einzurichten. Geht hervorragend. Ich empfehle zur Einrichtung den Zugang über ein LAN Kabel und den Anschluss eines Monitores, damit die Meldungen verfolgt werden können. Weiter musst Du folgendes machen (einen von Raspbian unterstützten WLAN Adapter vorausgesetzt):


    1) erster Start inkl. automatischer Einrichtung, einfach durchlaufen lassen

    2) Zugriff mit Browser über LAN (die IP Adresse steht am Ende der Meldungen auf dem angeschlossenen Monitor) auf motionEye Oberfläche, erweitere Ansicht aktivieren, admin Passwort anlegen

    3) Zugangsdaten WLAN eintragen: Network -> wireless Network anschalten // Zugangsdaten eintragen // evt. feste IP vergeben

    4) über ssh anmelden (Nutzer:admin/PW:angelegtes PW)

    5) System beschreibbar machen: mount -o remount,rw /

    6) internes WLAN ausschalten nano /data/etc/modprobe.conf Eintragen: blacklist brcmfmac // speichern: STRG-O,dann STRG-X

    7) LAN Kabel abziehen, WLAN Adapter muss natürlich angeschlossen sein, neu starten


    Grüße, STF

    "And now for something completely different."


    Hofeis guide to: Wie frage ich nach Hilfe? *** Mein nagelneuer Raspberry Pi 3B+ zeigt nur ein buntes Bild. (Ab)Hilfe.

    5 Mal editiert, zuletzt von STF () aus folgendem Grund: Link korrigiert, Fippteler

  • Hallo STF,


    so, am WE hatte ich nun endlich genügend Zeit mich mit Deiner Installationsbeschreibung zu beschäftigen.

    Nun konnte ich erfolgreich motionEyeOs installieren und den USB-WLan-Adapter aktivieren.

    Vielen Dank !


    Noch bevor ich von Dir die Installationsbeschreibung erhielt konnte ich motionEye installieren.

    Es lag, wie ich bereits vermutet hatte daran, dass ich vor der eigentlichen Installation

    Inbetriebnahme Kamera-Modul durchgeführt hatte.


    Kann man das motionEyeOS nachträglich noch erweitern ?


    Viele Grüße

    Ich Bins

  • was schwebt Dir denn vor?

    Beispielsweise:

    Audio über VNC-Viewer oder Xtightvncviewer oder PulseAudio oder Isecast streamen

    Inzw. ist mir bekannt, dass der VNV-Viewer kein Audio übertragen kann.


    motionEye: Bild und Video Dateien werden mit Besitzer root und Gruppe root gespeichert

    und hier speziell die Idee von hyle

    Das NAS könnte man mounten nach /var/lib/motioneye/Camera1/, oder STF was sagt der Kenner dazu? ;)


    Viele Grüße

    Ich Bins

  • Audio über VNC-Viewer oder Xtightvncviewer oder PulseAudio oder Isecast streamen

    Inzw. ist mir bekannt, dass der VNV-Viewer kein Audio übertragen kann.

    Audio wird nix mit motionEyeOS und motion generell. Calin beantwortet die Fragen dahingehend immer so , so, so....


    Allerdings gab es einige Projekte für Babycams, vielleicht kannst Du ja sowas nutzen. (ungelesen/ungetestet) 

    VNC geht schonmal gar nicht , auf dem Pi läuft ja mit meOS noch nicht mal ein X...


    Deinen anderen thread habe ich nicht verstanden.

    root und Gruppe root gespeichert

    meOS speichert doch lokal dahin: bzw. woanders, aber dazu musst Du den Pfad ändern.

    Oder Du lässt gleich auf ein Network share (samba) speichern. Dazu musst Du nur die Zugangsdaten haben.


    Per ftp hängt es doch auch sicher davon ab, mit welchen Daten ich mich anmelde.



    Da weiss ich jetzt nicht, wo das Problem ist. Vielleicht kannst Du es erklären?


    Viele Grüße, STF

    "And now for something completely different."


    Hofeis guide to: Wie frage ich nach Hilfe? *** Mein nagelneuer Raspberry Pi 3B+ zeigt nur ein buntes Bild. (Ab)Hilfe.

  • Vor dem Erklären wollte ich nochmal den FTP-Upload überprüfen und bin am Rätseln, weshalb motionEye keine Daten zum Fritz!NAS sendet.

    Das Testen innerhalb von motionEye liefert

    Accessing the upload service succeeded!

    Teste ich ein zweites Mal hängt sich motionEye auf (die Punkte kreisen ewig). :conf:

  • FTP-Upload

    Ich habs gerad nochmal bei meiner Fritz!Box probiert, sowohl Test als auch Upload per ftp funktionieren sauber. Allerdings reicht es ja, einen Service (samba ODER ftp) zum externen Speichern zu nehmen. ftp/sftp/dropbox/Google Drive sind immer zusätzlich zum (lokalen) storage device (Karte / angeschlossene Laufwerke / Samba). Und ob es sich bei Deiner Version aufhängt oder ein Gerät nur nicht antwortet, weiß erst mal keiner. Reagiert denn das System, wenn Du versuchst, mit einem zweiten Gerät darauf zuzugreifen?


    Grüße, STF

    "And now for something completely different."


    Hofeis guide to: Wie frage ich nach Hilfe? *** Mein nagelneuer Raspberry Pi 3B+ zeigt nur ein buntes Bild. (Ab)Hilfe.

  • Hallo STF,


    mit meinem Win7 PC kann ich mit FileZilla auf das Fritz!NAS zugreifen und der manuelle Upload funzt.

    Bei meinem zweiten Raspi den ich mir zum Testen zulegte und mit Deiner Hilfe motionEyeOS installieren konnte liefert der FTP-Test auch

    Accessing the upload service succeeded!

    aber es findet, wie beim Wirk-Raspi mit motionEye ebenfalls kein Upload statt.


    Verstehe ich das richtig ? MotionEye sollte doch die erstellten Aufnahmen lokal unter /var/lib/motioneye/Camera1/ und parallel auf dem Fritz!NAS speichern.



    Viele Grüße

    Ich Bins

  • mit meinem Win7 PC kann ich mit FileZilla auf das Fritz!NAS zugreifen und der manuelle Upload funzt.

    Wieviel Platz hast Du da noch drauf? Ist ein externer Speicher? Wenns voll ist, kommt keine Fehlermeldung von meOS hochgeploppt, die steht nur in der motioneye.log (Expert settings -> log Files)

    /var/lib/motioneye/Camera1/

    Dieses Verzeichnis gibts nicht unter meOS. /var/lib wird nach /data/varlib gelinkt, da drunter ist weder motioneye noch Camera1. Der eingestellte Pfad ist: /data/output/Camera1.


    Welchen Pfad hast Du für den ftp Zugang auf der Fritz!Box freigegeben? Kommt da sicher nichts an?

    Grüße, STF

    "And now for something completely different."


    Hofeis guide to: Wie frage ich nach Hilfe? *** Mein nagelneuer Raspberry Pi 3B+ zeigt nur ein buntes Bild. (Ab)Hilfe.

    Einmal editiert, zuletzt von STF ()

  • Es ist ein leerer neu NTFS formatierter 4 GB USB-Stick. Zuvor hatte ich ihn mit Fat32 formatiert aber funzte auch nicht.


    /var/lib/motioneye/Camera1/ erwähnte ich im Zusammenhang mit motionEye ohne OS.

    Welchen Pfad hast Du für den ftp Zugang auf der Fritz!Box freigegeben?

    Was meinst Du mit Freigabe, dieses Symbol das Ähnlichkeit mit < hat ?

    Diesen < habe ich erst jetzt gesetzt, Erfolg gleich null.


    In der Benutzerverwaltung der Fritz!Box steht:

    Momentan ist die Anmeldung bei Zugriff aus dem Heimnetz deaktiviert. Die angezeigten Benutzer gelten nur für den Zugriff aus dem Internet.


    Das Benutzerkonto hat die nachfolgenden Einstellungen mit lesen und schreiben.



  • Ich bin mir nicht sicher ob das auch für die Fritte selbst zutrifft, aber dürfen bei Dir WLAN-Geräte miteinander kommunizieren? Der WLAN-Stick am RPi ist doch noch aktuell oder? :denker:

    "Alles, was wir sind, ist Sand im Wind, Hoschi."

  • Ich beschränke WLan-Geräte über den MAC-Adressfilter, die zugelassenen WLAN-Geräte dürfen miteinander kommunizieren. Mit der gleichen Hardware hat der Upload im März noch gefunzt, siehe ftp-verbindung-konfigurieren-bei-motioneye-ftp-server-und-fritzbox-7390. Am 21. Mai musste ich das Betriebssystem und die Anwendungen neu installieren, weil mein Raspi wegen einem fehlerhaften Eintrag in der Datei /etc/fstab nicht mehr booten wollte. Du erinnerst Dich, ich experimentierte und kannte den Parameter nofail noch nicht.

  • Ach ja, stimmt, da klingelt was bei mir! Sorry, ich leide manchmal an Forendemenz! :dau1: Da sind auf die Dauer auch eine Menge an Beiträgen zu lesen, dadurch merkt man sich (leider) nicht alles... ;)

    "Alles, was wir sind, ist Sand im Wind, Hoschi."

  • Nur so ein Verdacht. Als im März der Upload zum NAS noch klappe hatte ich das 2017-11-29-raspbian-stretch.img installiert. Nachdem ich im Mai neu aufsetzen musste liefert nun

    uname -a

    Linux Hostname 4.14.34-v7+ #1110 SMP Mon Apr 16 15:18:51 BST 2018 armv7l GNU/Linux


    Ich habe hier schon gelesen, dass sich im neuen Release vom April ein paar Verschlimmbesserungen befinden siehe:

    neues stretch Release date: 2018-04-18 schmiert andauernd ab bei x11vnc

    Und hier besonders

    jar schrieb:

    kann auf dem NAS nur noch über Umwege löschen

  • Release vom April ein paar Verschlimmbesserungen befinden siehe:

    neues stretch Release date: 2018-04-18 schmiert andauernd ab bei x11vnc

    Und hier besonders

    ...

    Das Benutzerkonto hat die nachfolgenden Einstellungen mit lesen und schreiben.

    Ok, das mag sein, dass dem guten jar ein paar Sachen nicht gefallen. Nur haben die allesamt nichts mit Deinen Fehlern zu tun. x11vnc ist immer schon Murks und das NAS per samba erreichbar. Beides nutzt Du nicht.


    Wenn der Upload nicht funktioniert (wiegesagt, bei meinem aktuellen motioneyeOS geht das problemlos über ftp auf die Fritz!Box), dann mach doch mal ein manuelles Bild (rechts unten auf dem Vollbild das Symbol) und sieh danach in die log Dateien. Dort muss dann drinstehen, warum es nicht funktioniert hat.


    Die Berechtigungen des ftp Zuganges sind nicht erkennbar, kannste das nochmal machen? Und dann stört mich der Satz:


    Momentan ist die Anmeldung bei Zugriff aus dem Heimnetz deaktiviert. Die angezeigten Benutzer gelten nur für den Zugriff aus dem Internet.


    Das sieht jetzt schon danach aus, als das Du die Fritz!Box nicht richtig konfiguriert hast. Das muss ich mal testen.


    Grüße, STF

    "And now for something completely different."


    Hofeis guide to: Wie frage ich nach Hilfe? *** Mein nagelneuer Raspberry Pi 3B+ zeigt nur ein buntes Bild. (Ab)Hilfe.

    2 Mal editiert, zuletzt von STF ()

  • Momentan ist die Anmeldung bei Zugriff aus dem Heimnetz deaktiviert. Die angezeigten Benutzer gelten nur für den Zugriff aus dem Internet.


    Diese Statusinformation wird angezeigt, wenn als Anmeldeverfahren im Heimnetz die Einstellung "Anmeldung mit dem FRITZ!Box-Kennwort" bzw. "Keine Anmeldung" aktiviert ist.

    :denker:


    Dazu habe ich noch das hier gefunden: https://service.avm.de/help/de…011/hilfe_system_kennwort

    "Alles, was wir sind, ist Sand im Wind, Hoschi."

  • Die angezeigten Benutzer gelten nur für den Zugriff aus dem Internet.

    Den Teil meinte ich. Das geht aus der AVM Anleitung (zumindest beim querlesen) nicht hervor, was das genau bedeutet. Allerdings hab ich in meiner FB die Nutzeranmeldung aktiviert.

    "And now for something completely different."


    Hofeis guide to: Wie frage ich nach Hilfe? *** Mein nagelneuer Raspberry Pi 3B+ zeigt nur ein buntes Bild. (Ab)Hilfe.