MotionEye installieren

  • Meine bisherige Einstellung unter "Anmeldung im Heimnetz" waren.


    Anmeldung mit dem FRITZ!Box-Kennwort

    Jetzt habe ich einen neuen Benutzer angelegt (ich wollte weder dem FtpUser noch dem myFritzUser diese Eigenschaften geben) und

    Anmeldung mit FRITZ!Box-Benutzernamen und Kennwort

    gewählt. Nun ist der Hinweis

    Momentan ist die Anmeldung bei Zugriff aus dem Heimnetz deaktiviert. Die angezeigten Benutzer gelten nur für den Zugriff aus dem Internet.weg. Auf dem NAS kommt aber noch immer nichts an.


    Danach macht ich einen Test mit motionEyeOS und öffnete motioneye.log

    Die letzten Einträge waren:


    Code
    1. File "/usr/lib/python2.7/site-packages/motioneye/uploadservices.py", line 875, in upload_media_file
    2. File "/usr/lib/python2.7/site-packages/motioneye/uploadservices.py", line 75, in upload_file
    3. Exception: failed to open file "/data/output/Camera1/2018-06-15/2018-06-15": [Errno 2] No such file or directory: '/data/output/Camera1/2018-06-15/2018-06-15'
    4. 2018-06-15 08:06:12: [motioneye] ERROR: failed to create movie preview for /data/output/Camera1/2018-06-15/2018-06-15: Command '[u'ffmpeg', u'-i', u'/data/output/Camera1/2018-06-15/2018-06-15', u'-f', u'mjpeg', u'-vframes', u'1', u'-ss', u'4', u'-y', u'/data/output/Camera1/2018-06-15/2018-06-15.thumb']' returned non-zero exit status 1
    5. 2018-06-15 08:06:12: [motioneye] ERROR: ftp: failed to open file "/data/output/Camera1/2018-06-15/2018-06-15": [Errno 2] No such file or directory: '/data/output/Camera1/2018-06-15/2018-06-15'
    6. 2018-06-15 08:06:12: [motioneye] ERROR: failed to upload file "/data/output/Camera1/2018-06-15/2018-06-15" with service ftp: failed to open file "/data/output/Camera1/2018-06-15/2018-06-15": [Errno 2] No such file or directory: '/data/output/Camera1/2018-06-15/2018-06-15'
    7. Traceback (most recent call last):
    8. File "/usr/lib/python2.7/site-packages/motioneye/uploadservices.py", line 875, in upload_media_file
    9. File "/usr/lib/python2.7/site-packages/motioneye/uploadservices.py", line 75, in upload_file
    10. Exception: failed to open file "/data/output/Camera1/2018-06-15/2018-06-15": [Errno 2] No such file or directory: '/data/output/Camera1/2018-06-15/2018-06-15'

    Esfällt mir auf, dass die Uhr ca. 65 min nach geht. Wie kann man das in motionEyeOS korrigieren ?

    Die Fehlermeldung No such file or directory: '/data/output/Camera1/2018-06-15/2018-06-15'

    könnte daran liegen, dass dieser Pfad als Root Directoty vorgegeben war. 

    Die Fotos liegen jedoch im Ordner /sdcard/camera1/2018-06-15 zumindest sehe ich das mit FileZilla.

  • Nachdem ich in motionEyeOS den Pfad auf /sdcard/Camera1 gewechselt habe erhalte ich nachfolgende Information im motioneye.log

  • /data/output/Camera1/2018-06-15/2018-06-15

    Da stimmt was nicht. Ich habe im Moment absolut keine Ahnung, wie das kommen kann, aber das Verzeichnis im Verzeichnis ist falsch. In einem Verzeichnis mit dem aktuellen Datum finden sich die angelegten Bilder und Videos, das sieht dann z.B, so aus: /data/output/Camera1/2018-06-15/13-28-37.jpg Dass nichts hochgeladen wird, liegt schlicht und ergreifend daran, dass die Dateien nicht gefunden werden.


    Zitat

    Exception: failed to open file "/data/output/Camera1/2018-06-15/2018-06-15": [Errno 2] No such file or directory: '/data/output/Camera1/2018-06-15/2018-06-15'


    Hast Du an irgendwelchen Konfigurationsdateien händisch was geändert?


    Die Fotos liegen jedoch im Ordner /sdcard/camera1/2018-06-15 zumindest sehe ich das mit FileZilla.

    ...

    Information im motioneye.log

    OSError: [Errno 30] Read-only file system: '/sdcard'

    Steht das irgendwo, dass Du das eintragen sollst? Mit Deinem Filezilla siehst Du doch "nur" die Freigabe. /sdcard gibt es so nicht und es würde versucht, auf dem System anzulegen - das ist aber read only (Infos hier). Und das sagt Dir das log auch.


    Esfällt mir auf, dass die Uhr ca. 65 min nach geht. Wie kann man das in motionEyeOS korrigieren ?

    Normalerweise holt sich das System die Uhrzeit aus dem Netz, warum funktioniert das nicht? Du könntest auch eine RTC installieren, siehe motionEyeOS Tweaks bzw. die Uhr per ssh und "date" stellen. Beim nächsten Reboot stimmts aber wieder nicht mehr.

    "And now for something completely different."


    Hofeis guide to: Wie frage ich nach Hilfe? *** Mein nagelneuer Raspberry Pi 3B+ zeigt nur ein buntes Bild. (Ab)Hilfe.

    2 Mal editiert, zuletzt von STF ()

  • Verzeichnis im Verzeichnis ist falsch

    Jetzt dämmerts, es liegt es an meiner Namensgebung für die Dateien.

    %Y-%m-%d/%Y-%m-%d %H-%M-%S

    Hatte bisher kein Ahnung, dass man in Linux keine Leerzeichen im Dateinamen verwenden sollte.

    Leerzeichen durch - ersetzt und schon kommen die Dateien im NAS an.

    Im Wirk-Raspi bei motionEye und im Test-Raspi (zwei SD-Karten, eine für motionEye und eine für motionEyeOS) hatte ich diese Namensgebung.

    Mit Deinem Filezilla siehst Du doch "nur" die Freigabe. /sdcard gibt es so nicht

    Bei motionEye ist im File Storage als Root Direktory /var/lib/motioneye/Camera1 voreingestellt. Genau unter diesem Pfad hole ich schon seit Wochen mit FileZilla bei meinem Wirk-Raspi (mit motionEye) die Dateien ab.


    Also lag es für mich nahe, dass es bei motionEyeOS auch der Pfad sein sollte den ich mit FileZilla sehe - war wohl ein Trugschluß.


    Dieses selbst verursachte Problem wäre somit gelöst.


    Vielen Dank für Eure Unterstützung.


    Wie schaffe ich es aber, dass die Dateien nur im NAS gespeichert werden ?

    Einmal editiert, zuletzt von Ich Bins ()

  • Hatte bisher kein Ahnung, dass man in Linux keine Leerzeichen im Dateinamen verwenden sollte.

    Das freut mich für Dich, dass es geht. Leerzeichen kannst Du natürlich verwenden, musst dies aber auf jeden Fall speziell beachten (Stichwort:escapen oder Anführungszeichen). Ich kenne allerdings kein OS, wo das nicht so wäre.


    Nur im NAS zu speichern wird auf jeden Fall gehen, wenn Du als Ziel das Network Share angibst (samba) oder Du mountest Dir das NAS irgendwohin und trägst den Pfad ein - das könnte ebenfalls funktionieren.


    Grüße, STF

    "And now for something completely different."


    Hofeis guide to: Wie frage ich nach Hilfe? *** Mein nagelneuer Raspberry Pi 3B+ zeigt nur ein buntes Bild. (Ab)Hilfe.

  • Nur im NAS zu speichern wird auf jeden Fall gehen, wenn Du als Ziel das Network Share angibst (samba)

    Was ich bisher über samba gelesen habe bezieht sich auf einen Linux-Speicher der für Windows-Systeme über das Netzwerk erreichbar ist.

    Müsste ich dazu Samba auf dem Raspi installieren und als Linux-Speicher das Fritz!NAS definieren ?


    Ich möchte ja erreichen, dass motionEye die Fotos und die Videos NICHT auf der SD-Karte speichert sondern über WLan auf dem Fritz!NAS.


    Du mountest Dir das NAS irgendwohin und trägst den Pfad ein

    Das könnte ich vermutlich mit Hilfe dieser Anleitung erreichen ?


    Das ganze Vorhaben wird jedoch scheitern, wenn mein WLan zu lahm ist.

  • Oder Du lässt gleich auf ein Network share (samba) speichern. Dazu musst Du nur die Zugangsdaten haben.

    ?thumbnail=1


    Versuch es doch erstmal damit. Den "1. Schritt: Vorbereitung auf AVM Fritz!Box" Deiner Anleitung musst Du aber trotzdem vorher befolgen.

    "Alles, was wir sind, ist Sand im Wind, Hoschi."

  • An meinen Wirk-Raspi im Nistkasten komme ich nicht dran, weil ich die Vögel nicht stören möchte.

    Im Wirk-Raspi ist kein motionEyeOS installiert sondern motionEye auf Raspbian Stretch.

    MotionEye hat jedoch nicht die Auswahlmöglichkeit Network Share unter File Storage sondern nur diese beiden.

     


    Ich verwende mom. noch motionEye 0.39. Es gibt bereits die Version 0.39.1, die wie vermutlich noch kein Nework Share enthält.


    Ist mein Vorhaben

    "MotionEye soll die Fotos und die Videos NICHT auf der SD-Karte im Raspi speichern, sondern nur über WLan auf dem Fritz!NAS"

    mit motionEye überhaupt zu realisieren ?

  • So jetzt, mit einem Tag Verspätung.

    Bei meinem Test-Raspi mit motionEye ohne OS ist es mir mit Hilfe dieser Anleitung gelungen das Fritz!NAS zu mounten.

    Wer dies nachvollziehen möchte sollte unbedingt darauf achten, in die Zeile der /etc/fstab nofail einzutragen.

    //192.168.178.1/FRITZ.NAS/STICK /home/user/NAS cifs credentials=/etc/samba/auth,uid=1000,gid=1000,nofail 0 0

    Gerade bei Netzwerk- oder USB-Medien-mounts ist der Parameter nofail imho einer der wichtigsten Parameter überhaupt. Man kann sich ja nie sicher sein, dass das Laufwerk (noch nicht) online oder angesteckt ist oder man sich vertippt hat und dann bootet das System eben nicht durch.


    Unter /home/user/NAS habe ich das Fritz!NAS eingehängt und als Pfad unter File Storage/Root Directory eingetragen.

    MotionEye im Test-Raspi speichert nun alle Aufnahmen über WLan im Fritz!NAS.


    Nach dieser erfolgreichen Aktion im Testbetrieb wagte ich diese Einstellungen an meinem Wirk-Raspi vorzunehmen.

    Nach dem Eintragen der Zugangsdaten in die /etc/samba/auth (warum werden die Zugangsdaten alternativ in die .smbcredentials eingetragen ?) hier auch erfolgte der Test ob das Einbinden des Fritz!NAS erfolgreich war.


    sudo mount -a lieferte jedoch

    mount error(112): Host is down ...... :conf:

    Was war nun schon wieder das Problem !

    Hier im Forum in dieser Unterhaltung konnte ich einen Lösungsansatz finden. Nachdem ich in die Wirk-fstab vers=1.0

    //192.168.178.1/FRITZ.NAS/STICK /home/user/NAS cifs vers=1.0,credentials=/etc/samba/auth,uid=1000,gid=1000,nofail 0 0

    eingetragen habe verlief der Test sudo mount -a erfolgreich.

    Nun habe ich geschaut welche Kernel in meinen Raspi drin sind.


    Wirk-Raspi

    sudo uname -a

    Linux hostname 4.14.34-v7+ #1110 SMP Mon Apr 16 15:18:51 BST 2018 armv7l GNU/Linux


    Test-Raspi

    sudo uname -a

    Linux hostname 4.9.59-v7+ #1047 SMP Sun Oct 29 12:19:23 GMT 2017 armv7l GNU/Linux


    Sagt mir als Linux Grünschnabel eigentlich nur, dass es unterschiedliche Kernel sind.


    Nach 12 Stunden Wirkbetrieb musste ich feststellen, dass sich motionEye ohne OS nach ca einer Stunde verabschiedet

    und keine Aufnahmen mehr macht.


    Dieses Problem kann ich kurzzeitig beheben, wenn ich motionEye stoppe und wieder starte.
    sudo systemctl stop motioneye

    sudo systemctl start motioneye

    nach dem letzten Starten von motionEye hielt das etwa 1 h 20. :(

    2 Mal editiert, zuletzt von Ich Bins ()

  • Zugangsdaten in die /etc/samba/auth (warum werden die Zugangsdaten alternativ in die .smbcredentials eingetragen ?)

    Das ist wohl je nach Anleitung unterschiedlich, .smbcredentials scheint gebräuchlicher zu sein). Du könntest sie natürlich auch direkt reinschreiben, doch dann kann die jeder lesen.

    motionEye ohne OS nach ca einer Stunde verabschiedet

    Danke, dass Du das so einfach machst. Hab ja schon ein paar Mal das "OS" rangedichtet. (: Sieh doch bitte mal in die logs, ob es irgendeine Fehlermeldung gibt. Mit motioneyeOS ist mir das noch nicht passiert. Ist "nur" das Kamerabild weg oder geht noch mehr nicht?


    Grüße, STF

    "And now for something completely different."


    Hofeis guide to: Wie frage ich nach Hilfe? *** Mein nagelneuer Raspberry Pi 3B+ zeigt nur ein buntes Bild. (Ab)Hilfe.

  • Hallo STF,


    Ist "nur" das Kamerabild weg oder geht noch mehr nicht?

    Leider werden, vermutlich ab diesem Zeitpunkt, auch keine Aufnahmen, weder Fotos noch Videos erstellt. Hinzu kommt, dass ca. zwei drittel der erstellten Videos defekt sind. Zum Abspielen der Videos verwende ich Irfanview. Bei defekten Videos erhalte ich die nachfolgende Fehlermeldung.

    Der VLC_Player kann diese Videos ebenfalls nicht abspielen.

    Abspielbare Videos sind ungewöhnlich kurz. Manche Fotos sind unvollständig.

    Vor der Übertragung der Aufnahmen auf das Fritz!NAS waren die lokal gespeicherten Videos und Fotos > o byte i.O. Ab und zu ist es lokal vorgekommen, dass Videos und Fotos mit 0 byte angelegt wurden.


    Laut der motionEye.conf werden die Logdateien unter /var/log gespeichert. Die motion.log mit 10 Zeilen ist vorhanden. Müsste es da nicht auch eine motionEye.log existieren ?

    Habe versucht auf Basis

    sudo journalctl -u motioneye > motioneye.log

    eine motionEye.log zu erstellen, konnte aber nach einen halben Stunde noch keine finden.


    Vll. ist die WLan-Übertragungsgeschwindigkeit zu langsam um life die Dateien auf dem NAS anzulegen. Ist es möglich die Dateien erst im Arbeitsspeicher zu erstellen und dann auf dem NAS zu speichern

    Bei Windows kann man einen virtuellen Arbeitsspeicher erstellen. Kann man das auch mit Raspbian ?