Nach Wechsel auf Rasbian stretch werden Perl Programme im Apache Webserver nicht mehr ausgeführt

  • Hallo,


    auf meinem Raspberry habe ich raspbian-wheezy durch raspbian-stretch ersetzt. Allerdings zeigt der Apache Webserver seit dem Update Perl Programme an, anstatt sie auszuführen.

    Die Perl Programme sind in Ordnung, sie laufen auf openSUSE, Bodhi-Linux und Raspian Wheezy.

    mod-perl ist installiert,

    Options +ExecCGI gesetzt,

    AddHandler cgi-script .pl gesetzt

    Die Pfade stimmen, das Perl Programm wird ja zum Download angeboten.

    Rechte der Perl-Programme stehen auf -rwxr-xr-x

    Und trotzdem funktioniert es nicht. Ich hoffe, jemand hat eine Idee, woran der Fehler liegen könnte.


    Version:
    Raspbian Stretch with desktop

    Version: April 2018
    Release date: 2018-04-18
    Kernel version: 4.14

    Apache Version:

    Server Version: Apache/2.4.25 (Raspian)

    Server built: 2018-03-31T08:47:16


    Hier meine Einstellungen:

    /etc/hosts

    Code
    1. radius@Dione:/etc $ cat hosts
    2. 127.0.0.1 localhost
    3. ::1 localhost ip6-localhost ip6-loopback
    4. ff02::1 ip6-allnodes
    5. ff02::2 ip6-allrouters
    6. 127.0.1.1 Dione testvh

    Hier die aktiven Einstellungen von apache2.conf, die entsprechen der Original Installation


    Hier die conf-enabled, die entsprechen der Original Installation

    Code
    1. radius@Dione:/etc/apache2 $ ls -l conf-enabled/ # Original Installation
    2. insgesamt 0
    3. lrwxrwxrwx 1 root root 30 Mai 28 17:40 charset.conf -> ../conf-available/charset.conf
    4. lrwxrwxrwx 1 root root 44 Mai 28 17:40 localized-error-pages.conf -> ../conf-available/localized-error-pages.conf
    5. lrwxrwxrwx 1 root root 46 Mai 28 17:40 other-vhosts-access-log.conf -> ../conf-available/other-vhosts-access-log.conf
    6. lrwxrwxrwx 1 root root 31 Mai 28 17:40 security.conf -> ../conf-available/security.conf
    7. lrwxrwxrwx 1 root root 36 Mai 28 17:40 serve-cgi-bin.conf -> ../conf-available/serve-cgi-bin.conf

    Hier die mods-enabled, Original Installation plus mod-perl und mod-zembperl

    Hier die Einstellung für den Virtual Host

    Grüße

    Radius

  • Hallo Zentris, danke für den Hinweis.


    lighttpd scheint auch virtual hosts zu unterstützen. Allerdings fehlt mir momentan die Zeit mich in ein anderes System einzuarbeiten (Habe den Anspruch, ein System einigermaßen zu verstehen).

    Bis Monatsende sollte perl möglichst mit dem Apache laufen. Notfalls installiere ich halt wieder den Backup des wheezy.


    Grüße

    Radius

  • Hallo fred0815,


    ich bin mir nicht sicher ob ich deine Frage richtig interpretiere.

    Code
    1. $ sudo a2enmod perl
    2. $ Module perl aready enabled
    3. $ echo $?
    4. $ 0

    Einmal editiert, zuletzt von Radius ()

  • Hallo,


    zu meiner Überraschung funktioniert perl, wenn ich nach dem Start des Raspberry ein "sudo systemctl restart apache2" ausführe.

    An den Konfigfiles ist nichts geändert. Das Verhalten ist reproduzierbar.

  • Hallo Radius,


    zeig mal bitte direkt nach einem Neustart, also dann wenn es nicht funktioniert, die Ausgabe von sudo systemctl status apache2! :denker:

    "Alles, was wir sind, ist Sand im Wind, Hoschi."

  • Hallo,


    hier die Ausgabe

    Grüße

    Radius

  • Hallo,


    ich habe mir überlegt, dass der Fehler dadurch zustande kommen könnte, dass der Apache schneller startet als das Netzwerk.

    Deshalb habe ich in /etc/init.d/apache2 ein "sleep 5" eingebaut.

    Hat leider nichts gebracht, der Fehler tritt immer noch auf und verschwindet erst mit dem Neustart des Apache.


    Grüße

    Radius