Servo über PWM - Unerklärliches Verhalten

  • So!


    Läuft jetzt! Endlich.

    Angeschlossen ist der Servo nun über einen 1kOhm Vorwiderstand. Die shottky-diode ist auch noch wie bereits beschrieben angeschlossen.

    Über die Versorgungsspannung hab ich nun auch noch den 1000uF Kondensator geschalten, der tatsächlich einen deutlich spürbaren positiven Effekt hat.

    So lief der Motor schon mit meinem Netzteil durchaus "akzeptabel". Hat noch etwas gestottert bei zu großen Winkeldifferenzen aber man merkte einen Besserung.

    Mit dem Labornetzteil lief er aber jetzt endlich richtig rund! Hab ich ihn von -135° auf die 135° gestellt (also die vollen 270° die der Motor drehen kann) dann drehte er sofort und mit voller Power los. Am Labornetzteil ist der Strom auf etwa 1,1 - 1,3A gestiegen. Am Oszilator waren dann auch keine negativen Einbrüche mehr sichtbar. Das Signal hat stattdessen kurz einen kleinen Sprung gemacht und ist dann wieder runter auf "normal" gegangen.

    Damit lässt sich also wohl schlussendlich das Netzteil und der fehlende Vorwiderstand als Hauptursache festlegen. Der Kondensator ist allerdings auch 'ne super Sache.


    Ich bedanke mich herzlich bei Allen, die tatkräftig gerätselt haben.

    Ich habe sehr viel hierbei von euch gelernt :)

  • Freut mich, dass es geht. Also das mit dem Transistor verstehe ich absolut nicht. Am Foto kann ich es nicht 100%ig sagen. Man müsste noch nachsehen, ob Emitter tatsächlich direkt auf Masse geht - aber eure Messwerte (0,9V / hoher Strom) deuten tatsächlich darauf hin.

    Ich würde mich ggf. nach einem anderen Servo umsehen - den Hersteller wird es wohl nicht lange geben - bei dem Murx den der offensichtlich herstellt...


    Ach ja, jetzt könntest Du noch ein Hakerl bei Erledigt rein machen...

    ...wenn Software nicht so hard-ware ;-) ...

    Freue mich über jeden like :thumbup:

  • Und mich freut das erst. Hat uns jetzt unglaublich lange aufgehalten.

    Beim nächsten mal werd ich wohl wirklich nen anderen Hersteller bevorzugen. Wobei ich eigentlich gedacht habe, dass man ein vernünftiges Produkt bei kanpp 20€ bekommt. Die meisten anderen Servos sind da, so wie ich es gesehen habe, deutlich günstiger. Aber was solls. jetzt läuft er ja gut. Für dieses Projekt taugt er also vorerst durchaus.