Raspberry Pi3B+ startet nicht, Regenbogen und gelber Blitz werden angezeigt

  • Stand: 2018-07-20


    Seit dem Erscheinen des neuesten Raspberry Pi 3B+ mit neuem SoC, LAN und WLAN Chips am 14.März 2018, häufen sich Meldungen über "Startprobleme". Diese äußern sich immer mit der Darstellung eines farbigen splash screens (Regenbogenbild) sowie je nach verwendetem System dem evt. erscheinen eines gelben Blitzes in der rechten oberen Bildschirmecke. Dazu blinkt die grüne oder rote LED regelmäßig (z.B. immer im Wechsel 4 x langsam, 4 x schnell) oder leuchtet permanent. Eine Erklärung der Blinkcodes findet sich z.B. hier.


    Schließt man tatsächliche Probleme der Stromversorgung durch die Verwendung des von der Raspberry Pi Foundation empfohlenen Netzteils aus, dann ist der Grund immer in der Verwendung eines zu alten Betriebssystems zu suchen. In der Hauptsache kann nach bootcode.bin und start*.elf der Kernel nicht geladen werden, daher stoppt die Verarbeitung.


    Nachfolgend also der Versuch einer Übersicht, welche Systeme (auch spezialisierte Distributionen) zum derzeitigen Zeitpunkt (s.o.) auch auf dem Raspberry Pi 3B+ verwendet werden können.

    System
    Pi0(W)
    Pi1(B) Pi2B Pi3B Pi3B+ Pi 3B+ ab V.X/Datum Anmerkungen
    Raspbian stretch
    (with desktop / lite)
    x x x x x Raspbian stretch ab Version 13.3.2018
    - ältere stretch (vor dem ang. Datum), alle jessie und wheezy Versionen starten nicht mit den originalen Downloads
    NOOBS (LITE)* 
    x x x x x ab Version 13.3.2018
    - der Loader stellt nur Systeme zur Installation zur Verfügung, die auch auf dem System laufen
    Arch Linux ARM x x x x -
    CentOS - - x x x - 32 / 64 Bit Versionen vorhanden
    DietPi x x x x x - alle RPi Versionen werden unterstützt
    Fedora Workstation
    -
    -
    x
    x
    x
    - ab F28
    Gentoo on RPi3 64Bit
    - - - x x - (inoffizielles) Image für RPi3B(+) und Pi-Top
    home-assistant.io (x) (x) (x) x (x) - alternative Installation erforderlich
    - Home Assistant Hausautomation
    Kali Linux
    x
    x
    x
    x
    x - ab 2018.2
    - spezielle Images für die verschiedenen RPi Versionen
    Kerberos.io
    x
    x
    x
    x
    x
    - spezielles System zur Videoüberwachung
    LibreElec
    x
    x
    x
    x
    x
    - spezielle Images für Pi0(W)/Pi und Pi2B/Pi3B(+)
    max2play x x x x x
    moodeaudio x x x x x - lt. Homepage nur mit Version vom 13.3.2018 kompatibel
    MotionEyeOS x x x x x
    ab Version 20180401 - spezielles System zur Videoüberwachung
    OpenElec x x x x - - spezielle Images für Pi0(W)/Pi und Pi2B/Pi3B
    - Weiterentwicklung fraglich
    openhabian (x) (x) x x x - Pi2B oder neuer empfohlen
    OSMC x x x x x
    Parrot
    - - x x - - spezielle Builds für RPi 2/3 und andere Einplatinenrechner verfügbar
    RaspArch - - x x x - Arch Linux Anpassung
    recalbox x x x x - - Unterstützung in Arbeit
    - spezielle Images für Pi0/1 - Pi2 - Pi3
    retropi x x x x x - spezielle Images für Pi0/1 und Pi2/3
    SparkyLinux - - x x -
    Suse Linux Enterprise Server for ARM
    - - - x - - spezielles Image nur für RPi3B
    Ubuntu mate 16.04/
    snappy Ubuntu core
    - - x x -
    Volumio x x x x x
    Windows 10 IoT Core - - x x (x) - es gibt einen inoffizellen Workaround


    *) NOOBS ist selbst kein eigenständiges Betriebssystem, sondern ein Starter für mehrere Systeme auf einer SD-Karte

    "And now for something completely different."


    Hofeis guide to: Wie frage ich nach Hilfe? *** Mein nagelneuer Raspberry Pi 3B+ zeigt nur ein buntes Bild. (Ab)Hilfe.

    21 Mal editiert, zuletzt von STF () aus folgendem Grund: - aktualisiert

  • Ich habe versucht Mate zu benutzen erst mit einem Netzteil 2,5 A ohne Reaktion auf dem Bildschirm. Dann mit einem 3 A dort kam nur der Regenbogen mit Blitz. :@:cursing: Zu wenig Strom!!!

    Mit dem Betriebssystem Stretch läuft es zwar, aber macht mal Google Maps auf, das kriecht so vor sich hin. Und die Daten Übertragung ist lässt auch zu wünschen übrig egal ob mit WLAN oder LAN. Ich habe eine 50000 Leitung.

    Meine Meinung läuft der RASPI 3 besser und schneller.

  • Hallo Detlev, zum Thema 🌈 würde ich Dir empfehlen, den ersten Beitrag zu lesen. Achso, wie war jetzt gleich nochmal Deine Frage? Dafür dann bitte ein *eigenes* Thema eröffnen.


    Grüße, STF

    "And now for something completely different."


    Hofeis guide to: Wie frage ich nach Hilfe? *** Mein nagelneuer Raspberry Pi 3B+ zeigt nur ein buntes Bild. (Ab)Hilfe.

  • Ich habe versucht Mate zu benutzen erst mit einem Netzteil 2,5 A ohne Reaktion auf dem Bildschirm. Dann mit einem 3 A dort kam nur der Regenbogen mit Blitz. :@:cursing: Zu wenig Strom!!!

    nein, eher zu geringe Spannung.

    Welches sind deine Netzteile, nicht Ladenetzteile!!!

    Übersetzungen zu Donald Trump:
    Mexikanisch -> El Trump
    Deutsch -> Trampel

    ----------------------------------------------------


  • Wieso wird das weiterhin so ausgeliefert??! Wieso gibt es nicht mal einen Hinweis? Noch nicht mal auf der offiziellen Seite, wo man das Betriebssystem runterlädt?!

    Wieviel tausende Stunden Arbeitszeit da verballert und in Frust umgewandelt werden. Das Image, das ich verwenden möchte geht natürlich nicht - kann’s einfach nicht glauben! :cursing::cursing::cursing::cursing::cursing::cursing::cursing::cursing::cursing::thumbdown: Hoffe ich kann es ohne Probleme wieder zurückgeben, aber jetzt hab ich schon heatsinks drauf und maaaan, kann doch nicht sein, dass Mann das so in Produktion gibt?! Glaub kaum, das sind das vorher niemandem aufgefallen ist!


    Ausserdem zeigt er den Blitz auch bei noobs an! Wieso ist da oben ein Kreuz auf der Liste?


    So sauer und gefrustet!

  • Hallo Pooopsi ,


    herzlich Willkommen hier im Forum.


    Jetzt hol erst mal tief Luft.


    Was genau ist denn Deine Frage? Ich habe doch nur alle (verfügbaren) Informationen an einer Stelle zusammengetragen. Wie ich schrieb, besteht *durchaus* ein Unterschied, ob nur Blitz und Regenbogenbild angezeigt wird oder der RPi läuft und zeigt dann den Blitz an.


    Also, wenn Du Dich wieder beruhigt hast, was geht denn (nicht) so, wie Du es Dir vorgestellt hast?


    Grüße, STF

    "And now for something completely different."


    Hofeis guide to: Wie frage ich nach Hilfe? *** Mein nagelneuer Raspberry Pi 3B+ zeigt nur ein buntes Bild. (Ab)Hilfe.

    Einmal editiert, zuletzt von STF ()

  • Auch wenn die Erstinbetriebnahme eines RPi für Neulinge nicht allzu schwer sein sollte, ein gewisses Grundwissen in Elektrik und Elektronik sollte man schon mitbringen:

    Wenn ein Rechner mit zu wenig Strom und/oder zu wenig Spannung versorgt wird, laufen eben alle Prozesse instabil bis gar nicht. Und das fängt schon beim Booten an, da dort beim Laden der ganzen Treiber zunächst mit 100% CPU-Leistung gefahren wird. Die Problematik mit unzurechenden Netzteilen (Handyladegeräte) wird hier im Forum gerne mit dem Begriff Mysterium umschrieben. (: Einfach mal die Foren-Suchfunktion anwerfen...


    Ebenso wichtig ist, das Image richtig auf die SD-Karte zu kopieren. Unter Windows läuft das mit win32diskimager, unter Linux mit dd. Außer NOOBS, das kann direkt auf die FAT32-Partition einer SDHC-Karte (max. 32GB) kopiert werden. SDXC-Karten mit >=64GB sind werkseitig mit dem Dateisystem (dr)exFAT vorformatiert. Das kann der Broadcom-SoC des RPi beim Bootvorgang nicht lesen.:baeh2:

    Und bei der Installation des Win10IoT-Images von M$ läuft's wie immer anders, als bei allen anderen Betriebssystemen... :stumm: 


    Pooopsi , so wie Du Deinen Frust beschreibst, trifft bei Dir eine Missachtung von mindestens einem, aber wahrscheinlich eher beiden Punkten zu...:conf:

    Der RPi ist schon ein Projekt für etwas ambitioniertere Bastler, die Klickibunti-Kiddies sollten eher die Finger davon lassen und bei ihren proprietären Sticks, Tablets etc. bleiben. Sorry STF , aber das war jetzt mein Frust...

  • Der RPi ist schon ein Projekt für etwas ambitioniertere Bastler, die Klickibunti-Kiddies sollten eher die Finger davon lassen und bei ihren proprietären Sticks, Tablets etc. bleiben.

    Dann lernen sie aber nicht dazu. Der Raspi ist gerade dafür konzipiert und lädt gerade solche Menschen auch dazu ein, über ihren Horizont zu blicken.

    Also, nicht verzagen, forum-raspberrypi.de fragen. ;)


    Pooopsi, bist am Zug. Fragen wurden dir ja gestellt.

    Übersetzungen zu Donald Trump:
    Mexikanisch -> El Trump
    Deutsch -> Trampel

    ----------------------------------------------------


  • flyppo , Du hast ja völlig recht, aber wenn jemand so unreflektiert jammert, dass alles shice sei und dabei über seine eigenen Fehler derart geflissentlich hinweg sieht, platzt selbst mir mal der Kragen.

    Aber bevor irgendetwas läuft, erst mal Kühlbleche draufpicken: Auch das steht nirgendwo auf der Internetseite der Foundation, auf die er sich ja (zumindest bezüglich des offiziellen Netzteils) beruft.


    Pooopsi , eat this: <°)))<

  • Hmm, Sorry wenn ich euch damit jetzt persönlich beleidigt haben sollte. ;) ...mal ehrlich: 2018 und mit was für Zeugs man sich immer noch rumärgern muss?! Wo ist die versprochene Zukunft von gestern?! -wieso kann man solche Probleme nicht einfach mal mit Pusten lösen, wie damals beim NES?!


    Also , das Netzteil hat 2,5a. Mit 2a powerbank geht’s auch nicht... jedenfalls nicht das Image das ich bräuchte! - aber ich bin auch nicht der einzige dem es so geht! Frag mich einfach wieso darauf nicht hingewiesen wird, dass das scheinbar nicht abwärtskompatibel ist. (Wie beim Gameboy! ;) )


    Hab versucht die Sd von meinem alten raspi zu nehmen auf dem ich die drifclub.cc Software installiert hatte, ziemlich geile mobile silent Disco die über den Hotspot läuft. - aber die funktioniert leider nicht, was schon echt doof ist, weil ein Event ansteht bei dem das funktionieren muss.


    noobs ausprobiert, aber da kommt der Blitz.

    (tatsächlich läuft wundersamer Weise eine alte sd Karte auf der max2play installiert war, also scheint es ganz sicher nicht am Netzteil zu liegen.)


    Hab die as Karte wie beschrieben mit Sd-Card-formatter /overwrite Formatiert -> auf dem 3B+ ging’s nicht, auf dem 3B schon.


    Mein Ziel war es eigentlich PureData /PurrData darauf zum laufen zu bringen und über mein arduino anzustubbsen um eine ziemlich abgefahrene Installation damit upzugraden, aber auch das ist für ein klickibuntikind wie mich nicht grade ein Kinderspiel.

    Bin grade dabei es jetzt einfach auch meinem alten 3B zu versuchen.


    Ach so, der alte Gameboytrick mit gegen die Wand werfen hat auch nicht funktioniert.

  • Sorry Pooopsi , aber ehrlich gesagt lese ich viel "bla bla" ohne konkrete Aussage. Du schreibst mein favorisiertes OS läuft nicht, alles Scheiße usw. ohne das OS konkret zu nennen oder sollte ich das tatsächlich überlesen haben? :-/


    Falls dem nicht so ist, dann... Wie sag ich das am besten diplomatisch :conf: Bla blub, heiße Luft und coole Sprüche hatte wir schon öfter hier, das ist einfach nur albern. :shy: Damit gewinnt man hier keinen Blumentopf.


    BTW: Anfragen haben hier im Tutorial-Bereich nichts zu suchen! :richter: Eröffne bitte einen eigenen Thread im entsprechenden Forenbereich!

    "Alles, was wir sind, ist Sand im Wind, Hoschi."

  • Hi Pooopsi ,


    ich glaube, ich habe Dich unterschätzt und Dich aufgrund Deiner Äußerungen zunächst für einen Troll gehalten. Ich möchte mich bei Dir dafür entschuldigen. Denn anscheinend hast Du am RPi schon einiges probiert (Retro-Konsole, max2play, ...) und mit alten RPis zum Laufen gebracht und Du beschäftigst Dich auch mit dem Arduino :thumbup:


    Beim neuen RPi3B+ wurden etliche Chips in der Peripherie (z.B. der USB/WLAN-"Wandler" und andere) erneuert. Dafür bedarf es mitunter neuer Treiber, die eben auch erst erstellt werden müssen. Vom Hörensagen weiß ich, dass der RPi3B+ erst mit den neueren Versionen von Raspbian Stretch läuft. Da ist man wohl nur mit dem Image vom 18.04.2018 (oder neuer) auf der sicheren Seite.

    Bei allen anderen Betriebssystemen müssen softwareseitig ebenfalls erst neue Treiber/Kernelversionen nachgezogen werden, um den RPi3B+ vernünftig ansteuern zu können. Der RPi3B (ohne Plus) hingegen macht keine Zicken.


    Ich weiß auch, wie es sich anfühlt, wenn man für eine Veranstaltung etwas RPi-basierendes auf die Beine stellen will/soll und der Termin immer näher kommt, aber die Software dann nicht so will, wie man es sich vorstellt. Das hatte ich bei meinem yamuplay auch schon zweimal, nämlich immer wenn der Faschingswagen auf Fahrt geht.


    Also schildere mal, wie Dein (nicht funktionierender) Gesamtaufbau aussieht. ich vermute irgendwie so:

    * Offizielles Steckernetzteil von der Foundation (5V, 2,5A)

    * den neuesten RPi3B+

    * Peripherie???

    Je nachdem, welche Zusatzgeräte noch dranhängen, kann die Versorgung dann durchaus in die Knie gehen, zumal der RPi3B+ wirklich kein Energiesparwunder ist.

    Bei meinen ernsthaften Projekten (yamuplay, Raspiblaster, OSMC-Mediacenter) verwende ich immer fest eingebaute Netzteile (z.B. Meanwell 5V, 25W oder stärker) und habe damit keine Probleme


    Auch wichtig:

    Welche USB-Kabel verwendest Du? Da gibt's auch furchtbar dünne und gleichzeitig lange, die aufgrund ihres relativ hohen Widerstandes einen Spannungsabfall verursachen, so dass am RPi nur noch 4,6V (oder so) ankommen. Wenn das der Fall ist, hilft Dir das beste Netzteil nichts, weil der Flaschenhals (das Kabel) hinterm Netzteil sitzt.


    schlizbäda

  • Zitat

    Welche USB-Kabel verwendest Du? Da gibt's auch furchtbar dünne und gleichzeitig lange,

    Aus diesem Grund versorge ich meine Pi`s nur noch direkt mit mind. 0,75mm2-Kabel über die Pins an der GPIO-Leiste, seitdem habe ich keinen Blitz mehr gesehen.

    Der despotische Bierbaron sagt: Kein Support per PN ! :angel::wink:

  • Guten! Morgen.


    (Ich lass mal das nebensächliche, aber noch mal Sorry falls mein unsachdienlicher Frust hier zu noch mehr Zeitverlust für alle lesenden geführt hat!)


    Also, ich verwende ein 5V/2,5a Netzteil das zusammen mit einem kühlergehäuse kam, also extra für den Pi ausgelegt ist.

    Peripherie: usb Tastatur+Maus

    +HDMI zu VGA Konverter mit usb 5V Unterstützung, den ich aber separat mit strom versorgt habe (beim 3B) funktionoert es aber auch, wenn ich den direkt an den raspi anschließe.


    Das Gehäuse hat einen kleinen Lüfter der an den Pins angeschlossen war, aber den hab ich versuchsweise auch deaktiviert.


    Die anderen Sd Karten mit max2play und dem driftclub habe ich allerdings nicht selbst installiert.

    Jetzt aber zumindest mal mit noobs eine erfolgreiche installation auf dem 3B - kann also auch nicht daran liegen, dass ich die Karte falsch formatiert hätte.

    —> für Noobs ist das Noobs („for all models“) beim 3B+ also nicht geeignet, was scheinbar niemandem auf der offiziellen Seite aufgefallen ist, was ich mir eigentlich nicht vorstellen kann, da es viel zu viele mit dem gleichen Problem gibt, weshalb ich davon ausgehe, dass es bewusst nicht erwähnt wird. Und das kostet halt einfach mal richtig viel Zeit, wenn mans mal hochrechnet! Denke schon dass ein kleiner Hinweis seitens des Herstellers da angebracht wär!


    PureData habe ich (auf dem 3B) bisher leider auch noch nicht zum laufen bringen können.

  • Naja, NOOBS ist so eine Sache. STF hat auch hierzu einen detaillierten Thread verfasst. Das Problem bzw. Missverständnis ist, dass aufgrund der Namensgebung viele Neulinge meinen, NOOBS sei genau das Richtige für sie. Tatsächlich ist es aber kein eigenes Betriebssystem, sondern eher so etwas wie ein aufgemotzter Bootloader, mit dem man auswählen kann, welches Betriebssystem aus einer Liste (Raspbian, *ELEC und ein paar andere) man letztlich installieren/verwenden will. Da die Foundation aus dieser Liste (neben NOOBS) nur Raspbian selbst pflegt, haben sie auch keinen Einfluss darauf, in welchen anderen Betriebssystemen bereits eine (vollständige) Treiberunterstützung für neue Modelle wie den RPi3B+ enthalten ist.

    Das Video Setting up your Rasberry Pi with NOOBS ist allerdings wirklich alt. Da erscheinen in den Screenshots noch Systeme wie RaspBMC, ein Quasi-VorVorVorgänger von OSMC, der seit Ende 2015 (oder so) nicht mehr gepflegt wird...


    Da bei der Verwendung von NOOBS (nicht nur) aufgrund einer notwendigen aber abweichenden Partitionierung der SD-Karte bezüglich einer "nackten" Raspbian-Installation einige Kompatibilitätsprobleme im Detail entstehen (z.B. in den Konfigurationsdateien), ist die allgemeine Forumsmeinung hier eher, dass NOOBS eigentlich nur zur "schnellen" Evaluierung der unterschiedlichen Betriebssysteme taugt, nicht aber zum späteren intensiven Arbeiten. Gerade Anfänger erleben dann schnell, dass bestimmte in Tutorials genannte Punkte einfach nicht funktionieren und werfen den RPi (verständlicherweise) in die Ecke.


    Und da bin ich beim nächsten Punkt (aber das ist ein anderes Thema):

    Viele Tutorials sind mittlerweile leider veraltet, da sie ursprünglich für Raspbian Jessie oder bereits für Wheezy erstellt wurden. Aber gerade zum aktuellen Raspbian Stretch haben sich viele Details geändert (z.B. Bluetooth), so dass die alten Herangehensweisen einfach nicht mehr passen. Und manche Tutorials sind einfach schlecht.


    Verkabelung:

    Deine Variante hört sich eigentlich gut an. Die USB-Peripherie Tastatur+Maus dürfte nicht viel Leistung ziehen, ich betrachte dies als unproblematisch. Dennoch hat fred0815 recht, wenn er die Versorgung mit vernünftigen Litzen über die GPIO-Leiste vornimmt. Das mache ich im Übrigen auch so. Der HDMI/VGA-Konverter ist separat versorgt und bleibt außen vor (prinzipiell auch richtig). Den Lüfter würde ich generell auch separat versorgen, es sei denn, er enthält eine eigene Elektronik für die Regelung, ich kenne ihn nicht.

    Und ja, das offizielle RPi-Netzteil von der Foundation mit 5V/2,5A ist mittlerweile zumindest für den RPi3B+ mit max. 3A wohl tatsächlich etwas dürftig ausgelegt. Ich habe seit zwei Tagen einen RPi3B+ herumliegen und das offizielle RPi-Steckernetzteil und werde das demnächst auch mal im fliegenden Aufbau querchecken...


    Einen schönen Sonntag wünscht der schlizbäda

  • Ich glaube das Problem mit dem 3 B+ ist das es eigentlich ein 3 B ist der nur übertaktet ist. Denn wenn er über 70°C geht er auf 1,2 Hz runter. In dem Augenblick macht er erstmal nix. Bemerkt man wenn man Musikvideos laufen lässt.

    Wie kann man ihn von Anfang an runtertakten?

  • Wie kann man ihn von Anfang an runtertakten?

    Sollte so gehen wie hier beschrieben (Setzen von arm_freq in der config.txt):

    https://www.raspberrypi.org/do…onfig-txt/overclocking.md


    Ich habe ebenfalls bemerkt, dass der Pi 3 B+ auf 1.2 GHz drosselt, wenn er mit mehreren Threads gestresst wird. Ihn künstlich zu untertakten habe ich allerdings nicht für notwendig befunden, da mir "Aussetzer" beim Ändern der Frequenz nicht aufgefallen sind. Ich benutze den Pi 3 B+ allerdings auch nicht zum abspielen von Videos.

    Pi 3 B+ (mein erster Raspi)

  • Hallo MrToddsFriends,


    wenn Du ein Problem mit Deinem RPi hast, dann eröffne bitte einen eigenen Thread im entsprechenden Forenbereich!

    "Alles, was wir sind, ist Sand im Wind, Hoschi."